Closed Bug 1123501 Opened 5 years ago Closed 5 years ago

Opening links on a page does not always work

Categories

(Firefox for iOS :: Browser, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: st3fan, Assigned: bnicholson)

References

Details

Attachments

(1 file)

47 bytes, text/x-github-pull-request
st3fan
: review+
Details | Review
STR:

1) Start the app
2) In the location bar type: news y
3) Select the yahoo search (at the bottom)
4) In the yahoo search results page, select the Hacker News page

Expected: news.ycombinator.com loads
Actual: nothing happens
I was testing on an older build before the search providers landed. But the results with the most recent build as of today are the same.

Testing on an iPad Mini with iOS 8.1.2
I am not completely sure this is a Yahoo specific problem, but so far the only page where I have reliably reproduced this error is the search results page of https://search.yahoo.com.

In the WKWebViewDelegate nothing fires after clicking links on the search results page. Connecting the Safari Web Inspector does not show any errors.
On the Yahoo page the problem is the target="_blank". The problem is that we don't support it.

<a id="link-6"
  class="yschttl spt"
  href="http://r.search.yahoo.com/_ylt=A0LEV2FAt71UE9UAaO3BGOd_;_ylu=X3oDMTByZHI5MXByBHNlYwNzcgRwb3MDNgRjb2xvA2JmMQR2dGlkAw--/RV=2/RE=1421748161/RO=10/RU=https%3a%2f%2fnews.ycombinator.com%2fnews/RK=0/RS=Mj7Xa.PbPG6fsChGZgsaoYlkV4Y-"
  target="_blank"
  data-bk="5141.1">

We need to implement the WKUIDelegate and specifically the webView:createWebViewWithConfiguration:navigationAction: delegate method, which is called when a site requests a page to be opened in a popup or a new window. Will file a bug.
Depends on: 1123520
To be clear, not a Yahoo problem.
Depends on: 1124942
Attached file Pull request
Assignee: nobody → bnicholson
Status: NEW → ASSIGNED
Attachment #8553435 - Flags: review?(sarentz)
Attachment #8553435 - Flags: review?(sarentz) → review+
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1123402
Duplicate of this bug: 1123520
No longer depends on: 1123520
Depends on: 1125258
No longer depends on: 1124942
You need to log in before you can comment on or make changes to this bug.