html5 full screen video freezes as a black screen

RESOLVED DUPLICATE of bug 1120128

Status

()

Core
Audio/Video
P1
normal
RESOLVED DUPLICATE of bug 1120128
3 years ago
2 years ago

People

(Reporter: Marc Auslander, Unassigned)

Tracking

36 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(firefox36 fixed, firefox37+ fixed, firefox38+ fixed, firefox39+ fixed)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150114125146

Steps to reproduce:

Playing a long html5 video in full screen.  An example is 
https://www.youtube.com/watch?v=3ZCvyoxRXLQ

During playback I may navigate using the left right keys. This may not be relevant.


Actual results:

Sometimes - this is intermittent and not reproducible - the video goes through one or more stages of bad behavior.  Video stops, audio continue.  Can sometimes restart by using the back (left arrow) key.  Video flashes black multiple times and continues.

Eventually, screen goes black.  I am not sure if audio continues or not.  I must use the task manager to kill firefox to regain control.

I cannot verify with a clean profile since the occurrence is not reproducible nor common - maybe once a day or less.


Expected results:

Normal play.

Updated

3 years ago
Component: Untriaged → Video/Audio
Product: Firefox → Core
(Reporter)

Comment 1

3 years ago
Although I've reported this as related to full screen, I have no real evidence of that.  I always watch full screen so I can't in fact claim it would not happen otherwise.

Comment 2

3 years ago
I do have the same problem. Windows 7 64 bit with ATI Radeon HD 4350. FF 36 b5.
Seen on Youtube (embedded player, HTML 5)
Normal size playback works OK for all videos I tried.
When going full screen and waiting 60 to 120 seconds the video starts to freeze with interleaved black screens which makes the whole screen blink between the video and black several times per second. It is unusable. Pausing and resuming does not help. This is not a bandwidth issue.
If I look in the HTML5 video stats I see that there is less painted frames than presented frames.
It seems to happen when the video resolution is 1920x1080. Sound countinues OK during this time.
Example Video:  The first video on this page:
http://www.pixelistes.fr/blog/que-se-passe-til-quand-vous-pressez-le-declencheur/?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+LeJournalDuGeek+%28le+Journal+du+Geek%29&utm_content=Netvibes

Comment 3

3 years ago
Ben, is it reproducible very time on that webpage?
Flags: needinfo?(marcausl)

Comment 4

3 years ago
*every time
Flags: needinfo?(marcausl) → needinfo?(benoit.grange)

Comment 5

3 years ago
Yes. At least yesterday.
Note that it does not happen on my other portable PC with same version of FF but different HW.
Flags: needinfo?(benoit.grange)

Comment 6

3 years ago
As you're able to reproduce it and it seems to be a regression, could you install mozregression on your machine and find a regression range, please.
See http://mozilla.github.io/mozregression/ for details.
Keywords: regressionwindow-wanted

Comment 7

3 years ago
I will try to do it tomorrow night.
Note that the problem only happens after the player switches to full hd (1920x1080). If I force it to a lasser resolution it works fine.

Comment 8

3 years ago
BTW, disabling HW acceleration solves the problem on FF36b6

I did the regression and found:

56:59.48 LOG: MainThread Bisector INFO Last good revision: 63eace116946
56:59.48 LOG: MainThread Bisector INFO First bad revision: c9e1814d648d
56:59.48 LOG: MainThread Bisector INFO Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=63eace116946&tochange=c9e1814d648d

But the changelog does not seem to make sense to me... "Tom Schuster — Bug 949666 - Save last used upload dir with e10s. r=billm"

If I look into the whole day pushlog it seems that some items are clearly linked to video, but I can't make sense of all of them.

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5ba06e4f49e8&tochange=7ab92d922d19

Tell me if you need more testing.

Comment 9

3 years ago
Cannot reproduce the problem anymore on this video with version Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0 ID:20150223185154 CSet: 276fd03ae5ac
I still have intermittent issue on other videos.
I've reproduce this bug using the following environment:

FF 37.0b2
Build Id: 20150302192546
OS: Win 8 x64
Graphic adapter: AMD Radeon HD 5450

STR:

1. On Chrome start a video from any of the following sites www.twitch.tv , www.liveleak.com or www.youtube.com .
2. On Firefox start a video from youtube and set the resolution to 1080p.
3. Go to fullscreen.

Issue:
The videos is black or is swithching or is flickering from black to video.

Note:
I noticed this issue is Graphic Card related it seem to be reproducible mainly on ATI Radeon 4000+ and 5000+ .
Also I verified the regression window provided by Ben on comment 8 and it seems that is the correct. 

Based on this information I'm confirming the bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regressionwindow-wanted
Tracking MSE related issue.

ni rillian for prioritization.
status-firefox37: --- → affected
status-firefox38: --- → affected
status-firefox39: --- → affected
tracking-firefox37: --- → +
tracking-firefox38: --- → +
tracking-firefox39: --- → +
Flags: needinfo?(giles)
Tracking as an mse bug, since this is reproducible on 37b2 per comment #10. I'm suspicious though if the original reports were against release 36, which doesn't have MSE enabled. The browser would be getting normal html5 mp4 video (or possibly flash) in that case.

Sounds like a general issue with video driver contention or performance. Matt, what do you think?

There are some graphics and media related changes at the end of Ben's pushlog. Bug 1038031, bug 1094614, and bug 1101260, for example.
Blocks: 778617
Flags: needinfo?(giles) → needinfo?(matt.woodrow)
Priority: -- → P1
The root cause is the same as bug 1132321 and a machine is on it's way to Matt Woodrow with an AMD6450 graphics card.
Can you reproduce with bug 1120128 fixed on nightly?
Flags: needinfo?(marcausl)
(Reporter)

Comment 15

3 years ago
I no longer see this bug and have not for a while I'm running 37 Beta, and I'm on a Thinkpad 530 with Intel Graphics.
Flags: needinfo?(marcausl)
Closing as a duplicate.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1120128
Fixed by bug 1120128.
status-firefox36: --- → fixed
status-firefox37: affected → fixed
status-firefox38: affected → fixed
status-firefox39: affected → fixed
No longer blocks: 778617
Flags: needinfo?(matt.woodrow)
You need to log in before you can comment on or make changes to this bug.