Simplify add-on development process by building set of features into firefox & GCLI

RESOLVED DUPLICATE of bug 1152126

Status

()

Firefox
Developer Tools
RESOLVED DUPLICATE of bug 1152126
3 years ago
3 years ago

People

(Reporter: irakli, Assigned: irakli)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
- Allow mounting directory on a disk with SDK add-on loayout as an add-on.
- Pick up changes in the mounted directory on add-on reload (disable / enable).
- Allow exporting directory on a disk as an add-on (.xpi).
Assignee: nobody → rFobic
Blocks: 1071311
This seems like bug 1071311 + some changes to gcli which aren't explained, what is planned there?
Flags: needinfo?(rFobic)
Blocks: 1124290
(In reply to Erik Vold [:erikvold] (please needinfo? me) from comment #2)
> This seems like bug 1071311 + some changes to gcli which aren't explained,
> what is planned there?

There is no real relation here, other than it would be cool if this was build as an `sdk-feature`. The problem with `sdk-feature` is that it's whole platform that needs to be built and can easily take up the whole quarter.

This bug is about adding gcli commands demoed at during week in pdx:

addon mount
addon unmount
addon export
addon reload

By set of features I was mainly implying that this commands don't necessarily have to be bound to gcli and could be used separately from it.
Flags: needinfo?(rFobic)
Blocks: 1124294
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1152126
No longer blocks: 1124294
No longer blocks: 1124290
You need to log in before you can comment on or make changes to this bug.