Better inform link clickers when the link generator leaves the conversation

RESOLVED DUPLICATE of bug 1155112

Status

defect
P2
normal
Rank:
25
RESOLVED DUPLICATE of bug 1155112
5 years ago
4 years ago

People

(Reporter: RT, Unassigned)

Tracking

unspecified
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [UX])

User Story

When a link clicker is in a conversation and the link generator leaves it, it is not obvious enough to the link clicker what just happened.

We need better UX to inform the user more clearly:
- Someone left the room
- Your camera is still on
- You can decide to leave or just hang around.
No description provided.
User Story: (updated)
Whiteboard: [UX]
Sevaan, can you please take a look and comment here on what could be done?
Flags: needinfo?(sfranks)
Yes, it is confusing.

Current implementation: Link generator leaves the room and the link clicker's view reverts back to "You're the first one here" message: http://cl.ly/image/0T283x1u2C0i

Just changing that message should suffice. Matej, any suggestions?

If there is an account associated, can we use the link generator's name? e.g. "Sevaan has left the room."

If no account, I'm not sure how best to generalize here. "The conversation participant has left the room." maybe? Sounds a bit dry.
Flags: needinfo?(sfranks)
With NI to Matej now.
Flags: needinfo?(matej)
(In reply to Sevaan Franks [:sevaan] from comment #2)
> Yes, it is confusing.
> 
> Current implementation: Link generator leaves the room and the link
> clicker's view reverts back to "You're the first one here" message:
> http://cl.ly/image/0T283x1u2C0i
> 
> Just changing that message should suffice. Matej, any suggestions?
> 
> If there is an account associated, can we use the link generator's name?
> e.g. "Sevaan has left the room."
> 
> If no account, I'm not sure how best to generalize here. "The conversation
> participant has left the room." maybe? Sounds a bit dry.

Would "You're the only one here" fix it?

If we definitely want to add the message that someone has left, it could be "Someone left. You're the only one here."

And then "Someone" could become the person's name if they're signed in.
Flags: needinfo?(matej)
Thanks Matej.
The main concern here (see user story field) is that we fear that users won't realize that after someone left the room, they still share their camera. In typical call scenarios when the other peer hangs-up your line gets disconnected too.

Is there a way to make it more obvious to the user?
(In reply to Romain Testard [:RT] from comment #5)
> Thanks Matej.
> The main concern here (see user story field) is that we fear that users
> won't realize that after someone left the room, they still share their
> camera. In typical call scenarios when the other peer hangs-up your line
> gets disconnected too.
> 
> Is there a way to make it more obvious to the user?

Wouldn't the preview pane still show the person on camera? I'm also trying to figure out the benefit or value of this message.

I worry that it's going to turn into something really long. Maybe we could imply it without saying it explicitly. Something like one of the following:

Someone left, but your conversation is still active.

You're the only one here, but you can invite someone else.

You're the only one here. Would you like to leave the conversation?
This is to address link clicker scenarios so "You're the only one here, but you can invite someone else." would not apply.
"Someone left, but your conversation is still active." probably addresses it - I NI Arcadio to see what he thinks since he raised the issue.
Flags: needinfo?(alainez)
Note: we don't currently have a link-generators's name, at best we have their email address (which they may/may not have exposed previously to the user).

Also, the comments here seem to conflict with bug 1108053, can we close one or the other as a duplicate, so that we've only got one place we're trying to change things?
Flags: needinfo?(rtestard)
Duplicate of this bug: 1108053
OK, marked bug 1108053 as a duplicate of this one.
Flags: needinfo?(rtestard)
(In reply to Romain Testard [:RT] from comment #7)
> This is to address link clicker scenarios so "You're the only one here, but
> you can invite someone else." would not apply.
> "Someone left, but your conversation is still active." probably addresses it
> - I NI Arcadio to see what he thinks since he raised the issue.

This has happened to a few people I've used Hello with already. We leave the convo. Later on, while I'm working I'll notice my Hello icon is blue. When I click the active link I see the other persons active camera. This maybe because they switched to another tab or window or moved on to another app. There a lots of reason for why they may not know their camera is on. They also don't have a blue icon to warn them. 

The request here is to inform users that their conversation is finished and that they need to hang up. We should be able to detect the end a call and deliver a message specific to that action. 

Focusing on the "You're the first/only one here" message isn't enough, I think. 

Maybe there could be message that gives them an indirect way of hanging up:
"Click the "Leave" button and tell us what you think"

We will also need to focus on the Link clicker experience to drive for Firefox conversions. This request has been made in a separate bug and email.
Flags: needinfo?(alainez)
Rank: 25
Flags: firefox-backlog+
Priority: -- → P2
Depends on: 1138453
I think we should go farther than "better inform" and actually force clients (on both sides) to leave the room when the other participant does. And when this happens, the client can be put into a state where the rejoin is automatic if the other person rejoins (assuming you keep the relevant tab or conversation window open).
I'm not sure about the auto-rejoin - it feels a bit like remote controlling the camera of the other peer but maybe we can find a suitable UX.
I agree that forcing the link clciker to leave when the link generator leaves sounds appropriate. We can perhaps have a notification on the link clicker side (HTML5 notification) when the link generator joins back as a way to address this scenario?

Sevaan what do you think?
(In reply to Romain Testard [:RT] from comment #13)
> I'm not sure about the auto-rejoin - it feels a bit like remote controlling
> the camera of the other peer but maybe we can find a suitable UX.

To be clear, I meant this only for the case where you were kicked out of the room by the other person leaving and you were left in what is today the "room is empty" state. The idea being that if the other person is quickly rejoining (due to connectivity issues or because they had to adjust something), you also having to manually rejoin would be annoying. Maybe that is not such a problematic case - for call-based models, it is expected that if someone hangs up you will both need to re-engage.

(If we did do the auto-rejoin thing, we could have a timeout to ensure you can't be "auto-rejoined" after a long period of time.)
Redesign of finished conversation screen (WIP): http://cl.ly/image/1D001m462b2r

I'm slightly confused by this bug. I'm going to summarize m 

I think we're overthinking an issue here.

If a link clicker (LC) is in an active conversation and the link generator (LG) leaves, the LC automatically hangs up. If the LC's camera is active, it is fine, as they are not actually in the conversation. They have to click the join button to go back into the room. So even if the LG rejoins the conversation, he/she won't be able to see the LC.

If we want to mitigate a jumpy LC who thinks they are in an active conversation, we could put a black transparent overlay over their preview, much like we do in the conversation window in Firefox.

I don't think we need to hang up the LG when the LC leaves. It's the LG's room, and there is a clear conversation window open in the browser to indicate this to them. However, I just noticed the LG opens a new window, the conversation stays on the old window. I propose that the conversation window should be on all Firefox windows, so it is always clear to the LG that their camera is on.

I also don't think we need to inform LC's when the LG joins back at this stage in the product. This can be handled in the future with async chat, and I bet a lot of the time the current sharing of Hello links is already taking place over instant messaging (I'd love to see a study on this), where users can already say to each other when they are rejoining if they weren't able to before leaving the room.

Arcadio's issue is a different one: where the LC has joined the conversation, and then left the tab and forgotten about it. That is the only case where their camera could be left on and forgotten about. So this is largely an issue for non-FX browsers (after parity work) which makes it tougher to control. We could do a timed pop-up where if the user is in an active room for 5 minutes (arbitrary pick), then a pop-up forces the user back to the tab to inform them their camera is still on. Google Calendar snaps me back to it when I ask for a pop-up reminder.
Oops, didn't know how to start it and left a false start in there!
 
> I'm slightly confused by this bug. I'm going to summarize m
> I don't think we need to hang up the LG when the LC leaves. It's the LG's
> room, and there is a clear conversation window open in the browser to
> indicate this to them. However, I just noticed the LG opens a new window,
> the conversation stays on the old window. I propose that the conversation
> window should be on all Firefox windows, so it is always clear to the LG
> that their camera is on.

Wait, I see the issue with the LG (it may not be crystal clear to an LG that a conversation window open means they are in the room), and we have another bug for further thought on that here: Bug 1137197.
(In reply to Sevaan Franks [:sevaan] from comment #15)
> 
> If a link clicker (LC) is in an active conversation and the link generator
> (LG) leaves, the LC automatically hangs up. If the LC's camera is active, it
> is fine, as they are not actually in the conversation. They have to click
> the join button to go back into the room. So even if the LG rejoins the
> conversation, he/she won't be able to see the LC.
If LC is in an active conversation and the LG leaves, the LC does NOT automatically hang up, he currently stays in the conversation. This is exactly the issue we are trying to fix here.
Ah, I must have been looking at another tab open with an LC, as I did a test before typing that... Let's just hang 'em up. They can always click the join button again to get back in and wait for a reconnect if that is what they want.

Add a "Rejoin the conversation" button underneath the "You're the first one here" message (which I thought we had a bug to change, because it's not accurate).
Depends on: 1155112
I created bug 1155112 to follow-up with implementation on the link clicker side.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1155112
You need to log in before you can comment on or make changes to this bug.