Last Comment Bug 112555 - Palm HotSync conduit for address book / contacts
: Palm HotSync conduit for address book / contacts
Status: VERIFIED DUPLICATE of bug 164760
:
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Address Book & Contacts (show other bugs)
: Trunk
: x86 Windows XP
-- enhancement with 21 votes (vote)
: Future
Assigned To: racham
: Ninoschka Baca
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-28 22:31 PST by Ben Liblit
Modified: 2006-02-11 13:22 PST (History)
23 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Ben Liblit 2001-11-28 22:31:05 PST
The Windows version of Mozilla should provide a HotSync conduit for 
synchronizing Mozilla address books with Palm the contacts database.  Netscape 
4.7x had this, Outlook has this, and it's the one missing feature that prevents 
me from switching to Mozilla full time.

I would have expected this to be a very common feature request, but I don't see 
any existing bugzilla reports that correspond to it.  There are, however, a few 
related reports worth being aware of:

    - Bug #28040 requests equivalent functionality under Linux & Gnome.  This
      report requests it under Windows.  There may be some development work
      that both can share.

    - Bug #16767 requests general "Palm integration" on the Macintosh.  It's not
      clear if this means mail, contacts, or both.

    - Bug #36836 requests mail synchronization, which (under Windows) requires
      MAPI support.  I'm not sure, but I *think* that address book sync doesn't
      involve MAPI, and therefore could proceed independently.

    - Bug #2933 documents some character set translation issues that may arise
      when working on address book synchronization.  It doesn't actually lay out
      synchronization itself as an explicitly requested feature, though.  That's
      what this report does.  Perhaps it would be appropriate to list bug #2933
      as a blocker of this bug.
Comment 1 User image Shawn Neumann 2001-12-31 11:34:11 PST
Personally, I think address book sync should be a must in 1.0.  It may be too
late as the focus is not on features but stability and performance at this point...
Comment 2 User image Ian Pottinger 2002-01-30 06:23:40 PST
Is this a duplicate of bug 108491 (or vice versa) ??  Note, this bug has been
futured while bug 108491 is targeted at mozilla1.0.1.
Comment 3 User image Ben Liblit 2002-01-30 12:09:34 PST
Concerning Ian Pottinger's question, I don't think that either bug is a
duplicate.  Bug #108491 requests "import" of PalmOS address books.  That, and
the rest of the description, suggests that the user wants to be able to read
Palm address books that are stored in static files.  Basically, they want to add
an import file format.  This bug report, on the other hand, requests a conduit
for HotSyncing, which is rather more dynamic.
Comment 4 User image Marek 2002-01-30 13:23:32 PST
I'm not sure. Bug #108491 also talks about "linking" (but is indeed rather 
vaguely worded). In any case I think that HotSyncing with the most popular PDA 
(BTW: Oliver, make that more than 16 million rather than a few thousand...) is 
really a rather important feature that should be available asap. Personally I 
agree with Shawn that it actually should be available with v1.0 (although 
unlikely). What can be done to possibly speed up the process?
Comment 5 User image John Marmion 2002-02-06 06:57:30 PST
I thought I would add the following comment from bug #83100 to this bug:

"My interest in this feature is because of the widespread availability of
syncing software for a variety of PDA's and net sites that uses Outlook as the
basis. Once this code is user-visible, I will be able to use the Outlook AB from
Mozilla, keeping it in sync with web based AB's and PDA's. I suspect there are
many peolpe who currently use Outlook, as well as syncing software that is
Outlook-specific, who would love to be able to use Mozilla instead. This will
help them make the transition. Hopefully we will get the sync software people to
support Mozilla / Netscape directly soon too ;-)"

My aim is to focus attention for #83100 and more recently bug #118119 which
broke the Outlook/OE functionality. But I thought that above is quite an
incisive comment that would add weight to this also when it gets some attention.
 
Comment 6 User image Niranjani Raya 2002-02-14 17:26:26 PST
Request has come from number of internal & external customers.
Comment 7 User image Peter Bauer 2002-07-07 12:30:13 PDT
The lack for synchronizing address book to palm handhelds holds down the
acceptance (euphoria?) for Mozilla in our sales personell. Sometimes it prevents
me from switching a user to Mozilla which otherwise would be a good decision.
Well known messengers do have this feature and so must Mozilla.
Comment 8 User image Alek Kowalczyk 2002-09-08 00:36:31 PDT
Why are you talking only about syncing address book in Windows?
I guess, Linux folks (like me...) also uses Palms. In Linux, you have support
for palms builded into both GNOME and KDE (and GNOME's one, gnome-pilotd works
fine even under KDE, as I use it for syncing with Ximian Evolution, program
similiar to MS Outlook), There are also some stand-alone, command line programs
to sync Palm  databases.
Comment 9 User image Rajiv Dayal 2002-10-08 17:57:31 PDT

*** This bug has been marked as a duplicate of 164760 ***
Comment 10 User image Rajiv Dayal 2002-12-02 12:27:46 PST
The Palm sync feature for Mozilla Address Book is now available in Mozilla 1.2.
You can download Mozilla 1.2 / 1.21 (when made available) and use this feature. 

You can find instructions on how to use it in the 1.2 release notes at:
http://www.mozilla.org/releases/mozilla1.2/#palminstall
Comment 11 User image Ninoschka Baca 2003-02-20 11:01:20 PST
Verified Duplicate.

Note You need to log in before you can comment on or make changes to this bug.