3-pane window title and selection not updated when message deleted in standalone window

RESOLVED DUPLICATE of bug 172392

Status

SeaMonkey
MailNews: Message Display
--
minor
RESOLVED DUPLICATE of bug 172392
16 years ago
13 years ago

People

(Reporter: J Luh, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
mozilla1.2alpha

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ue1])

(Reporter)

Description

16 years ago
With 2001112806 on Mac OS X 10.1.1 the 3-pane window does not update properly
when a message is deleted in the standalone window.

To reproduce:

1. Open an IMAP folder that has more than one message in it.
2. Double-click on first message to open it in a standalone window.
3. Press Delete button in standalone window.

What should happen:
a) standalone window updated with next message in folder (or standalone window
closes on deleting the last message)
b) deleted message is removed from 3-pane window.
c) selected message changes in 3-pane window.
d) 3-pane window title updates to match currently selected message 
 
What happens:
Standalone window is updated properly, and deleted message is properly removed
from message list in 3-pane window. But: 3-pane window title is not updated. No
message is selected in 3-pane window (message currently shown in standalone
window should be selected in 3-pane window).

Updated

16 years ago
QA Contact: esther → sheelar

Comment 1

16 years ago
confirming on 2001-12-03-06 on mac os x as well as on win98.  We need to change
the title of the 3 pane to the next message as well as select this in the thread
pane.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: MacOS X → All
Hardware: Macintosh → All
(Reporter)

Updated

16 years ago
Keywords: mozilla1.0

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.2

Comment 2

16 years ago
Is this still an issue in Mozilla 1.0?
(Reporter)

Updated

16 years ago
Keywords: mozilla1.0 → mozilla1.1

Comment 3

16 years ago
commercial branch builds:  06-20-08 on win98
Still an issue.  We do not update the 3 pane window and we don't select 
the next message in the thread pane.  This is not just imap it is seen on pop
accounts as well. 

Updated

16 years ago
Keywords: mozilla1.0.1, nsbeta1

Comment 4

16 years ago
Discussed in mail news bug meeting.  Decided to minus this bug.
Keywords: nsbeta1 → nsbeta1-

Comment 5

16 years ago
*** Bug 150091 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
2002-06-05-08-1.0.0/  Windows Build.

1. Double click a msg in 3 Pane to read it in Standalone window.
2. Delete msg
3. Next message appears in Standalone.
4. Close Standalone window and return to 3 Pane.

Expected: Message that was just closed in Standalone should have focus in Thread 
Pane.

Actual: Nothing in Thread pane has focus.

Try the same steps as above, but don't delete the message.
1. Double click a msg in 3 Pane to read it in Standalone window.
2. Close Standalone window and return to 3 Pane.
Results: Message that was just closed in Standalone has focus in Thread Pane. 
Expected Results.

This is really annoying for us Standalone Window users.
Whiteboard: [ue1]

Comment 7

16 years ago
*** Bug 156807 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
Is it related to bug 62938?

Comment 9

16 years ago
yeah this bug is a dupe of bug 62938

but this bug has more recent activity.

note this bug can also be reproduced w/out using a stand alone
mesg. Just take a folder, delete megs until empty and notice
last mesg deleted is still showing in preview panee even though
thread pane is empty.g
 

Comment 10

16 years ago
*** Bug 80546 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 11

16 years ago
Note that bug 62938 refers to the contents of the message pane, whereas this bug
deals with the window title and the currently selected message. So this bug and
bug 62938 are not exact duplicates, but are closely related and probably could
be combined into one bug.

Comment 12

15 years ago
nominating for the next release
Keywords: nsbeta1- → nsbeta1

Updated

15 years ago
Blocks: 160730
(Reporter)

Updated

15 years ago
Keywords: mozilla1.1 → mozilla1.2

Comment 13

15 years ago
this bug is essentially a dupe of bug 172392 (which already has a patch under
review)

*** This bug has been marked as a duplicate of 172392 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.