[RTL] File name is not displayed from right to left when you share a contact

RESOLVED DUPLICATE of bug 1210731

Status

Firefox OS
Gaia::SMS
P3
normal
RESOLVED DUPLICATE of bug 1210731
3 years ago
3 years ago

People

(Reporter: jlorenzo, Unassigned)

Tracking

unspecified
x86_64
Linux
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.2-bug-bash], [2.2-nexus-5-l])

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8555903 [details]
Screenshot

Pre-requisite
Have a contact with a short name like "hello".
Set the phone in Arabic.

STR
1. Open contacts
2. Open a contact's details
3. Tap "Share contacts"
4. Select "Messages"

Actual results
The filename is displayed in LTR. See attached screenshot
(Reporter)

Comment 1

3 years ago
Created attachment 8555904 [details]
Screenshot

Wrong screenshot. Here's the right one.
Attachment #8555903 - Attachment is obsolete: true
(Reporter)

Comment 2

3 years ago
QA wanted to check if it does repro with a video of a music.
QA Whiteboard: [rtl-impact]
Keywords: qawanted
Blocks: 1064569
No longer blocks: 1071918
(Reporter)

Updated

3 years ago
Whiteboard: [2.2-bug-bash]
blocking-b2g: --- → 2.2?
Hey Ahmed,

Just to confirm, should both LTR and RTL file names be always right aligned in RTL (left and right side are bound by attachment width)?

And one side question about RTL file name, currently it's displayed like .vcfأحمد but we suppose it should be أحمد.vcf, right?

Thanks!
Flags: needinfo?(nefzaoui)
QA Contact: bzumwalt
Issue occurs with music and video files on latest Flame 3.0

Music files show as [filename].mp3 in messages app
Video files show as [filename].3gp in messages app

Device: Flame 3.0 Master
Build ID: 20150129010239
Gaia: 9d2378a9ef092ab1fc15c3a9f7fc4171aab59d57
Gecko: 6bfc0e1c4b29
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
QA Whiteboard: [rtl-impact] → [rtl-impact][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [rtl-impact][QAnalyst-Triage?] → [rtl-impact][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Reporter)

Comment 6

3 years ago
Comms triage: RTL bugs are considered as features for now. Let's remove the blocking nom' and wait until the RTL triage team team goes through this one.
blocking-b2g: 2.2? → ---
feature-b2g: --- → 2.2+
Priority: -- → P2
Re-triage: downgrade to P3
feature-b2g: 2.2+ → ---
Priority: P2 → P3

Comment 8

3 years ago
Setting ni? to Kaze instead of Ahmed to try to spread the load a bit better.
Flags: needinfo?(nefzaoui) → needinfo?(fabien)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15929/
Flags: in-moztrap+

Updated

3 years ago
Whiteboard: [2.2-bug-bash] → [2.2-bug-bash], MGSEI-RTL-3F

Updated

3 years ago
QA Whiteboard: [rtl-impact][QAnalyst-Triage+] → [rtl-impact][QAnalyst-Triage+][MGSEI-Triage+]
Whiteboard: [2.2-bug-bash], MGSEI-RTL-3F → [2.2-bug-bash], MGSEI-RTL-3F, [2.2-nexus-5-l]
QA Whiteboard: [rtl-impact][QAnalyst-Triage+][MGSEI-Triage+] → [rtl-impact][QAnalyst-Triage+][MGSEI-Triage+]MGSEI-RTL-3F
Whiteboard: [2.2-bug-bash], MGSEI-RTL-3F, [2.2-nexus-5-l] → [2.2-bug-bash], [2.2-nexus-5-l]
This issue can be reproduced on AriesKK_V2.5
Rate:5/5
Build ID               20150812230643
Gaia Revision          52f3ea58df38e5427f6afeb636bc6ad01d24022f
Gaia Date              2015-08-12 16:40:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/7649ffe28b67aa2dad0f67ea01500c0ff91b2bac
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150812.222959
Firmware Date          Wed Aug 12 22:30:07 UTC 2015
Bootloader             s1
Blocks: 1181936
Created attachment 8649621 [details]
AriesKK_V2.5.png
Created attachment 8685858 [details]
Can't repro_AriesKKv2.5.png.png

This problem cannot be reproduced on latest AriesKK v2.5 and FlameKK v2.5 by the STR in comment 0.
On message compose view, the vcf/music/video filename and file size are displayed right aligned. Closing as resolved worksforme.

See attachment: Can't repro_AriesKKv2.5.png
Reproduce rate: 0/5

Device information:
Aries KK v2.5 
Build ID               20151110094357
Gaia Revision          07baf613699fa6225359c7f04825c5caeb71d424
Gaia Date              2015-11-09 21:32:50
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/e14287b00a514a15418dfaa89287030c588ad19d
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151110.090331
Firmware Date          Tue Nov 10 09:03:39 UTC 2015
Bootloader             s1

Flame KK 2.5 512mb 
Build ID               20151109004552
Gaia Revision          cf646c52bb947af28329b0a100df91d1b1f2a907
Gaia Date              2015-11-09 02:55:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/4eafef5b80f8985c94c4a067f130d37513e1a581
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151109.041411
Firmware Date          Mon Nov  9 04:14:26 EST 2015
Bootloader             L1TC000118D0
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(kaze)
Resolution: --- → WORKSFORME
Likely bug 1210731
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1210731
You need to log in before you can comment on or make changes to this bug.