[Messages] Caret shown in Options -> on top of Settings button

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: echang, Assigned: steveck)

Tracking

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-CP-bug-bash])

Attachments

(3 attachments)

*** Steps to Reproduce
1. Empty messages, no mail thread
2. Tap 3 dots to options
NEED STR

*** Expected Results
Caret not shown

*** Actual Results
Caret shown on "Settings"

*** Reproduction Frequency: 10%

*** Version
Serial: e47cd843 (State: device)
Build ID               20150129003432
Gaia Revision          6e494f1d2676d231abba7dcc2e2822d1170d2d02
Gaia Date              2015-01-29 06:34:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5e6fac01a72f
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150129.042943
Firmware Date          Thu Jan 29 04:29:53 EST 2015
Bootloader             L1TC000118D0
Reporter

Updated

5 years ago
QA Whiteboard: [COM=Gaia::Messages]
Keywords: steps-wanted
blocking-b2g: --- → 2.2?
Triage: Broken new functionality.
blocking-b2g: 2.2? → 2.2+
Reporter

Comment 3

5 years ago
Messages empty
1. Tap 3 dots to options, only "Settings" there.
2. Tap & slide  the small space between left border and the " Settings         " button and slide to the right. (but not to highlight the button)

Messages not empty, with mail threads
1. Tap 3 dots to options, "Select Threads", "Settings" there.
2. Tap & slide  the small space between left border and the " Select Threads       " button and slide to the right. (but not to highlight the button)
Keywords: steps-wanted
Also occurring in master so marking "status-b2g-v3.0" as affected.

Environmental variables:
Flame 3.0 device
Build Id: 20150130082956
Gecko: 8e96000
Gaia: 21829dd
Platform version: 38.0a1

Updated

5 years ago
Blocks: CopyPasteGaia
No longer blocks: CopyPasteLegacy

Updated

4 years ago
QA Whiteboard: [COM=Gaia::Messages] → [COM=Gaia::SMS]
Assignee

Updated

4 years ago
Assignee: nobody → schung
Depends on: 1129356
Assignee

Comment 6

4 years ago
Comment on attachment 8562670 [details] [review]
Link to github

Hi Oleg, since bug 1129356 landed, now we can apply user-select none to root html element(main-wrapper panel is absolute positioned element). In the meantime we don't use universal selector to apply user-selector to all the elements, it should be able to inherit from html element after bug 1129356 landed.
Attachment #8562670 - Attachment description: [gaia] steveck-chung:message-text-selection-polish > mozilla-b2g:master → Link to github
Attachment #8562670 - Flags: review?(azasypkin)
Comment on attachment 8562670 [details] [review]
Link to github

Looks good to me, thanks!
Attachment #8562670 - Flags: review?(azasypkin) → review+
Assignee

Comment 8

4 years ago
Thanks!

In master: https://github.com/mozilla-b2g/gaia/commit/2fcc32b3dca792b7ce43d16aaa504fe41b4899db
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 9

4 years ago
Comment on attachment 8562670 [details] [review]
Link to github

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):Bug 1092437 (text selection feature)
[User impact] if declined: String in option menu will become selectable. 
[Testing completed]: N/A
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: N/A
Attachment #8562670 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8562670 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Important prerequisite to STR at comment 3: Turn off Edge Gesture.
I was having trouble reproducing this bug on an 1/29 central build because I had edge gesture turned on. (by default it is turned on)

------

This issue is verified fixed on Flame 3.0 and 2.2. Long pressing on the space between Messages Settings and left edge of the phone does not bring up a caret/waterdrop icon.

Device: Flame 3.0
BuildID: 20150406010204
Gaia: ef61ebbe5de8c2c9fc2a8f74a12455044c3b82e9
Gecko: 4fe763cbe196
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Device: Flame 2.2
BuildID: 20150406002503
Gaia: a6351e1197d54f8624523c2db9ba1418f2aa046f
Gecko: c3335a5d3063
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Gaia::SMS] → [COM=Gaia::SMS][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [COM=Gaia::SMS][QAnalyst-Triage?] → [COM=Gaia::SMS][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.