bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

tab bar should have a "New Tab" button

VERIFIED FIXED in mozilla1.0.1


Tabbed Browser
17 years ago
10 years ago


(Reporter: Hampton Maxwell, Assigned: jag (Peter Annema))


Dependency tree / graph

Firefox Tracking Flags

(Not tracked)


(Whiteboard: [adt2 RTM] [ETA 06/20][verified on trunk])


(18 attachments)

24.44 KB, image/jpeg
29.68 KB, image/png
3.34 KB, image/png
8.32 KB, image/png
161.52 KB, image/png
161.58 KB, image/png
47.29 KB, image/jpeg
4.04 KB, application/zip
10.39 KB, patch
Samir Gehani
: review+
Joe Hewitt (gone)
: superreview+
Details | Diff | Splinter Review
3.24 KB, image/png
2.24 KB, image/png
266 bytes, image/png
2.08 KB, image/png
877 bytes, application/x-compressed
648 bytes, image/gif
16.40 KB, image/png
1.21 KB, patch
Brian Ryner (not reading)
: review+
Blake Ross
: superreview+
Details | Diff | Splinter Review
1.01 KB, image/gif


17 years ago
After using Opera 6 for a few hours I noticed that tabs become a lot more useful
using their "New Window" button.

I'd like to suggest that there be a small button on the right side of the tab
bar ("New Tab"?) that creates new tabs and is equivalent to pressing Ctrl+T. 
Ctrl+T is just fine but I think if you're moving the mouse about switching
between tabs a button on the bar is more convenient.
Ever confirmed: true

Comment 1

17 years ago
-> UID.

Reporter, would you like to attach a screenshot of opera's button?
Component: Tabbed Browser → User Interface Design
Hardware: PC → All
marlon/hyatt/mpt, what d'you think?

Comment 3

17 years ago
Created attachment 60072 [details]
Screenshot of opera tabs


16 years ago
Target Milestone: --- → Future

Comment 4

16 years ago
Not exactly what you are saying, but what about having a "new tab" button on the
navigation toolbar.  Often I have my tab bar hidden if there is only one tab
open on the page and having access to the button when the tab bar is not
available would be wonderful

Comment 5

16 years ago
Just a tip for those who don't know, as I only discovered it on a guess. You can
drag a link or PT bookmark to a blank space in the tab bar, and have it open in
a new tab. That does half of what this bug asks for.

Also, I believe I've seen a screenshot of another Windows app with a new tab
type button... perhaps mIRC?

Comment 6

16 years ago
Created attachment 83807 [details]
screenshot of the "new" button and its selection menu.

This is not exactly the same than bug 127640. The initial report of bug 127640
says that the "new" button coul be beside the "prev" button and could have two
different fonctions: 1) open a new window 2) open a new tab

The choice between the two possibilities could be done with a menu under the
button. Take a look at the screenshot to see what it could look like.

Comment 7

16 years ago
Please don't look at the icon of the button, I've gimped it too fast.

But something interesting should be to have a different icons when "new tab" is
selected, and when "new window" is selected.
(so, on the screenshot, the icon would not be coherent, and should look like a
"T" instead)

Comment 8

16 years ago
My 0.02USD:

I submit that any New Tab button on the navigation bar be optional (like Go) and
disabled by default, since many (like myself) like their navigation bars

My idea was to have a New Tab button located just to the left of the Close Tab
button on the Tab Bar. But then I started thinking putting it there might cause
some grief for those not so nimble with the mouse: they might occasionally hit
the Close Tab button when aiming for the New Tab button. So perhaps it might be
placed on the far left of the Tab Bar, with an option in Preferences that would
let the user choose between having it on the right or left. (Default to left.)
Just a thought. 

Comment 9

16 years ago
-> me
Assignee: hyatt → jaggernaut
Component: User Interface Design → Tabbed Browser
Keywords: nsbeta1
Target Milestone: Future → mozilla1.0.1

Comment 10

16 years ago
Our suggestion is something like:

[N]/ T1 \/ T2 \/ T3 \______[X]

Where the N will be some nice icon, or perhaps the text "New".

Lori, marlon: icon or text?

Comment 11

16 years ago
Problem with the [n] where you have it is the thing it creates is going to pop
up all the way on the other side. The screenshot someone posted of Opera's looks
much more intuitive, and excruciatingly purty. (Having used Opera briefly,
that's about the only UI that looks halfway decent... quite a miracle wherever
it came from.)

Re: jag's icon/text question... I can't think of a possible icon that would be
obvious what it does. Opera's "New page" (or "New tab") is nice wording. If it
could specifically be shortened to "New..." when the tabs start shrinking,
that'd be ideal, IMO.

Comment 12

16 years ago
nsbeta1+/adt2 to add a simple button only, no fake tabs or other complications,
 and no prefs in this release.  Needs to land on branch by 6/3 to make L10N
freeze.  We had some discussion of this in UI ng some months back, IIRC, there
were some icons posted too.
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P1
Whiteboard: [adt2]

Comment 13

16 years ago
Created attachment 85705 [details]
Snapshot of sample button

This is the basic idea, I'll see if I can find a better image in n.p.m.ui.

Comment 14

16 years ago
Okay, honestly, I'd never figure out what that was, and many users don't know to
hover over it and see.  Do we have to go with an icon here?  Newness is a hard
concept to display.  I think we should just stick with "New Tab" and swallow the
slightly larger amount of space we lose from it.

Comment 15

16 years ago
Note, also, that "New Tab" gives a significantly larger and easier target to hit
than that sample button -- and the purpose of this is for quicker mouse access
to new tab, isn't it?

Comment 16

16 years ago
That's fine with me. "New" or "New tab"? See also comment 10 :)

Comment 17

16 years ago
Blake: Big targets for quicker access are always nice (<cough>button
menus<cough>), but the main intent of this was to make the operation more
discoverable. Usability  subjects were going to the popup menu in Open Web
Location, which didn't seem worthwhile. I would hope that many users will
eventually learn one or more ways to open an existing URL/bookmark in a new tab.
 To handle the space tradeoff, it would be ideal (IMO), if the button had the
icon and 'New Tab' (New still begs the question - New What?), but was able to
collapse the text as it shrinks along with the tabs.  When we add support for
showing toolbar button icons without the text, it would benefit from that too.

Comment 18

16 years ago
How about using an icon like the New Document icon from various word processors?
 A blank page with a star on it?  Most people that use word processors
understand what that does...

Comment 19

16 years ago
I think a star (*) on a button like the X would be good. Of course, opposite the X.

Comment 20

16 years ago
Created attachment 85791 [details]
screenshot of '*' new button

This is another idea of what the new button could look like.


16 years ago
Blocks: 149058


16 years ago
Whiteboard: [adt2] → [adt2 RTM] [ETA Need]

Comment 21

16 years ago
I've been wanting this feature for quite some time, it greatly speeds up tabbed
browsing.  The most recently suggested button for a new tab (id=85791) I think
would be confused too much with the close tab button.  The third screenshot
(id=85705) is in the right direction... maybe make it a little bigger and with
the words "New Tab" on it.

Comment 22

16 years ago
Created attachment 86485 [details]
screenshot with widget look

here's an idea which uses the widget style button used on [close tab]

Comment 23

16 years ago
Created attachment 86486 [details]
screenshot using a new document button style

second screenshot shows a new document button which uses a bit more color. 
which direction do we think work best?

Comment 24

16 years ago
I think the "new document" style (screenshot id=86486) is in the right
direction, as a "*" by itself doesn't seem intuitive, to me at least.  I think
making the icon a little bigger and explicitly adding the words "New Tab" is ideal.

Comment 25

16 years ago
it seems by adding text we are only going to steal space from the tab bar. 
Users probably aren't going to have a problem figuring the button out especially
since its placed within the context of use.  Tooltips suffice on navigator
buttons elsewhere i don't think users will have much difficulty determining the
function of this one. Of course we'll have the opportunity to validate that in
upcoming tab browsing user testing.

Comment 26

16 years ago
Created attachment 86503 [details]
Screenshot with new document style with text

Just as an example, here's a quick mock-up of what I was thinking.  I think,
irrelevant of the text, having a slightly bigger button is better for hitting
quickly, and the text is just an added plus for new users.  Just an idea.

Comment 27

16 years ago
We're currently in l10n UI freeze. So if we can get by with no added text, that
would be better. thanks

Comment 28

16 years ago
we came up with an idea like that (which is borrowed from opera) in one of the
feature design meetings.  We certainly can do it, however it uses more space.
There was also the feeling by some that it seems slightly weird to click on a
tab and never actually be able to open it.  But i am less concerned about that.
 I am working on a new design for the tab look which will hopefully replace all
tabs in modern (except sidebar's) fixing some of the visual weirdness with what
we currently have. 

will post a screenshot with new tab look, and the icon in a small tab to the left.


Comment 29

16 years ago
I would personally go with the "new document button style" look, since it's
clear enough and takes up less space.

Comment 30

16 years ago
I quite like the "new document button style one", except the blue/yellow star is
a little hard to make out.

  "Users probably aren't going to have a problem figuring the button out
  especially since its placed within the context of use."
I think that's quite well said. The tab bar has ONE button on the left. It's of
a page, just like MS Word. Worst case, user clicks it figure out what it does...
then they know... no risk of dataloss or anything.

Comment 31

16 years ago
Of all the ideas that don't have text, the new document button style is my
preference as well.  It resembles what they've seen before, and is big enough to
be hit easily and quickly.  I don't how much the "*" adds to the intuitiveness,
personally, but it the icon as a whole still feels right and users should be
able to figure out its use, if only by clicking on it finding out (and as has
been said, that's not terrible since there's no data loss involved).

Comment 32

16 years ago
Created attachment 86551 [details]
new tab button (3 states)

jag try these on

Comment 33

16 years ago
I think the button in attatchment 86551 is great.
I don't think we need text... the function should be pretty obvious.

Comment 34

16 years ago
Created attachment 86887 [details] [diff] [review]
Add new tab button

Comment 35

16 years ago
I'm using a greyscale version of the modern button for the classic theme as a 
placeholder, I'll make sure we get a better image, but I need to get this patch 
in before the l10n freeze because of the tooltiptext.
Whiteboard: [adt2 RTM] [ETA Need] → [adt2 RTM] [ETA 06/07]

Comment 36

16 years ago
Comment on attachment 86887 [details] [diff] [review]
Add new tab button

r=sgehani (contingent upon removing ``disabled=disablenew'' per discussion)
Attachment #86887 - Flags: review+

Comment 37

16 years ago
Comment on attachment 86887 [details] [diff] [review]
Add new tab button

por favor, rename those newtab.gif images to tab-new.gif

Attachment #86887 - Flags: superreview+

Comment 38

16 years ago
I think the usual style for tooltips is initial cap.

So the text should be spelled "Open a new tab".

Comment 39

16 years ago
You're right. Fixed locally.


16 years ago
Keywords: adt1.0.1, mozilla1.0.1

Comment 40

16 years ago
adt1.0.1+ (on ADT's behalf) approval for the 1.0 branch, pending Drivers'
approval. Pls check this in asap, then add the "fixed1.0.1" keyword.
Keywords: adt1.0.1 → adt1.0.1+, approval
Whiteboard: [adt2 RTM] [ETA 06/07] → [adt2 RTM] [ETA 06/11]

Comment 41

16 years ago
Created attachment 87144 [details]
Screenshot of modern

Comment 42

16 years ago
Created attachment 87145 [details]
Screenshot of classic

Yes, it sticks out like a sore thumb. I'll make sure we get a better icon for
classic once the person who does those gets back. Alternatively, let me check
in just the DTD change now and the rest later.

Comment 43

16 years ago
Approved for UI change from L10n. Please checkin asap. Thanks.

Comment 44

16 years ago
Nit: you could update BrowserOpenTab() to call gBrowser.newTab() instead.

Comment 45

16 years ago

New tab button works, however, I see no icon in either classic or modern.  I see
the empty space and will get a "Open a new tab" tooltip though.

Comment 46

16 years ago
macosx 2002061208 trunk build, modern skin

agreed. I see an empty space where the icon goes. I see a tooltip when I mouse
over the empty spot. Clicking the spot creates a new tab.

There's just no icon.


Comment 47

16 years ago
Removing "+" from adt1.0.1, until we have clarification on why the icons are
missing. pls see comments Comment #45 and Comment #46.

sairuh - can you pls look into Comment #45 and Comment #46. thanks!
Keywords: adt1.0.1+ → adt1.0.1
Whiteboard: [adt2 RTM] [ETA 06/11] → [adt2 RTM] [ETA 06/13]

Comment 48

16 years ago
I checked the images in without -kb. Should be fixed as of a few hours ago,
visible in tomorrow's builds.

Comment 49

16 years ago
*** Bug 151225 has been marked as a duplicate of this bug. ***
verified using 2002.06.13.0x commercial trunk bits on linux rh7.2, win2k and mac
10.1.5. tested both themes as well.

marking resolved fixed...er, that is the correct ritual for this, yes?
Last Resolved: 16 years ago
Resolution: --- → FIXED
Whiteboard: [adt2 RTM] [ETA 06/13] → [adt2 RTM] [ETA 06/13][verified on trunk]

Comment 51

16 years ago
Re-Issuing "+" based on Comment #50 From sairuh, pending Drivers' approval. Pls
check this into the 1.0 branch, then add "fixed1.01" keyword.
Keywords: adt1.0.1 → adt1.0.1+

Comment 52

16 years ago
Created attachment 87667 [details]
New Tab button for Classic

A suggestion for the New Tab button in Classic.

Comment 53

16 years ago
Created attachment 87668 [details]
Screenshot of Classic button suggestion

Comment 54

16 years ago
Marcus, am I wrong or does your proposal have some kind of grey background?
That looks fine with windows standard colors, where the area around the icon has
the same color, but IMHO transparent background would be better, because people
may change their UI colors (or have others on other OSs).
My apologies if the background *is* transparent - it just does not look like, here.

In yesterdays build the "new tab" button looked much larger than the "close tab"
button when hovered over, it fills all of the available space. That looks not
very consistent, I think. Is there anything that can be done about it?

Apart from that I like the button and its design very much! Thanks!

Comment 55

16 years ago
they button looks blurry for me at 1152x864 using 2002061308 on W2K
Sorry for dropping in late, but I think it would be worthwile to think about
positioning a button like this to the right of the address bar, 'go'-button
style, and make a pref for it.
- User apparently wants to use keyboard + mouse to open an address in a new tab.
Why not have user type address, then click button?
- no tab bar space wasted
- always visible, also with tab bar auto-hidden
- makes it very easy to duplicate a window in a new tab (just click button; big
plus imho)
- Somewhat weaker association with tab bar

Comment 57

16 years ago
Interesting, but at this point it should be in its own RFE bug report, since
this one is already fixed/verified.

Comment 58

16 years ago
Created attachment 87832 [details]
New Tab button suggestion for Classic (3 states)

Revision of my previous suggestion. Three states, as GIFs, with transparent
backgrounds, and with most of the superfluous shading removed.


16 years ago
Whiteboard: [adt2 RTM] [ETA 06/13][verified on trunk] → [adt2 RTM] [ETA 06/18][verified on trunk]

Comment 59

16 years ago
The implemented Classic image needs a little polish.  As stated earlier in
comment #54 that if "chrome" is not gray than you get a nasty block background
surrounding the "new Tab" image.  At a minimum the existing image should have a
transparent background to avoid the block (like all other chrome images do). 
I'll post up a new version with a transparent background for Classic.

I think that Marcus has some nice images that should be considered.  They seem
to follow the theme better than the existing image.  However, Trudelle's
probably right that this should be filed under a new bug.

Comment 60

16 years ago
Created attachment 87997 [details]
Classic version of "New Tab" w/ transparent background instead of grey

Comment 61

16 years ago
Comment on attachment 86887 [details] [diff] [review]
Add new tab button

a=asa (on behalf of drivers) for checkin to the branch.
Attachment #86887 - Flags: approval+


16 years ago
Keywords: approval, mozilla1.0.1 → mozilla1.0.1+

Comment 62

16 years ago
The classic images belong in this bug, the request for change about placement of
the button belongs in its own bug.

Classic only needs one image, the depressed look is derived from the inverted 3d
border on the button itself.

Comment 63

16 years ago
> Classic only needs one image, the depressed look is derived from the inverted 3d
> border on the button itself.

What about the hover state?

Comment 64

16 years ago
Created attachment 88295 [details]
"new tab" screenshot of current classic theme in WinXP

Hey Jag this is what the "New Tab" looks like in the mozilla classic theme
under WinXP default.  Notice the gray background color, none of the other
images in mozilla chrome suffer from this.  Attachment 87997 [details] takes out JUST the
background color.  This should be a no-brain new checkin?


16 years ago
Whiteboard: [adt2 RTM] [ETA 06/18][verified on trunk] → [adt2 RTM] [ETA 06/20][verified on trunk]

Comment 65

16 years ago
Yeah, we should check the transparent button into the trunk and branch, asap. 
The button looks ugly in classic.


16 years ago
Keywords: mozilla1.0.1+ → fixed1.0.1

Comment 66

16 years ago
Created attachment 88824 [details] [diff] [review]
Allow pressed look to move image

Comment 67

16 years ago
Created attachment 88825 [details]
image for classic


16 years ago
Attachment #88825 - Attachment is patch: false
Attachment #88825 - Attachment mime type: text/plain → image/gif

Comment 68

16 years ago
jag, that's the same image as modern, color and all. Did you attach the wrong file?
Comment on attachment 88824 [details] [diff] [review]
Allow pressed look to move image

Attachment #88824 - Flags: review+

Comment 70

16 years ago
Comment on attachment 88824 [details] [diff] [review]
Allow pressed look to move image

Attachment #88824 - Flags: superreview+

Comment 71

16 years ago
jmd: it's not quite the same. Notice that the 3d bubble button look is gone and
the background is transparent. This is what the classic skin maintainer gave me.

Comment 72

16 years ago
jag looks much better.  What's the new ETA for checkin?

Comment 73

16 years ago
It was checked in Saturday.
verified on the branch using 2002.06.27.0x comm bits on all platforms.
Keywords: fixed1.0.1 → verified1.0.1

Comment 75

16 years ago
Jeremy M. Dolan (answer to comment #68):
There is bug 155242 about using a "less modern" new tab icon for classic skin
(different component and cc list, so probably not noticed by people here). It
was filed a week after this one here had been checked in.
Summary: [rfe] tab bar should have a "New Tab" button → tab bar should have a "New Tab" button
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.