Closed Bug 1127953 Opened 7 years ago Closed 7 years ago

[Lockscreen] [text selection] The text selection options (select all, cut, copy, paste) can appear on the lockscreen if they are present prior to quickly turning your screen off and back on.

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.2 affected, b2g-master affected)

RESOLVED DUPLICATE of bug 1135231
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: jmitchell, Assigned: gduan)

References

()

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(3 files)

Description:
If the user has the Text Selection options (Select All, copy, cut, paste) up on the screen and then quickly turns the screen off and back on again, the text selection bubbles will appear on the lockscreen momentarily

Repro Steps:
1) Update a Flame to 20150130010210
2) Enter Email (or anywhere where you can get cut/copy/paste)
3) Select Text to bring up cut/copy/paste bubbles
4) Quickly press power button twice

Actual:
 Text Selection bubbles are seen on the lockscreen

Expected:
Text Selection bubbles will not appear on the lockscreen

Environmental Variables:
Device: Flame 3.0
Build ID: 20150130010210
Gaia: 8238eeacc7030b2cdbf7ab4eba2f36779b702599
Gecko: 29b05d283b00
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 9/10
See attached: logcat, video: http://youtu.be/wGTjMeGBzVA
--------------------------------------------------------------------------------------------
This issue also occurs on Flame 2.2 (v18d-1), Flame 2.2 (v18d); Text Selection was not implemented in 2.1

evice: Flame 2.2 (KK - Nightly - Full Flash)
Build ID: 20150128002506
Gaia: cd42b034fd2825c3675ace3a67f5775eb61c2d60
Gecko: d824c65a6a2b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.2 (KK - Nightly - Full-Flashed)
Build ID: 20150128002506
Gaia: cd42b034fd2825c3675ace3a67f5775eb61c2d60
Gecko: d824c65a6a2b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18d
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
NI on component owner for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(gchang)
I observe that the utility bubble will appear in the lock screen momentarily and then disappear. Add developer for more information.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][textselection]
Flags: needinfo?(gchang)
Assignee: nobody → gduan
QA Whiteboard: [QAnalyst-Triage+][textselection] → [QAnalyst-Triage+][COM=Text Selection]
See Also: → 1135231
it's fixed in bug 1135231.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1135231
You need to log in before you can comment on or make changes to this bug.