[Homescreen] [Text Selection] Text Selection options (cut, copy, paste, select all) appear on the homescreen when long-pressing empty areas of the screen in homescreen edit mode.

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: mancas)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], )

Attachments

(3 attachments, 1 obsolete attachment)

Description:
Long-pressing an icon on the homescreen will put the device in edit mode, then long pressing certain areas of the homescreen while in edit mode will cause text selection elements (copy, cut, paste bubbles and blue text carets) to appear. You can use 'select all' or drag the carets around to select icon names. If you select done or lock and unlock the device these highlighted icon names will persist onto the normal homescreenas well as blue carets and text selection option bubbles. If these items are used to select icons on the homescreen those icons that have highlighted names can not be long-pressed on to enter edit mode, nor can you tap on them to launch that app. 


Repro Steps:
1) Update a Flame to 20150130010210
2) Long press on an app icon to enter edit mode
3) Scroll down to the bottom and long press and empty area (occurs on other empty areas but the very bottom has a higher repro rate)

Actual:
Text selection options become available

Expected:
text selections options will not become available 
-or-
text selection will be confined to a single icon name (but they can still copy/paste when in edit mode for a particular app icon so this is not necessary here) 

Environmental Variables:
Device: Flame 3.0
Build ID: 20150130010210
Gaia: 8238eeacc7030b2cdbf7ab4eba2f36779b702599
Gecko: 29b05d283b00
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Repro frequency: 9/11
See attached: logcat, video: http://youtu.be/SuDwcl13yVA
-------------------------------------------------------------------------------------
This issue also occurs on Flame 2.2 (v18d-1), Flame 2.2 (v18d); Text Selection was not implemented in 2.1

evice: Flame 2.2 (KK - Nightly - Full Flash)
Build ID: 20150128002506
Gaia: cd42b034fd2825c3675ace3a67f5775eb61c2d60
Gecko: d824c65a6a2b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.2 (KK - Nightly - Full-Flashed)
Build ID: 20150128002506
Gaia: cd42b034fd2825c3675ace3a67f5775eb61c2d60
Gecko: d824c65a6a2b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18d
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
NI on component owner for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(gchang)
Add developers for more information.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][textselection]
Flags: needinfo?(gchang)
Blocks: CopyPasteGaia
No longer blocks: CopyPasteLegacy
broken new feature nominated as 2.2?
blocking-b2g: --- → 2.2?
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
Adding tim for text selection triage.
Flags: needinfo?(timdream)
Whiteboard: [3.0-Daily-Testing][systemsfe] → [3.0-Daily-Testing]
Flags: needinfo?(timdream) → needinfo?(hochang)
This should block as new feature broken
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(hochang)
QA Whiteboard: [QAnalyst-Triage+][textselection] → [QAnalyst-Triage+][COM=Text Selection]
Agreed this is a blocker, but I expect bug 1129356 may fix this, so adding as a dependency (all the icons in GaiaGrid are abs-pos).
Depends on: 1129356
Can we test again since the dependency bug landed?
Keywords: qawanted
QA Contact: ychung
This issue still reproduces on the latest Flame Master (tinderbox, mozilla-central).

Result: When long-pressing the empty area in edit mode, the text selection bubble appears. When selecting the 'select all' button, all app names and "Done" button are selected, which remain selected after exiting the edit mode.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150211130440
Gaia: e280a660955bbdab265d50f8d9e009de34082332
Gecko: c1ac604684b4
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
QA Whiteboard: [QAnalyst-Triage+][COM=Text Selection] → [QAnalyst-Triage?][COM=Text Selection]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Contact: ychung
QA Whiteboard: [QAnalyst-Triage?][COM=Text Selection] → [QAnalyst-Triage+][COM=Text Selection]
Flags: needinfo?(ktucker)
Assignee: nobody → b.mcb
Posted file Proposed patch (obsolete) —
Kevin could you help me with the review of the patch?

Thanks!
Attachment #8564921 - Flags: review?(kgrandon)
Comment on attachment 8564919 [details] [review]
[gaia] mancas:bug1127954 > mozilla-b2g:master

I think this looks good, thanks!
Attachment #8564919 - Flags: review+
Comment on attachment 8564921 [details] [review]
Proposed patch

Let's use the autolander attachment.
Attachment #8564921 - Attachment is obsolete: true
Attachment #8564921 - Flags: review?(kgrandon)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Please request Gaia v2.2 approval on this patch when you get a chance.
Flags: needinfo?(b.mcb)
Target Milestone: --- → 2.2 S6 (20feb)
Comment on attachment 8564919 [details] [review]
[gaia] mancas:bug1127954 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): No regression
[User impact] if declined: Selection bubbles can appear and the user can select all the text without the possibility of deselect it.
[Testing completed]: No need, css change
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]:None
Flags: needinfo?(b.mcb)
Attachment #8564919 - Flags: approval-gaia-v2.2?
Keywords: verifyme
Attachment #8564919 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Posted video Verify_video.mp4
The problem is verified not happen on latest Flame 2.2 & 3.0 build.

Repro Steps:
1) Update a Flame to Latest build.
2) Long press on an app icon to enter edit mode
3) Scroll down to the bottom and long press and empty area (occurs on other empty areas but the very bottom has a higher repro rate)

Actual Result:
3) text selections options will not become available.

Fail rate:0/10
See attachment:Verify_video.MP4

Flame 2.2 version:
Build ID               20150225002505
Gaia Revision          ca64f2fe145909f31af266b1730874051ba76c78
Gaia Date              2015-02-24 22:06:53
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/16804008c29f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.041814
Firmware Date          Wed Feb 25 04:18:25 EST 2015
Bootloader             L1TC000118D0
Flame 3.0 version:
Flame3.0:
Build ID               20150225010244
Gaia Revision          f6bfd854fe4746f21bc006eac145365e85f98808
Gaia Date              2015-02-24 21:10:44
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0a8b3b67715a
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.043702
Firmware Date          Wed Feb 25 04:37:14 EST 2015
Bootloader             L1TC00011880
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][COM=Text Selection] → [QAnalyst-Triage+][COM=Text Selection][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.