Last Comment Bug 1129857 - Update timezones to 2015a
: Update timezones to 2015a
Status: RESOLVED FIXED
[see https://bugzil.la/1009894#c33 fo...
:
Product: Calendar
Classification: Client Software
Component: Internal Components (show other bugs)
: unspecified
: All All
-- normal (vote)
: 4.0.0.1
Assigned To: Geoff Lankow (:darktrojan)
:
:
Mentors:
: 1090082 1150361 1152212 1155210 1162011 1164899 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-05 02:35 PST by Geoff Lankow (:darktrojan)
Modified: 2015-06-02 02:45 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
2015a.diff (3.28 KB, patch)
2015-02-05 02:35 PST, Geoff Lankow (:darktrojan)
philipp: review+
Details | Diff | Splinter Review

Description User image Geoff Lankow (:darktrojan) 2015-02-05 02:35:25 PST
Created attachment 8559715 [details] [diff] [review]
2015a.diff

Filing this, not only because it needs to be done, but because it's so easy.
Comment 1 User image Philipp Kewisch [:Fallen] 2015-02-05 06:48:45 PST
Comment on attachment 8559715 [details] [diff] [review]
2015a.diff

Review of attachment 8559715 [details] [diff] [review]:
-----------------------------------------------------------------

Thats all that changed between 2014j and 2015a? Looking at the changelog it sounds like there were more changes, and looking at the code it just looks like those timezones no longer have DST, since the BEGIN:DAYLIGHT component is missing?
Comment 2 User image Geoff Lankow (:darktrojan) 2015-02-05 14:52:17 PST
Those are all the changes that affect us. I was confused when I saw the missing DST too, but according to tz-announce that's what's happening.
Comment 3 User image Philipp Kewisch [:Fallen] 2015-02-08 06:01:29 PST
Comment on attachment 8559715 [details] [diff] [review]
2015a.diff

Review of attachment 8559715 [details] [diff] [review]:
-----------------------------------------------------------------

Ok go.
Comment 4 User image Geoff Lankow (:darktrojan) 2015-02-08 19:25:59 PST
https://hg.mozilla.org/comm-central/rev/66f961f8ac26
Comment 5 User image Philipp Kewisch [:Fallen] 2015-02-12 17:40:12 PST
*** Bug 1090082 has been marked as a duplicate of this bug. ***
Comment 6 User image [:MakeMyDay] 2015-04-02 00:26:44 PDT
*** Bug 1150361 has been marked as a duplicate of this bug. ***
Comment 7 User image [:MakeMyDay] 2015-04-08 05:26:24 PDT
*** Bug 1152212 has been marked as a duplicate of this bug. ***
Comment 8 User image [:MakeMyDay] 2015-04-16 08:56:13 PDT
*** Bug 1155210 has been marked as a duplicate of this bug. ***
Comment 9 User image Decathlon 2015-05-06 06:09:08 PDT
*** Bug 1162011 has been marked as a duplicate of this bug. ***
Comment 10 User image Stefan Sitter 2015-05-14 13:28:52 PDT
*** Bug 1164899 has been marked as a duplicate of this bug. ***
Comment 11 User image Dmitriy Popkov 2015-06-02 01:59:57 PDT
Not all broken timezones was fixed with the patch
https://hg.mozilla.org/comm-central/rev/66f961f8ac26

All timezones should be patched, otherwise it's incorrect to mark issues like https://bugzilla.mozilla.org/show_bug.cgi?id=1090082 as dupluicate of this bug
Comment 12 User image Stefan Sitter 2015-06-02 02:17:46 PDT
Dmitriy, what timezones are still broken in Lightning 4.0 Beta?

The patch mentioned above only covers the update from 2014j release of tz data to the 2015a release. Russia timezones were changed with the earlier 2014f release and were already changed with the update to 2014j release in Bug 1121415.
Comment 13 User image Stefan Sitter 2015-06-02 02:45:51 PDT
In addition there is a timezones extension based on 2015a release attached Bug 1009894 that you can install in Thunderbird if you want the updated timezones for older releases like Lightning 3.3.

Note You need to log in before you can comment on or make changes to this bug.