Closed Bug 11304 Opened 21 years ago Closed 21 years ago

[BLOCKER] XUL Popups need to be rewritten using xp-menu code

Categories

(Core :: XUL, defect, P1)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: mikepinkerton, Assigned: hyatt)

References

Details

(Whiteboard: [PDT+]Waiting for clarification from development...)

Note to hyatt to rewrite the xul popups using what he's learned from doing the xp
menus. Also a placeholder for sched items that depend on his work.
Blocks: 9454
Summary: XUL Popups need to be rewritten using xp-menu code → [BLOCKER] XUL Popups need to be rewritten using xp-menu code
Marking this as a blocker, because Linux toolbar dropdowns (and therefore QA
testing of all editor features requiring them) are waiting on this.
this is a different bug.  XUL popups are tooltips and such.  xp context menus is
bug 11583
*** Bug 11583 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Target Milestone: M9
Does this have to be fixed in M9?  This will take me a minimum of one full day
to code (and probably one day of debugging before popups work again).

The alternative is to leave 'em broken for M9.

I have no opinion one way or the other.  I've stated the time it will take. I'll
let someone make the call as to whether or not I should do it for M9.
Target Milestone: M9 → M10
Given some of the other bugs that are being escalated that I really need to work
on (e.g., the crash in bookmarks and in mailnews move/copy menus), I'm inclined
to agree.

Moving to M10.
Priority: P3 → P2
setting P2 for M10. If this is really a blocker, it should be marked as such

(severity=blocker), and we'll bump the priority.
Severity: normal → blocker
*** Bug 12212 has been marked as a duplicate of this bug. ***
Priority: P2 → P1
this is blocking my overlay feature work; I can't verify/fix bugs related to
popups.

up to P1 to match severity:blocker
Blocks: 7482, 9751, 10607, 11068
add dependencies for editor bugs
Blocks: 12670
Blocks: 11739
Left-click popups work now.  It's up to the individual owners of their
respective popups to fix them.  Just look at the code for a single menu item on
the menu bar (e.g., the File menu), and copy it to make a popup menu.

To make a popup that contains stuff other than menu items, just put the stuff
directly inside the <menupopup> tag... it's essentially just a vertical box, so
it can hold anything.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Fixed. Syntax has changed, so current ones have to be updated.
No longer blocks: 11739
Status: RESOLVED → REOPENED
left-mouse drop-downs work, ther are issues with them sticking open, but that is
another problem. reopening the bug -- checked on win95 and mac, they worked
fine. using the 1999092009 linux build, the drop-downs did not work
My hands have deteriorated to the point where I can no longer type.  I need
help.  If you think you can fix this bug on your own, please take it away from
me.  If you'd like to volunteer to be my hands for a specific bug, then I'll be
happy to come up to your cube and sit with you and fix the bug (assuming you
have the patience for that).
Resolution: FIXED → ---
Clearing Fixed resolution due to reopen.
Blocks: 11346
Target Milestone: M10 → M11
mass migration to m11
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
QA Contact: phillip → cpratt
assigning Pratt as QA contact
How do I verify this as fixed? I am unclear what this bug means. There don't
appear to be any dropdown menus in the toolbar in current builds...
Whiteboard: Waiting for clarification from development...
I'm still unsure as how I can verify this one as fixed. Using the 1999092909
build under NT, I see no "left-mouse drop-downs" in the UI, and I don't see any
tooltips either. Could someone please give me a clue as to how I should verify
this fix? Thanks!
On Linux, I see dropdowns on the editor menubar, and right-mouse context menus
over links in the browser.  Haven't been able to get a Windows build to check
there.
Status: RESOLVED → VERIFIED
Now that we've reverted to older UI, I can verify this as fixed. 1999101109
build, NT.
Putting on [PDT]+ radar.
Whiteboard: Waiting for clarification from development... → [PDT+]Waiting for clarification from development...
No longer blocks: 11346
You need to log in before you can comment on or make changes to this bug.