Implement Service Worker Clients.matchAll ClientQueryOptions options

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
4 years ago
a month ago

People

(Reporter: bkelly, Unassigned)

Tracking

(Blocks 2 bugs, {dev-doc-complete})

Firefox Tracking Flags

(Not tracked)

Details

The rename landed in:https://hg.mozilla.org/integration/mozilla-inbound/rev/39354f436e2b

The only thing that's left is implementing the options parameter (selecting uncontrolled clients).
Summary: Implement Service Worker Clients.matchAll() → Implement Service Worker Clients.matchAll ClientQueryOptions options

Updated

4 years ago
Assignee: nobody → alberto.crespellperez
Thanks for taking this bug!

Bug 1130684 adds a set of all opened documents which I believe you can reuse for matchAll.
See Also: → 1130684
Status: NEW → ASSIGNED
in order to fulfill this, service workers should handle the case of having controlled clients such as workers and shared workers, because of this, Bug 1032521 is needed, adding the dependency. Thanks!
Depends on: 1032521
not working on this for the current sprint (FxOS-S2) so releasing it for now to allow anyone else to take it. Thanks!
Assignee: alberto.crespellperez → nobody
Status: ASSIGNED → NEW
testing/web-platform/mozilla/tests/service-workers/service-worker/clients-matchall-client-types.https.html

should be updated to check the shared worker and all cases (commented out in bug 1189686) when this is fixed.

Updated

3 years ago
Depends on: 1229056
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1247550
(Reporter)

Updated

2 years ago
No longer blocks: ServiceWorkers-postv1
All dependents fixed now.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Reporter)

Updated

a year ago
Blocks: 1131324
I've just checked, and it looks like we have already documented this sufficiently:
https://developer.mozilla.org/en-US/docs/Web/API/Clients/matchAll

Setting ddn -> ddc.
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.