Closed Bug 1130788 Opened 8 years ago Closed 7 years ago

[e10s] Resizing browser causes spinner to appear indefinitely

Categories

(Core :: Graphics, defect)

x86_64
Windows 7
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 1147728
Tracking Status
e10s m6+ ---

People

(Reporter: bjornson, Assigned: gw280)

References

(Blocks 1 open bug)

Details

(Whiteboard: gfx-noted, hardware accel disabled, hardware info in comment 6)

Resize the browser window. Page content is replaced with a large spinner (progress indicator) and never replaced with the content.
I can not reproduce the issue with a local build Firefox38 (32 bit) on windows7
Can we please have a little bit more context ?

32 or 64 bit build, did you try the safemode/new profile ?
Is this a new issue and did it worked in previous nightly builds ?
Does this happen independent of the loaded content ?
Flags: needinfo?(bjornson)
Sorry for the brevity.

- 64 bit build.
- Only happens with e10s enabled.
- Does not happen in safemode.
- Does happen if I disable all addons.
- Dose happen after using Refresh Firefox.
- New in the last ~36 hours or so.
- Independent of content, any page.

I think this is the same problem -- at least the same symptom: after restarting FF, restored tabs do not load but instead just show the spinner.
Flags: needinfo?(bjornson)
>- Does not happen in safemode
and what happens if you just disable the hardware acceleration under options/advanced/general ?
The safemode disables not only the addons but also the hardware acceleration
Does not happen with hardware acceleration disabled.
Can you please post the graphic section of about:support ?
Severity: blocker → major
Component: General → Graphics
Product: Firefox → Core
Version: Firefox 38 → Trunk
Adapter Description	Intel(R) HD Graphics Family
Adapter Drivers	igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
Adapter RAM	Unknown
Device ID	0x0126
Direct2D Enabled	Blocked for your graphics driver version.
DirectWrite Enabled	false (6.2.9200.16492)
Driver Date	11-28-2011
Driver Version	8.882.2.4000
GPU #2 Active	false
GPU Accelerated Windows	0/1 Basic (OMTC) Blocked for your graphics driver version.
Subsys ID	168a103c
Vendor ID	0x8086
WebGL Renderer	Blocked for your graphics driver version.
windowLayerManagerRemote	true
AzureCanvasBackend	skia
AzureContentBackend	cairo
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
For what it's worth, I have switchable graphics and this issue does not happen with the Radeon HD 7690M XT running.
Flags: needinfo?(gwright)
Summary: [e10s] Resizing browser causes content to disappear → [e10s] Resizing browser causes spinner to appear indefinitely
Can you post the about:support for when your 7690M is active?
Flags: needinfo?(bjornson)
Adapter Description	Radeon (TM) HD 7690M XT
Adapter Description (GPU #2)	Intel(R) HD Graphics Family
Adapter Drivers	aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter Drivers (GPU #2)	igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
Adapter RAM	1024
Adapter RAM (GPU #2)	Unknown
Device ID	0x6740
Device ID (GPU #2)	0x0126
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16492)
Driver Date	11-28-2011
Driver Date (GPU #2)	11-28-2011
Driver Version	8.882.2.4000
Driver Version (GPU #2)	8.882.2.4000
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	168a103c
Subsys ID (GPU #2)	168a103c
Vendor ID	0x1002
Vendor ID (GPU #2)	0x8086
WebGL Renderer	Google Inc. -- ANGLE (Radeon (TM) HD 7690M XT Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Flags: needinfo?(bjornson)
Whiteboard: gfx-noted
George, what's the status on this one? Can we reproduce this with the same config?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: gfx-noted → gfx-noted, hardware accel disabled, hardware info in comment 6
I haven't been able to reproduce it locally but it appears related to the bugs which cover issues with e10s on RDP and virtual machines (e.g. bug 1135247, bug 1128062, etc).

I'm currently working on the RDP bug so hopefully that should cover this as well.
Flags: needinfo?(gwright)
Assignee: nobody → gwright
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1147728
You need to log in before you can comment on or make changes to this bug.