[e10s] Spinner of death opening Firefox through Remote Desktop (RDP)

RESOLVED DUPLICATE of bug 1147728

Status

()

Core
Graphics
--
critical
RESOLVED DUPLICATE of bug 1147728
3 years ago
3 years ago

People

(Reporter: jib, Assigned: gw280)

Tracking

(Blocks: 2 bugs)

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10sm6+)

Details

(URL)

Attachments

(1 attachment)

Created attachment 8567312 [details]
about:support

STR
1. On Windows 7, make sure Nightly is closed.
2. Remote Desktop into machine from another system.
3. Open Nightly.

Expected results:
1. Nightly start page appears.
2. if I add a tab and ype in the URL then that page appears to.
3. I can resize window without incident.

Actual result:
1. Nightly start page is an entirely blank page and nothing happens.
2. I open an new tab and enter the URL and I get the giant spinner
   of death indefinitely. Tabbing back to Nightly start page shows
   a spinner there too now.
3. Several other URLs like google.com seem to work, but even on
   these working pages, if I resize the browser window then I get
   the spinner there as well indefinitely.

Workarounds (either of these work):
A. Open a New non-e10s window => everything works.
B. In STR step 1, open Nightly *first* and then Remote Desktop => works.

This is likely the same problem as Bug 1130788, since I can reproduce that one consistently with these STRs, but I decided to file a separate bug since my symtpoms are more severe and contained to RDP for me. I can hardly use Firefox at all this way.
I forgot another Workaround:
C. Hold SHIFT to open Nightly in Safe Mode.

But this may be a red herring, as it looks like e10s is not enabled in safe mode (tabs are not underlined,  even though "Enabled E10S (multi-process)" is checked)?

I'm able to reproduce this with a new profile (although I seem to have a confounding number of plugins even by default. Ugh wish that were simpler to nuke a lot of that)

I should also mention this is a fresh pull off of m-c today.
Depends on: 1131167
See Also: → bug 1130788
Blocks: 1131167
No longer depends on: 1131167
(In reply to Jan-Ivar Bruaroey [:jib] from comment #1)
> But this may be a red herring, as it looks like e10s is not enabled in safe
> mode (tabs are not underlined,  even though "Enabled E10S (multi-process)"
> is checked)?

Yes, e10s is disabled in safe mode.
(In reply to Jan-Ivar Bruaroey [:jib] from comment #0)
> This is likely the same problem as Bug 1130788, since I can reproduce that
> one consistently with these STRs, but I decided to file a separate bug since
> my symtpoms are more severe and contained to RDP for me. I can hardly use
> Firefox at all this way.

Are you using BasicLayers with RDP? I assume so, as there probably isn't any hardware acceleration available. If it's Basic without OMTC then I'd expect e10s to not work.
Never mind, just saw your about:support attachment and it is using OMTC.
I worry we'll shed windows developers once this goes to Firefox Developer Edition... Remote Desktop is sort of a thing.
Severity: normal → critical

Comment 6

3 years ago
I just tested connecting from Win7 to Win8 using RDP and I don't see any issues. 

Graphics
--------

Adapter Description: RDPUDD Chained DD
Adapter Description (GPU #2): Intel(R) HD Graphics 4000
Adapter Drivers: RDPUDD
Adapter Drivers (GPU #2): igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
Adapter RAM: Unknown
Adapter RAM (GPU #2): Unknown
Device ID: 0x0000
Device ID (GPU #2): 0x0166
Direct2D Enabled: Blocked for your graphics card because of unresolved driver issues.
DirectWrite Enabled: false (6.3.9600.17415)
Driver Date (GPU #2): 3-7-2014
Driver Version (GPU #2): 10.18.10.3496
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 WARP (OMTC)
Subsys ID: 00000000
Subsys ID (GPU #2): 01661414
Vendor ID: 0x0000
Vendor ID (GPU #2): 0x8086
WebGL Renderer: Blocked for your graphics card because of unresolved driver issues.
windowLayerManagerRemote: true
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0


Juan, can QE folks give us some help here? We're looking for rendering issues in Nightly when connecting via RDP. A Win7 -> Win7 connection needs testing, I've tried Win7 -> Win8.
Flags: needinfo?(jbecerra)
(In reply to Jim Mathies [:jimm] from comment #6)
> I just tested connecting from Win7 to Win8 using RDP and I don't see any
> issues. 
> 
...
> 
> 
> Juan, can QE folks give us some help here? We're looking for rendering
> issues in Nightly when connecting via RDP. A Win7 -> Win7 connection needs
> testing, I've tried Win7 -> Win8.

Win8.1 -> Win7:
I haven't been able to reproduce the problem yet, but I will report back shortly after testing on a few machines with different types of graphics cards configurations, and by going Win7 -> Win7 as well.
Flags: needinfo?(jbecerra)
I have been able to reproduce this reliably now on three machines, with slightly different flavors of Win7 and different graphics cards.

Jim, please ping me for machine credentials so you can connect remotely to them.
Flags: needinfo?(jmathies)

Comment 9

3 years ago
I can reproduce locally now. The RDP connection must be to Win7, from Win7 or Win8.
Flags: needinfo?(jmathies)
tracking-e10s: --- → m6+
(Assignee)

Updated

3 years ago
Assignee: nobody → gwright
Looks like you're able to reproduce it, which is great. FWIW I was remoting in from OSX -> Win7 with Remote Desktop Connection.
And I can reproduce it from Linux -> Juan's machine using rdesktop. I couldn't reproduce RDPing to the Toronto Windows RDP dev machine which runs Windows Server 2012 though.

Updated

3 years ago
Duplicate of this bug: 1134704

Updated

3 years ago
Summary: [e10s] Spinner of death opening Firefox through Remote Desktop → [e10s] Spinner of death opening Firefox through Remote Desktop (RDP)

Updated

3 years ago
Blocks: 1111396
Can you flip the layers.prefer-d3d9 pref to true and let me know if that causes the pages to start rendering properly?
Flags: needinfo?(jib)
That fixes it.
Flags: needinfo?(jib)
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1147728

Updated

3 years ago
Blocks: 993639

Updated

3 years ago
No longer blocks: 1111396
You need to log in before you can comment on or make changes to this bug.