[RTL][Dialer]The position of buttons on toolbar is mirrored at active call screen.

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
P1
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: autra)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(2 attachments)

Posted image toolbar.png
[1.Description]:
[RTL][Dialer]When you MO a call, the position of buttons on toolbar is mirrored, the pause button is left-aligned and mute button is right-aligned.
See attachment:toolbar.png

[2.Testing Steps]: 
Prerequisite: Set system language as Arabic.
1. Launch Phone app.
2. Make a call.
3. Observe the toolbar(such as pause, dailer button).

[3.Expected Result]: 
3. The position of buttons on toolbar should not be mirrored.

[4.Actual Result]: 
3. The position of buttons on toolbar is mirrored.

[5.Reproduction build]: 
Flame 2.2 build:
Build ID               20150209002504
Gaia Revision          e827781324cbde91d2434b388f5dead3303a85ee
Gaia Date              2015-02-06 20:54:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0552759956d3
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150209.040038
Firmware Date          Mon Feb  9 04:00:51 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
QA Whiteboard: [rtl-impact]
triage: P1, the toolbar should not be reversed
feature-b2g: --- → 2.2+
Priority: -- → P1
Sue, can you file a new bug for the + sign being in the wrong place on this same screen?
Flags: needinfo?(lulu.tian)
(In reply to Dylan Oliver [:doliver] from comment #2)
No need to file a bug for that, bug 1131246 already exists.
Flags: needinfo?(lulu.tian)
QA Contact: augustin.trancart
QA Contact: augustin.trancart
Assignee: nobody → augustin.trancart
Comment on attachment 8562879 [details] [review]
[gaia] autra:bug-1131492 > mozilla-b2g:master

Hi Gabriel,

Could you review this please? Thanks!
Attachment #8562879 - Flags: review?(gsvelto)
Comment on attachment 8562879 [details] [review]
[gaia] autra:bug-1131492 > mozilla-b2g:master

The fix works but I'd rather see the element's direction be set directly in the HTML code instead, see here:

https://github.com/mozilla-b2g/gaia/blob/bc0036116ab2f66dd56bf85e64c879b462311a46/apps/callscreen/index.html#L159

Since this is unconditional I'd rather not add another CSS rule just for it.
Attachment #8562879 - Flags: review?(gsvelto) → review-
Comment on attachment 8562879 [details] [review]
[gaia] autra:bug-1131492 > mozilla-b2g:master

Indeed it makes sense. Thanks!
Attachment #8562879 - Flags: review- → review?(gsvelto)
Comment on attachment 8562879 [details] [review]
[gaia] autra:bug-1131492 > mozilla-b2g:master

Excellent, thanks!
Attachment #8562879 - Flags: review?(gsvelto) → review+
Augustin, can this be landed now?
Flags: needinfo?(augustin.trancart)
Flags: needinfo?(augustin.trancart)
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8562879 [details] [review]
[gaia] autra:bug-1131492 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): not a regression (I  think)
[User impact] if declined: button will be in the wrong order, but still usable. Low impact
[Testing completed]: on flame v2.2
[Risk to taking this patch] (and alternatives if risky): very low
[String changes made]: None
Attachment #8562879 - Flags: approval-gaia-v2.2?
Attachment #8562879 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on the latest Nightly  Flame KK 3.0 and 2.2 builds.

Actual Results: The icons are not reversed in RTL.

Environmental Variables:
Device: Flame 3.0 KK (Full Flash) (319 MB)
BuildID: 20150223010224
Gaia: a6881205deae450757a8d1e1ed65e5e5be0ec633
Gecko: 86d2bb8bb1c9
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Environmental Variables:
Device: Flame 2.2 KK (Full Flash) (319 MB)
BuildID: 20150223002503
Gaia: 389542b71c89253c0d176d3b0bfb54e275c19bf1
Gecko: 9fd3441c8983
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15425/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.