[RTL][Dialer]The control icons [mute, keyboard, add call, speaker, pause] are not reversed.

VERIFIED DUPLICATE of bug 1217377

Status

Firefox OS
Gaia::Dialer
VERIFIED DUPLICATE of bug 1217377
3 years ago
3 years ago

People

(Reporter: Alissa(leave from Mozilla), Assigned: gsvelto)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.5 verified, b2g-master verified)

Details

(Whiteboard: [2.5-rtl-test-run])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8677985 [details]
Dialer_control button.png

[1.Description]:
[RTL][Arieskk_v2.5][Flamekk_v2.5][Dialer]The control icons [mute, keyboard, add call, speaker, pause] are not reversed.
See attachment: Dialer_control button.png

[2.Testing Steps]: 
1. Set your phone language to Arabic and launch Dialer. 
2. Make a call. 
3. Observe the connecting view.

[3.Expected Result]: 
3.The control icons [mute, keyboard, add call, speaker, pause] should be reversed

[4.Actual Result]: 
3.All the button remain the same as LTR way.

[5.Reproduction build]: 
Device: AriesKK_2.5 [Affected]
Build ID               20151023005002
Gaia Revision          29ce8ec8606e59f582375234440812b046346513
Gaia Date              2015-10-22 05:31:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1f03a14106e59280761ac53904340f389674337f
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151023.001128
Firmware Date          Fri Oct 23 00:11:35 UTC 2015
Bootloader             s1

Device: FlameKK_v2.5[Affected]
Build ID               20151022150207
Gaia Revision          29ce8ec8606e59f582375234440812b046346513
Gaia Date              2015-10-22 05:31:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/76bd0c01d72e64ca4f261ffdb2652a91f961e930
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151022.185000
Firmware Date          Thu Oct 22 18:50:13 EDT 2015
Base image                              v18d v4
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
15425
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
status-b2g-master: --- → affected
(Assignee)

Comment 1

3 years ago
This is by design, see bug 1131492. Has the rationale behind that bug changed and we do want to reverse the icons now?
See Also: → bug 1131492
Mermi, can you weigh in please, since you're a native Arabic person?
Flags: needinfo?(manelmozz)
We should follow the RTL 2.5 specs, which mention: "tool bar icons should be mirrored" (see https://mozilla.app.box.com/s/sp6lzaf2aimv4i7juafelthg74e6pgys/1/4635667922/39239281605/1)
So this is a valid bug. thanks
Flags: needinfo?(manelmozz)
(In reply to Delphine Lebédel [:delphine - use need info] from comment #3)
> We should follow the RTL 2.5 specs, which mention: "tool bar icons should be
> mirrored" (see
> https://mozilla.app.box.com/s/sp6lzaf2aimv4i7juafelthg74e6pgys/1/4635667922/
> 39239281605/1)
> So this is a valid bug. thanks

The fact that UX did not object on that spec rule also reassures that ^. This is a valid bug.
No longer blocks: 1217377

Updated

3 years ago
Depends on: 1217377
(Assignee)

Comment 5

3 years ago
Great, thanks for clearing this up.
(Assignee)

Updated

3 years ago
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Created attachment 8680008 [details] [review]
[gaia] gabrielesvelto:bug-1217759-advanced-call-options-rtl-fix > mozilla-b2g:master
(Assignee)

Comment 7

3 years ago
Comment on attachment 8680008 [details] [review]
[gaia] gabrielesvelto:bug-1217759-advanced-call-options-rtl-fix > mozilla-b2g:master

Super-quick one-line fix.
Attachment #8680008 - Flags: review?(thills)

Comment 8

3 years ago
FWIW my PR for bug 1217377 also includes this fix.

Up to you to decide if you prefer a single PR to fix all RTL issues or if you prefer to apply your patch first.
Fix will land in bug 1217377
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1217377
Comment on attachment 8680008 [details] [review]
[gaia] gabrielesvelto:bug-1217759-advanced-call-options-rtl-fix > mozilla-b2g:master

Canceling as it looks like it's getting landed in another bug.
Attachment #8680008 - Flags: review?(thills)
Created attachment 8684867 [details]
Verify_pass.png

This bug has been verified as "pass" on the latest build of Aries KK 2.5/v2.6 and Flame KK v2.5/v2.6 512mb 
by STR in comment 0.
Actual results: The control icons [mute, keyboard, add call, speaker, pause] is reversed.
See attachment: Verify_pass.png
Reproduce rate: 0/10

Device: Aries KK 2.6 (master)(pass)
Build ID               20151107001102
Gaia Revision          c3436122d678911d04b8f491724596116890ff9b
Gaia Date              2015-11-06 18:22:03
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e2a910c048dc82fc3be53475f18e7f81f03e377b
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151106.232924
Firmware Date          Fri Nov  6 23:29:32 UTC 2015
Bootloader             s1

Device: Aries KK 2.5(pass)
Build ID               20151107112205
Gaia Revision          577948202ae12154524a2bd2bd6d467838ad50b8
Gaia Date              2015-11-07 10:00:59
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/ae7b8b1fd9e1504347b938820f99d75058049386
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151107.104119
Firmware Date          Sat Nov  7 10:41:27 UTC 2015
Bootloader             s1

Device: Flame KK 2.6 512mb (master)(pass)
Build ID               20151108150206
Gaia Revision          c3436122d678911d04b8f491724596116890ff9b
Gaia Date              2015-11-06 18:22:03
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e2a910c048dc82fc3be53475f18e7f81f03e377b
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151108.183921
Firmware Date          Sun Nov  8 18:39:33 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 512mb (pass)
Build ID               20151108004501
Gaia Revision          577948202ae12154524a2bd2bd6d467838ad50b8
Gaia Date              2015-11-07 10:00:59
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/ae7b8b1fd9e1504347b938820f99d75058049386
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151108.045623
Firmware Date          Sun Nov  8 04:56:35 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
status-b2g-v2.5: --- → verified
status-b2g-master: affected → verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.