Wishlist FAQ has become a historical relic

VERIFIED FIXED

Status

www.mozilla.org
General
VERIFIED FIXED
16 years ago
5 years ago

People

(Reporter: Mike Simons, Assigned: hsivonen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 4 obsolete attachments)

(Reporter)

Description

16 years ago
This FAQ was last updated 1999-12-02.  Based on my quick reading it appears
that most things listed in the FAQ as not yet done have been done for months.
(Crypto in main, Prevent Animations, PNG Alpha Support, etc).

  I suggest that this FAQ get updated or moved to a history section of the site.  =)
Yes, it is quite different now from when I wrote this.  I no longer follow
wishlist, or Mozilla too much for that matter, so we'd need to find someone who
does to update this.

Comment 2

16 years ago
-> taking QA contact so I don't need to watch Dawn anymore. ;)
QA Contact: endico → imajes

Comment 3

15 years ago
I want to update the Wishlist FAQ. I'm running http://wishlist.mozdev.org. :)

Comment 4

15 years ago
I want to update the Wishlist FAQ. I'm running http://wishlist.mozdev.org. :)

Comment 5

15 years ago
Yes, please remove the page. See bug 65948

Comment 6

15 years ago
Created attachment 107562 [details] [diff] [review]
New FAQ

Comment 7

15 years ago
Created attachment 107563 [details]
New FAQ (HTML)

Comment 8

15 years ago
*** Bug 65948 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Keywords: patch

Comment 9

15 years ago
*** Bug 143988 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Blocks: 65447

Comment 10

15 years ago
*** Bug 166707 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

15 years ago
Created attachment 117316 [details]
Daniel Wang's FAQ with edits

* Switched to HTML 4.01 Strict. The www.mozilla.org wrapper makes XHTML 
  ill-formed.

* Used dl instead of ol, since the numbering isn't important (IMO) and the 
  issues come in issue-explanation pairs which can be represented as dt-dd 
  pairs. (Note: the <dt>s will be bolded by persistent-style.css once 
  the document is uploaded to www.mozilla.org.)
  
* marked <blink> up as <code>

* smartened quotes

* fixed ampersands in URLs

* used <code> instead of <blockquote> for a pref code example
  
* Spelling edits:
  no-one -> no one
  fully-customizable -> fully customizable
  Pheonix -> Phoenix
  javascript -> JavaScript
  XML 1 -> XML 1.0
  DOM 1 -> DOM Level 1
  flash -> Flash
  java -> Java
  availabe -> available
  ministrator -> administrator
  
* Edits to substance
  Mozilla currently has full support -> Mozilla currently supports (claiming 
    full support is a can of worms)
  XSL -> XSLT (There are no plans to support XSL-FO)
  SVG support -> Partial SVG support
  removed MS remarks from the MHTML answer
  changed wording regarding Mozilla versions to allowd more timelessness in the

    answer concerning mail and news filters
  added link to http://www.mozilla.org/docs/web-developer/faq.html#alttooltip

Daniel Wang, Matthew Tuck, is this OK for check-in?
Attachment #107562 - Attachment is obsolete: true
Attachment #107563 - Attachment is obsolete: true
(Assignee)

Comment 12

15 years ago
Taking bug since the default assignee hasn't commented.
Assignee: endico → hsivonen
(Assignee)

Comment 13

15 years ago
Created attachment 117317 [details]
Daniel Wang's FAQ with edits v2

Removed a useless <style> element I forgot to remove before attaching the
previous version.
Attachment #117316 - Attachment is obsolete: true

Comment 14

15 years ago
looks fine to me :-)
> Mozilla currently supports W3C HTML 4.01, XML 1.0, CSS 1, and DOM
> Level 1 and partial support for CSS 2, DOM 2 and 3, XSLT, XLink, and
> MathML. Partial SVG support is availabe but is not compiled into
> Mozilla releases.

I don't quite understand why this information is in a "Wishlist FAQ"... In
general, there seem several entries here which say "Mozilla has feature X." If
it has this feature, it can't be a wishlist item.

Also, if this document is a FAQ, why is it not structured like one? :-)

> Advertisement Blockers
> 
> There are various ways you can do this already, and it will probably
> possible to write a Mozilla plugin to do this. 

There is one - http://bannerblind.mozdev.org .

> However, this proposal
> is 1) unethical and 2) unimplementable as an open source organization
> like Mozilla.org could not and should not discriminate what content
> is acceptable or unacceptable to the user. Hence it is unlikely this
> will every appear in Mozilla or Communicator.

See http://www.mozilla.org/README-style.html under "Speak for yourself". You
should not be declaring things "unethical" in a mozilla.org-hosted document, or
making statements about mozilla.org policy. Please replace this paragraph with a
link to bannerblind, plus optionally a paragraph which begins "However, before
installing this software, you might like to consider that some websites rely on
advertising revenue..." 

> Support for mouse button 4 and 5 is being worked on, and with some
> luck should be implemented in Mozilla 1.3 (see bug 30431). 

Well, were they? :-) In general, it's good not to promise features by specific
releases.

Keyboard
> Shortcut Customisation
> 
> It is currently not possible to customise keyboard shortcuts. The
> relevent bug is bug 57805) and we need help on implementing this
> feature.

Surely this is true of most features on this page?

> Mozilla currently does not support AutoScroll (Panning) navigation,
> which in Internet Explorer is activated by pressing down the middle
> mouse button and draging the cursor and in other applications is a
> ‘hand’ cursor. Because there is no apparent standard on how
> AutoScroll is implemented, this enhancement still needs some
> discussion (see bug 22775 (AutoScroll)).

Why does this bug have "AutoScroll" next to it when other buglinks have no
similar designation?

> Turn Off <Blink>
> 
> There is currently no direct support for this in Mozilla, however, it
> is possible to do this with a user CSS stylesheet. 

Link to instructions?

Gerv

Comment 16

15 years ago
I've been following the wishlist page (off-and-on) for a while now.  The reason
for those "Mozilla has feature X" bits is likely to be pure archaeology.  Also,
it'd be nice to have a page of "frequently requested Mozilla features that
already exist".  Mozilla is so big that some of the more interesting features
are buried behind the normal everyday features.

[short digression on ad blocking]
I agree with keeping the ethical issues of blocking ads off of the wishlist
page.  There are several sites that both depend on ad revenue, and don't care
that much if you block ads on that site.  There are people who are so easily
distracted by flashing bouncing <blink>ing things that they'd have trouble
getting useful work done on the current web without blocking ads.  It's a bit
pointless to argue about whether ad blocking should be implemented, since there
are several ways of doing it now.  The cat's out of the bag.
[end digression]

I think the wishlist should be a list of oft-requested features that either a)
exist already, b) require much work to implement, or c) will never be
implemented due to architecture issues.  Perhaps sorted by number of requests,
or which of the categories the feature fits.

For features that exist already, there should be some pointer to how to access
them.  For "much work required" features, some indication of what sort of work
is needed would be useful (code, art, whatever).  For features denied by design,
if it's possible to explain why quickly, it should be on the page.  If it's too
complicated to explain, perhaps a pointer to another doc would be good.

After thinking about this for a bit, I can see why the wishlist doesn't get
updated very often.  Too many questions, and Mozilla gets updated so fast that
it is difficult to keep up with which features have been implemented already. 
Hence the usefulness of putting a link to a bug in, so that a user could check
things.
(Assignee)

Comment 17

15 years ago
Created attachment 120596 [details]
Daniel Wang's FAQ with more edits
Attachment #117317 - Attachment is obsolete: true
(Assignee)

Comment 18

15 years ago
> I don't quite understand why this information is in a "Wishlist FAQ"... In
> general, there seem several entries here which say "Mozilla has feature X." 
> If it has this feature, it can't be a wishlist item.

Fixed.

> Also, if this document is a FAQ, why is it not structured like one? :-)

It isn't a FAQ, but let's keep the URL.

> See http://www.mozilla.org/README-style.html under "Speak for yourself". 
> You should not be declaring things "unethical" in a mozilla.org-hosted 
> document

Yes, I should have done something about it earlier. Fixed.

> In general, it's good not to promise features by specific
> releases.

Fixed.

> Surely this is true of most features on this page?

Fixed.

> Link to instructions?

Added inline.
(Assignee)

Comment 19

15 years ago
Checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 20

15 years ago
http://wiki.mozdev.org:8080/cgi-bin/mozdev-wiki.pl?WishlistFAQ

Wishlist FAQ at MozDev.org is now availiable on Wiki, meaning anyone can edit
it. I'm not totally done in porting over the information from the original
Wishlist site. 

Also, references to Phoenix will probably have to be change to Firebird (the
tentative offical new name.) Furthermore, customizable toolbars wish should be
changed, since the Mozilla suite will be broken up, and the Firebird will become
the browser, and Minotaur (Thunderbird) will become the mail client. 

Comment 21

15 years ago
v

should add
 tabbed browser bug 104778
 delete attachment bug 2920

a "all bugs listed here" link would be nice
Status: RESOLVED → VERIFIED
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.