[Calendar] notifications aren't closed during click if it was triggered while the calendar app was closed

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: mmedeiros, Assigned: mmedeiros)

Tracking

({regression})

unspecified
2.2 S7 (6mar)
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(1 attachment)

steps to reproduce:

 1. create a new event with a reminder;
 2. close the calendar app before the notification is fired;
 3. tap the notification (can be on the lockscreen, tray or toast);

expected:

it should open the calendar app on the correct event and delete the notification.

actual:

notification remains on the tray.
Assignee: nobody → mmedeiros
blocking-b2g: --- → 2.2?
Keywords: regression
Depends on: 1120857
Comment on attachment 8563716 [details] [review]
[gaia] millermedeiros:1132336-notification-click-close > mozilla-b2g:master

added a "tag" to all the notifications ("tag" works like an ID) so if the app creates multiple notifications for same URL it will consider as a single notification (will override the previous one). It also uses the "tag" to find and close all the notifications during `launch`, that way we use the same logic if app is open or closed avoiding this kind of error.

also added some safeguards against the unlikely case of a busytime or event being null for some reason when the alarm is triggered (I think I saw it happen but was not able to reproduce).
Attachment #8563716 - Flags: review?(gaye)
Target Milestone: --- → 2.2 S6 (20feb)
Comment on attachment 8563716 [details] [review]
[gaia] millermedeiros:1132336-notification-click-close > mozilla-b2g:master

LGTM!
Attachment #8563716 - Flags: review?(gaye) → review+

Comment 4

4 years ago
Triage is blocking because this is a regression.
blocking-b2g: 2.2? → 2.2+
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8563716 [details] [review]
[gaia] millermedeiros:1132336-notification-click-close > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1042939
[User impact] if declined: user will need to delete the notification manually and might cause confusion (it's a regression and bad UX)
[Testing completed]: manual
[Risk to taking this patch] (and alternatives if risky): very low risk, changes are local and should not cause conflicts
[String changes made]: none
Attachment #8563716 - Flags: approval-gaia-v2.2?
Attachment #8563716 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on the latest Nightly 3.0 and 2.2 builds.
	
Actual results:  The notifications are dismissed when pressed on for calendar events even if the calendar is closed.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150226010233
Gaia: 7894b929f1b0394f3c997f72a6482bc7813e758d
Gecko: dd6353d61993
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150226002503
Gaia: bf24aa57fa7760260ab05d1f53242c8d8ae59e83
Gecko: 363123044e61
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.