[Text Selection] "Headline", "History result", and ""Search Suggestion" in Rocketbar result set should not be selected

VERIFIED DUPLICATE of bug 1127743

Status

defect
VERIFIED DUPLICATE of bug 1127743
4 years ago
4 years ago

People

(Reporter: hcheng, Unassigned)

Tracking

unspecified
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+)

Details

*Description
As a user, I don't want to select "Headline", "History result", and ""Search Suggestion" when I use search app.

*Steps:
1. enter rocketbar, and type some input
2. long tap headline such as "HISTORY" or "GOOGLE SEARCH"
3. long tap history results
4. long tap search suggestion results

*Expected result:
nothing happen

*Actual result:
At step 2, headline is selected.
At step 3, both website name or URL of history result are selected.
At step 4, search suggestion is selected.
env info
Build ID               20150211162505
Gaia Revision          791e53728cd8018f1d7cf7efe06bbeb1179f0370
Gaia Date              2015-02-11 19:31:02
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/dcf030ef499d
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150211.194909
Firmware Date          Wed Feb 11 19:49:19 EST 2015
Bootloader             L1TC000118D0
blocking-b2g: --- → 2.2?
QA Whiteboard: [COM=Text Selection]
This shall be fixed in 1127743
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1127743
Lets verify this once the DUP is uplifted.
blocking-b2g: 2.2? → 2.2+
Keywords: verifyme
NI myself to follow up
Flags: needinfo?(hcheng)
Verified in below builds.
*2.2:
Build ID               20150225162504
Gaia Revision          e4bf968d5a7366e7bdc58f0fdba28b32e864bdf7
Gaia Date              2015-02-25 18:39:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/da6ac51f5113
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.200419
Firmware Date          Wed Feb 25 20:04:31 EST 2015
Bootloader             L1TC000118D0


*master:

Build ID               20150225160227
Gaia Revision          cc235a867161e0000ea55a4f009b3be19021f066
Gaia Date              2015-02-25 05:01:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6608e0605dfc
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.192909
Firmware Date          Wed Feb 25 19:29:21 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Flags: needinfo?(hcheng)
Per comment 3 & comment 5, clear 'verifyme' keyword.
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.