Rocketbar's FTU message is selectable

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: shinglyu, Assigned: mancas)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [Text Selection][2.2-CP-bug-bash])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Posted image screenshot
Description

The FTU message for rocketbar is selectable.

Steps to Reproduce

* Reset or flash the phone to reset it back to factory settings.
* Click through the FTU.
* Click the "Search or enter address" to bring up the FTU.
* A floating box will show up to introduce the rocketbar (see the attachment).
* Long press the text in the floating box.

Expected Results

The text in the box should not be selectable.

Actual Results

The text is selected.

Other Notes


Reproduction Frequency: 

100%

Updated

4 years ago
Blocks: CopyPasteGaia
No longer blocks: CopyPasteLegacy
blocking-b2g: --- → 2.2?
Whiteboard: [2.2-CP-bug-bash] → [2.2-CP-bug-bash][systemsfe]
Whiteboard: [2.2-CP-bug-bash][systemsfe] → [Text Selection][2.2-CP-bug-bash]
This text selection bug is owned by sys-platorm
Flags: needinfo?(hochang)

Comment 2

4 years ago
Hi Candice, I'm tracking copy paste gecko work and Gaia apps that are owned by sys-platform (settings, lockscreen, keyboard...etc). But there is per Gaia app work/bug that needs every team's help.

I'd say this one should block, can you help to find someone for this? Thank you.
Flags: needinfo?(hochang) → needinfo?(cserran)
(Assignee)

Comment 4

4 years ago
Hi Candice who is the best person to review this patch? It prevents the user from select any text in the search page. Also the patch fixes this bug1124575
Assignee: nobody → b.mcb
Hey Manuel

You can give the view to me or Ben Francis

Cheers
Flags: needinfo?(cserran)
(Assignee)

Comment 6

4 years ago
Comment on attachment 8560381 [details] [review]
[PullReq] mancas:bug1127743 to mozilla-b2g:v2.2

Thanks Dale!
Attachment #8560381 - Flags: review?(dale)
Comment on attachment 8560381 [details] [review]
[PullReq] mancas:bug1127743 to mozilla-b2g:v2.2

Retriggered the single failing tests, assume it is unrelated. 

The patch should be done against master and then uplifted, so if you land, please do it against master

Cheers
Attachment #8560381 - Flags: review?(dale) → review+
Duplicate of this bug: 1132365
Try is green, merged to master in https://github.com/mozilla-b2g/gaia/commit/09349e1038ceb73a02ff2824da652cec48460c3d
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S6 (20feb)
Duplicate of this bug: 1127731
(In reply to Dale Harvey (:daleharvey) from comment #9)
> Try is green, merged to master in
> https://github.com/mozilla-b2g/gaia/commit/
> 09349e1038ceb73a02ff2824da652cec48460c3d

Dale, can you please request 2.2 approval on this if this is ready to land? Thanks!
blocking-b2g: 2.2? → 2.2+
Dale, can you please uplift to 2.2?
Flags: needinfo?(dale)
(Assignee)

Comment 13

4 years ago
Comment on attachment 8560381 [details] [review]
[PullReq] mancas:bug1127743 to mozilla-b2g:v2.2

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Text Selection
[User impact] if declined: The user can select a non-selectable text
[Testing completed]: No need, just a CSS change
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]:None
Attachment #8560381 - Flags: approval-gaia-v2.2?
Attachment #8560381 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual Results: The search suggestions message could not be selected.

Environmental Variables:
Device: Flame 3.0 KK (319MB) (Full Flash)
BuildID: 20150305010212
Gaia: eff3321ab4e65da3f906688ebb55ddf1e93d9452
Gecko: 56492f7244a9
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (319MB) (Full Flash)
BuildID: 20150305002528
Gaia: 89af288bad6751248ff84504fa898206fee127fe
Gecko: 6d8d294aa8f3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.