Closed Bug 1132535 Opened 6 years ago Closed 6 years ago

[e10s] tabbing between form elements is very slow

Categories

(Add-on SDK Graveyard :: General, defect, P1)

x86_64
Linux
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1129567

People

(Reporter: froydnj, Unassigned)

References

Details

STR:

1. File a new Bugzilla bug:

https://bugzilla.mozilla.org/enter_bug.cgi

2. Click in the "QA Contact" box.  I don't think it really matters which form element is chosen.

3. Hit <TAB> to switch focus to the next element (the "CC:" label)

Expected results:

Focusing is virtually instantaneous.

Actual results:

Focusing takes long enough that you can almost count the seconds.  My stopwatch says it was about 1.9 seconds to switch focus.
Nathan, I can't repo. Do you have any addons installed?
Flags: needinfo?(nfroyd)
about:support says:

Mozilla Tree Status	1.0.1	true	mozilla-tree-status@jsantell.com
Test Pilot	1.2.3	true	testpilot@labs.mozilla.com

(I have a couple others installed, but they're all disabled, so I'm not listing them here.)
Flags: needinfo?(nfroyd)
Can you try with those disabled?
Flags: needinfo?(nfroyd)
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #3)
> Can you try with those disabled?

Wickedly fast again.  Is that just addon CPOW traffic gumming up IPC or something?
Flags: needinfo?(nfroyd)
Apparently the slowness is from Mozilla Tree Status (possibly Test Pilot, but I didn't check).  Sigh.
A lot of addons now have the CPOW warning message, even if they don't seem to be using CPOWs (MTS included here, does nothing other than render a button, and send an XHR once every 5 minutes by default, very unexciting). A few fixes to reduce CPOW traffic were just implemented in bug 1133834 and bug 1133834 that should speed up all addons that use these components. Moving this over to SDK components.
Blocks: e10s-sdk
Product: Firefox → Add-on SDK
(In reply to Jordan Santell [:jsantell] [@jsantell] from comment #6)
> A lot of addons now have the CPOW warning message, even if they don't seem
> to be using CPOWs (MTS included here, does nothing other than render a
> button, and send an XHR once every 5 minutes by default, very unexciting). A
> few fixes to reduce CPOW traffic were just implemented in bug 1133834 and
> bug 1133834 that should speed up all addons that use these components.

For the curious, what was the second bug supposed to be?  It looks like you listed the same bug twice.
Flags: needinfo?(jsantell)
(In reply to Jordan Santell [:jsantell] [@jsantell] from comment #6)
> A lot of addons now have the CPOW warning message, even if they don't seem
> to be using CPOWs (MTS included here, does nothing other than render a
> button, and send an XHR once every 5 minutes by default, very unexciting). A
> few fixes to reduce CPOW traffic were just implemented in bug 1133834 and
> bug 1133834 that should speed up all addons that use these components.
> Moving this over to SDK components.

The slowness you're talking about should only affect page load. Tabbing between elements shouldn't be affected and I have Tree Status installed and can't reproduce it. My money is on test pilot tbh.
(In reply to Dave Townsend [:mossop] from comment #8)
> The slowness you're talking about should only affect page load. Tabbing
> between elements shouldn't be affected and I have Tree Status installed and
> can't reproduce it. My money is on test pilot tbh.

It's not Test Pilot (or, at least, I have Test Pilot turned off currently--I don't want to restart my browser a bunch of times to toggle Test Pilot on and off--it's possible Test Pilot causes slowness too); Tree Status is the only addon I have activated, and flipping it off makes tabbing noticeably faster.
oops, bug 1132753
Flags: needinfo?(jsantell)
The tree status addon is really small, so could be a good case of investigating if one of the core SDK modules is causing this. https://github.com/jsantell/mozilla-tree-status/tree/master/lib

As a sanity check, in your preferences, is the rate to check the tree status set to a reasonable number? Default is 5 minutes, checks simple-prefs, then uses the sdk/request module to pull down JSON, then possibly a notification. Uses some core components like event/core|target and promises, and if one of those is causing a slowdown issue, that's really bad.
(In reply to Nathan Froyd [:froydnj] [:nfroyd] from comment #9)
> (In reply to Dave Townsend [:mossop] from comment #8)
> > The slowness you're talking about should only affect page load. Tabbing
> > between elements shouldn't be affected and I have Tree Status installed and
> > can't reproduce it. My money is on test pilot tbh.
> 
> It's not Test Pilot (or, at least, I have Test Pilot turned off currently--I
> don't want to restart my browser a bunch of times to toggle Test Pilot on
> and off--it's possible Test Pilot causes slowness too); Tree Status is the
> only addon I have activated, and flipping it off makes tabbing noticeably
> faster.

Can you try with the test build in bug 1129567 comment 24 and see if it fixes things?
(In reply to Jordan Santell [:jsantell] [@jsantell] from comment #11)
> As a sanity check, in your preferences, is the rate to check the tree status
> set to a reasonable number?

I haven't changed this, so it's 5 minutes per default.

(In reply to Dave Townsend [:mossop] from comment #12)
> Can you try with the test build in bug 1129567 comment 24 and see if it
> fixes things?

I will try, sure.
(In reply to Dave Townsend [:mossop] from comment #12)
> Can you try with the test build in bug 1129567 comment 24 and see if it
> fixes things?

This build does make things faster; I don't think there's noticeable difference between tree status enabled vs. disabled now.
Status: NEW → RESOLVED
Closed: 6 years ago
Priority: -- → P1
Resolution: --- → DUPLICATE
Duplicate of bug: 1129567
You need to log in before you can comment on or make changes to this bug.