Closed Bug 1133156 Opened 5 years ago Closed 5 years ago

Introduction of "soft" checks for HTTP framing errors broke hallmark.com, Wordpress and some other sites with CSS after gzdeflate()

Categories

(Core :: Networking: HTTP, defect, major)

defect
Not set
major

Tracking

()

RESOLVED FIXED
Tracking Status
firefox37 --- unaffected
firefox38 + fixed

People

(Reporter: jst, Assigned: bagder)

References

()

Details

(Keywords: regression)

The fix for bug 237623 broke http://www.hallmark.com (right before Valentines day, no less! :). The side loads, but its css file doesn't (and possibly others). Flipping the pref network.http.enforce-framing.soft to false makes the site work again.
[Tracking Requested - why for this release]: This regressed in 38.
And hat-tip to billm for tracking down the regression!
this browser thing would be a lot easier without damn web comapt.

backed out bug 237623 in comment 3 and we'll try it again.
thanks jst
It also broke CSS loading for http://www.sueddeutsche.de, one of the top German news portals.

I didn't open a new bug since it's already backed out, but you may want to check this site as well before re-enabling it.
Did the backout get stuck in inbound and never got to m-c ?
(In reply to Daniel Stenberg [:bagder] from comment #7)
> Did the backout get stuck in inbound and never got to m-c ?

s/never/not yet/

looks that way https://tbpl.mozilla.org/
Duplicate of this bug: 1133193
Duplicate of this bug: 1133239
Severity: normal → major
Summary: Introduction of "soft" checks for HTTP framing errors broke hallmark.com → Introduction of "soft" checks for HTTP framing errors broke hallmark.com, Wordpress and some other sites with CSS after gzdeflate()
This problem was due to an incomplete check for the end of compressed streams in the patch for bug 237623. This has been backed out already and we're now doing the check differently.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Updating the tracking flags accordingly
You need to log in before you can comment on or make changes to this bug.