Flame: Settings -> Sound -> Manage Tones window transition seems broken

RESOLVED DUPLICATE of bug 1137203

Status

()

defect
RESOLVED DUPLICATE of bug 1137203
4 years ago
4 years ago

People

(Reporter: njpark, Assigned: BenWa)

Tracking

({regression})

unspecified
All
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(1 attachment)

Reporter

Description

4 years ago
STR:
Open Settings -> Sound -> Manage Tones menu
Actual:
The window transition seems broken, and it is different from Bug 1127877.
Expected:
The window transition is normal

Video Link:
https://www.youtube.com/watch?v=qssUv6eaUII

Version Info:
2.2
No-Jun-MacBook-Pro:B2G-flash-tool mozilla$ ./check_versions.sh 
Gaia-Rev        ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/78d823f7be4c
Build-ID        20150217002515
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150217.040742
FW-Date         Tue Feb 17 04:07:53 EST 2015
Bootloader      L1TC000118D0

3.0
Gaia-Rev        ae02fbdeae77b2002cebe33c61aedeee4b9439fd
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/4bb425001d8a
Build-ID        20150217074221
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150217.111839
FW-Date         Tue Feb 17 11:18:50 EST 2015
Bootloader      L1TC000118D0
Reporter

Comment 1

4 years ago
ni?ing milan for possible graphics bug.  Nominating for 2.2 since the transition is quite noticeably wrong.
blocking-b2g: --- → 2.2?
Flags: needinfo?(milan)
Component: Gaia::Settings → Graphics: Layers
OS: Mac OS X → Gonk (Firefox OS)
Product: Firefox OS → Core
Hardware: x86 → All
This goes away if bug 1121871 is backed out.
Blocks: 1121871
Assignee: nobody → bgirard
Flags: needinfo?(milan)
Reporter

Updated

4 years ago
Keywords: regression

Comment 3

4 years ago
Triage is blocking because this is a regression.
blocking-b2g: 2.2? → 2.2+
Assignee

Comment 4

4 years ago
I can still reproduce this with bug 1134762 landed (which cleaned up bug 1121871). Investigating.
Assignee

Comment 5

4 years ago
It is related to low-res painting. Not related to intermediate surface recycling (turning it off makes the glitches worse cause we repaint it every frame).
Assignee

Comment 6

4 years ago
Posted patch work aroundSplinter Review
Ok kats is correct. The problem is we only draw the critical display port. With OMTA we have to draw everything.
Assignee

Comment 7

4 years ago
The animation is set on the parent container layer. Going to try to disable the critical display port code if there's an animation on an ancestor layer.
Assignee

Comment 8

4 years ago
The problem in the work around I found will be addressed in bug 1137203.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1137203
You need to log in before you can comment on or make changes to this bug.