Closed Bug 1134015 Opened 5 years ago Closed 5 years ago

The button toasts are broken

Categories

(Firefox for Android :: General, defect)

38 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 38
Tracking Status
firefox38 --- verified
fennec 38+ ---

People

(Reporter: AndyP, Assigned: AndyP, Mentored)

References

Details

(Keywords: regression)

Attachments

(1 file)

This is a regression of bug #1099500.

Depends on bug #1133278 and bug #1133499.
There is a patch up in 1099500, but we don't need another dupe.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1133499
Whoops, read Margaret's last comment.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Blocks: 1099500
Keywords: regression
ButtonToast.java hides the toast in its onClickListener using ReasonHidden.CLICKED therefore it is neccessary to not delete the callbacks here if this reason occurs.
Attachment #8565694 - Flags: review?(margaret.leibovic)
Just some additional information:
The callback data in case of ReasonHidden.CLICKED is removed in ButtonToast.java [1], there is also ReasonHidden.STARTUP which is as well used in ButtonToast.java. Both cases are now excluded.

[1] https://mxr.mozilla.org/mozilla-central/source/mobile/android/base/widget/ButtonToast.java#122
Comment on attachment 8565694 [details] [diff] [review]
bug1134015_fixBrokenButtonToast.diff

Review of attachment 8565694 [details] [diff] [review]:
-----------------------------------------------------------------

I can land this for you.
Attachment #8565694 - Flags: review?(margaret.leibovic) → review+
https://hg.mozilla.org/integration/fx-team/rev/15edc0cdbae7
Assignee: nobody → drag
tracking-fennec: --- → 38+
https://hg.mozilla.org/mozilla-central/rev/15edc0cdbae7
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 38
-Close a tab, tap 'Undo' on the 'Closed tab - Undo' tab toast notification => The closed tab is opened in the same position as it was before.
-Choose "Open Link in New Tab/Private Tab", tap "Switch" on the "New Tab opened" notification => The new tab is displayed. So:
Verified as fixed on:
Device: Nexus 5 (Android 5.0.1)
Build: Firefox for Android 38.0a1 (2015-02-19)
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1133499
You need to log in before you can comment on or make changes to this bug.