Cannot find property public mx.core::FlexBitmap SharedLibrary on http://www.rfcmedia.com/thirdrockradio/

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
4 years ago
3 years ago

People

(Reporter: jrconlin, Assigned: tschneider)

Tracking

38 Branch

Details

(URL)

(Reporter)

Description

4 years ago
+++ Initially filed via the problem reporting functionality in Shumway +++
Please add any further information that you deem helpful here:

Page http://www.rfcmedia.com/thirdrockradio/
Shumway errors out with: 

"Unexpected: Cannot find property public mx.core::FlexBitmap" shumway.player.js:139:16
f.assert() shumway.player.js:139
f.unexpected() shumway.player.js:166
g</f.prototype.findDomainProperty() shumway.player.js:21472
u</a.prototype.findScopeProperty() shumway.player.js:10182
u</a.prototype.findScopeProperty() shumway.player.js:10177
u</a.prototype.findScopeProperty() shumway.player.js:10177
u</a.prototype.findScopeProperty() shumway.player.js:10177
u</a.prototype.findScopeProperty() shumway.player.js:10177
u</a.prototype.findScopeProperty() shumway.player.js:10177
B</r.interpretMethod() shumway.player.js:21949
X/e<() shumway.player.js:9617
r() shumway.player.js:21318
v() shumway.player.js:21324
g</f.prototype.findDefiningScriptSlow() shumway.player.js:21525
g</f.prototype.findDefiningScript() shumway.player.js:21514
g</f.prototype.getProperty() shumway.player.js:21453
g</f.prototype.getClass() shumway.player.js:21463
m</b.prototype._applyLoadUpdate() shumway.player.js:35546
m</b.processLateEvents() shumway.player.js:35399
m</b.processEvents() shumway.player.js:35345
m</g.prototype._eventLoopTick()  shumway.player.js:52648

----------------------

Technical Information:
Firefox version: 38.0a1 (20150217030213)
Shumway version: 0.9.3775 (a82ac47)
Duplicate of this bug: 1132804
I can also reproduce this on Amazon's Instant Video when playing a video I've purchased. You can switch Amazon's Instant Video settings from Silverlight to Flash:

https://smile.amazon.com/gp/video/settings
(Assignee)

Updated

4 years ago
Assignee: nobody → schneider
Blocks: 1038057
Summary: Cannot find property public mx.core::FlexBitmap on http://www.rfcmedia.com/thirdrockradio/ → Cannot find property public mx.core::FlexBitmap SharedLibrary on http://www.rfcmedia.com/thirdrockradio/
Blocks: 1142562
This bug does not need to block Shumway's 1.0 milestone for ads.
No longer blocks: 1038057
Mistakenly filed against Firefox 38 and should be instead 38 Branch. Sorry for the spam. dkl
Version: Firefox 38 → 38 Branch
Product: Firefox → Firefox Graveyard
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.