[RTL][Messages] File size in thumbnail not right-aligned.

RESOLVED DUPLICATE of bug 1210731

Status

Firefox OS
Gaia::SMS
P3
normal
RESOLVED DUPLICATE of bug 1210731
4 years ago
3 years ago

People

(Reporter: YeojinC, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 8566246 [details]
fileSize.png

Description:
When the user attach a file in an MMS, the file size in the created thumbnail is located on the left side.

Pre-requisite: Have at least 1 photo in the device. 

Repro Steps:
1) Update a Flame to 20150218010226.
2) Set the device language in Arabic under Settings > Language.
3) Open Messages app.
4) Select New message icon.
5) Select the clip icon.
6) Select Gallery > Select any photo > Select Done.
7) Observe the file size displayed in the thumbnail.

Actual:
The file size is left-aligned in the thumbnail.

Expected:
The file size is right-aligned in the thumbnail.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150218010226
Gaia: 82f286f10a41aab84a0796c89fbefe67b179994b
Gecko: 9696d1c4b3ba
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 3/3
See attached: screenshot
(Reporter)

Comment 1

4 years ago
This issue also reproduces on Flame 2.2.

Result: File size is left-aligned.

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150218002515
Gaia: da509caa7395d3d090ce973e8de082b4680a590d
Gecko: 96da179a7d3a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Please see bug 1080833
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Depends on: 1080833
Flags: needinfo?(ktucker)
Triage: P3 (but definitely good to have for consistency)
Priority: -- → P3
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15929/
Flags: in-moztrap+

Updated

3 years ago
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing], MGSEI-RTL-3F
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
QA Whiteboard: [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]MGSEI-RTL-3F
Whiteboard: [3.0-Daily-Testing], MGSEI-RTL-3F → [3.0-Daily-Testing]
This issue can be reproduced on latest build of AriesKK_V2.5.
Rate:5/5
Build ID               20150814002719
Gaia Revision          39b121515ab8a8c3ea07f26d3ba1dd792e90217c
Gaia Date              2015-08-13 18:25:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4e883591bb5dff021c108d3e30198a99547eed1e
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150813.235024
Firmware Date          Thu Aug 13 23:50:32 UTC 2015
Bootloader             s1
Blocks: 1181936
Created attachment 8649637 [details]
AriesKK_V2.5.png
Created attachment 8685873 [details]
Can't repro_FlameKK2.5.png

This problem cannot be reproduced on latest AriesKK v2.5 and FlameKK v2.5 by the STR in comment 0.
In RTL mode, at message compose view, the attachment file size is right-aligned in the thumbnail. Closing as resolved worksforme.

See attachment: Can't repro_FlameKK2.5.png
Reproduce rate: 0/5

Device information:
Aries KK v2.5 
Build ID               20151110094357
Gaia Revision          07baf613699fa6225359c7f04825c5caeb71d424
Gaia Date              2015-11-09 21:32:50
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/e14287b00a514a15418dfaa89287030c588ad19d
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151110.090331
Firmware Date          Tue Nov 10 09:03:39 UTC 2015
Bootloader             s1

Flame KK 2.5 512mb 
Build ID               20151109004552
Gaia Revision          cf646c52bb947af28329b0a100df91d1b1f2a907
Gaia Date              2015-11-09 02:55:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/4eafef5b80f8985c94c4a067f130d37513e1a581
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151109.041411
Firmware Date          Mon Nov  9 04:14:26 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Attachment #8685873 - Attachment is obsolete: true
Created attachment 8685874 [details]
Can't repro_FlameKK2.5.png

Wrong screenshot. Here's the right one.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1210731
You need to log in before you can comment on or make changes to this bug.