Drop nsIDOMWindowUtils.sendKeyEvent()

RESOLVED FIXED in Firefox 60

Status

()

RESOLVED FIXED
4 years ago
8 months ago

People

(Reporter: masayuki, Assigned: masayuki)

Tracking

(Blocks: 1 bug)

Trunk
mozilla60
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox60 fixed)

Details

Attachments

(1 attachment)

Comment hidden (empty)
No longer blocks: 119609
Depends on: 1119609
Keywords: dev-doc-needed
Blocks: 1136539
We need Bug 1137557 to move forms.js away from this method.
Depends on: 1137557
Depends on: 1255806
(Assignee)

Updated

9 months ago
Depends on: 1434317
(Assignee)

Updated

9 months ago
Depends on: 1433648
Comment hidden (mozreview-request)
FYI: I wait bug 1433648 and bug 1434317 because I don't want to break Thunderbird. However, I'd like to land this ASAP and the fix is really easy. So, even if they are not fixed in the next week, I'll land this anyway.

Comment 6

9 months ago
mozreview-review
Comment on attachment 8947348 [details]
Bug 1134542 - Get rid of nsIDOMWindowUtils::sendKeyEvent() and nsIFrameLoader::sendCrossProcessKeyEvent()

https://reviewboard.mozilla.org/r/217086/#review222924
Attachment #8947348 - Flags: review?(bugs) → review+
Comment hidden (mozreview-request)

Comment 9

8 months ago
Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/158bcad6b96a
Get rid of nsIDOMWindowUtils::sendKeyEvent() and nsIFrameLoader::sendCrossProcessKeyEvent() r=smaug

Comment 10

8 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/158bcad6b96a
Status: NEW → RESOLVED
Last Resolved: 8 months ago
status-firefox60: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Duplicate of this bug: 1437283
Sorry, but the MDN team no longer has time/resources to update XPCOM docs. We are focusing just on web platform docs going forward.
Keywords: dev-doc-needed
You need to log in before you can comment on or make changes to this bug.