[ALA] Can't edit GPS coordinates of Custom Location

RESOLVED FIXED in 2.2 S8 (20mar)

Status

defect
P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: janx, Assigned: marta)

Tracking

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Steps to reproduce:
0. Use latest Firefox OS (I used Flame)
1. Go to Settings > Privacy Controls > Location Accuracy > Set custom location
2. Select "Enter GPS Coordinates", and try to change the fields to 30.0500/31.2333 (Cairo, Egypt)

Expected:
The input fields let you change the coordinates

Actual:
The cursor is stuck to the left of the input field, so you can't the remove pre-filled digits. You can only add digits to the left (making the coord invalid).
(Reporter)

Updated

4 years ago
OS: Linux → All
Hardware: x86_64 → All
Notes: The user actually can change the coordinates but it is extremely difficult. They must tap in the field to get the blue text selection caret and drag it to the right of the pre-entered numbers. This is particularly difficult in the Longitude as the caret will be partially cut-off by the keyboard. This work-around will most likely not be apparent to most.



This issue occurs on 3.0 and 2.2

Device: Flame 3.0 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150224010314
Gaia: 31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gecko: 368c62292249
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150224002637
Gaia: 8e98fe665f3821d10d4d982cbb14cbe5b94d0be5
Gecko: 2b70d9d62799
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Repro frequency: 6/6
See attached: video: https://www.youtube.com/upload




NI - to Peter - this might want to be considered for blocking nomination as it effectively prevents use / blocks functionality.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
NI for component owner for nomination decision for 2.2.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(gchang)
Hi Marta,
This might need your help to investigate.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][COM=Privacy Panel]
Flags: needinfo?(gchang) → needinfo?(marta)
(Assignee)

Comment 4

4 years ago
I will provide a patch within the next few days, need to test it
Flags: needinfo?(marta)
I just tested this again with the latest changes and it appears to still be broken.

Updated

4 years ago
Flags: needinfo?(marta)

Updated

4 years ago
Status: NEW → ASSIGNED

Updated

4 years ago
blocking-b2g: --- → 2.2+

Updated

4 years ago
Priority: -- → P1
Hi Marta,
I see you already have a patch submitted. Do you like to ask someone to review the patch?
Thanks!
(Assignee)

Updated

4 years ago
Flags: needinfo?(marta)
Attachment #8571423 - Flags: review?(janx)
(Reporter)

Comment 8

4 years ago
Comment on attachment 8571423 [details] [review]
[gaia] martasect:Bug_1134711 > mozilla-b2g:master

Thanks a lot for trying to fix this, Marta! Your attempt makes sense, but it didn't solve the problem for me, as demonstrated in this video:

https://www.youtube.com/watch?v=7w73j08v2Oo

I think the problem actually stems from the weird input field: You can't place the cursor where you want, and you can't long-press to select/cut/copy/paste.

After investigating, I found out that bug 1126174 removed `-moz-user-select` on everything but a few input types. Fabien forgot about `input[type="number"]` in https://github.com/mozilla-b2g/gaia/blob/master/apps/privacy-panel/style/panels.css#L22-L29

To fix the problem, please replace all the specific `input[type="X"]` by a single `input` query selector.
Attachment #8571423 - Flags: review?(janx) → review-
(Assignee)

Comment 9

4 years ago
Comment on attachment 8571423 [details] [review]
[gaia] martasect:Bug_1134711 > mozilla-b2g:master

Hey, could you take a look? As requested I did replace all occurrences of "input[type=X]" with "input"
Attachment #8571423 - Flags: review- → review?(janx)
(Reporter)

Comment 10

4 years ago
Comment on attachment 8571423 [details] [review]
[gaia] martasect:Bug_1134711 > mozilla-b2g:master

Hi Marta, this does fix the problem, thanks!

However, there is no need to change all these `input[type=range]` rules. Please only fix the problematic -moz-user-select rule in apps/privacy-panel/style/panels.css line 22 (as you've already correctly done in this patch).

If you could please undo your other `input[type=range]` changes, I'll r+ your next pull request.
Attachment #8571423 - Flags: review?(janx) → review-
(Reporter)

Comment 11

4 years ago
P.S. Sorry about the confusion, it's my fault: When I said "please replace all the specific `input[type="X"]` by a single `input` query selector" in comment 8, I actually meant "please replace the specific query selectors on just this one `-moz-user-select: text` rule in apps/privacy-panel/style/panels.css line 22".
(Assignee)

Comment 12

4 years ago
Comment on attachment 8571423 [details] [review]
[gaia] martasect:Bug_1134711 > mozilla-b2g:master

corrected as requested
Attachment #8571423 - Flags: review- → review?(janx)
(Reporter)

Comment 13

4 years ago
Comment on attachment 8571423 [details] [review]
[gaia] martasect:Bug_1134711 > mozilla-b2g:master

Thanks Marta! Merged as https://github.com/mozilla-b2g/gaia/commit/aee8084a4f.
Attachment #8571423 - Flags: review?(janx) → review+
(Reporter)

Updated

4 years ago
Assignee: huseby → marta
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Please request Gaia v2.2 approval on this patch when you get a chance.
Flags: needinfo?(marta)
Target Milestone: --- → 2.2 S8 (20mar)
(Assignee)

Comment 15

4 years ago
Comment on attachment 8571423 [details] [review]
[gaia] martasect:Bug_1134711 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1134711
[User impact] if declined: User will not be able to change the coordinates in ALA
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: non
Flags: needinfo?(marta)
Attachment #8571423 - Flags: approval-gaia-v2.2?(dietrich)
Attachment #8571423 - Flags: approval-gaia-v2.2?(dietrich) → approval-gaia-v2.2+
You need to log in before you can comment on or make changes to this bug.