Closed Bug 1135320 Opened 7 years ago Closed 6 years ago

Re-enable gen-eme-voucher.py on Win64

Categories

(Release Engineering :: General, defect)

x86_64
Windows 8
defect
Not set
normal

Tracking

(firefox41 wontfix, firefox42 fixed, firefox43 fixed)

RESOLVED FIXED
Tracking Status
firefox41 --- wontfix
firefox42 --- fixed
firefox43 --- fixed

People

(Reporter: cpearce, Assigned: eflores)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

I disabled generating the EME voucher in bug 1134913, as the voucher generator does not handle a Win64 binary. Once Adobe provide a patch so it can handle Win64 binaries, we should re-enable it on Win64.
Comment on attachment 8647267 [details] [diff] [review]
1135320.patch

Review of attachment 8647267 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, but someone more qualified should r+ing this code.
Attachment #8647267 - Flags: review?(cpearce) → review?(mh+mozilla)
Comment on attachment 8647267 [details] [diff] [review]
1135320.patch

Review of attachment 8647267 [details] [diff] [review]:
-----------------------------------------------------------------

Technically, this is a backout of bug 1134913, you don't really need a review.
Attachment #8647267 - Flags: review?(mh+mozilla) → review+
Assignee: nobody → edwin
https://hg.mozilla.org/mozilla-central/rev/7d6edef7f242
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
See Also: → 1211184
Depends on: 1211184
Comment on attachment 8647267 [details] [diff] [review]
1135320.patch

Approval Request Comment
[Feature/regressing bug #]:
[User impact if declined]: 64-bit Firefox 42 users won't be able to use Netflix EME without the voucher.bin signature file generated by this patch.
[Describe test coverage new/current, TreeHerder]: This patch landed in Nightly 43 and has been tested since then.
[Risks and why]: Low risk because the voucher.bin file does not affect any Firefox code except EME and without this patch EME doesn't work at all.
[String/UUID change made/needed]: None
Attachment #8647267 - Flags: approval-mozilla-beta?
Comment on attachment 8647267 [details] [diff] [review]
1135320.patch

Sure, should be in 42 beta 4.
Attachment #8647267 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Thanks! checkin-needed for mozilla-beta
For uplift requests, approval-mozilla-beta+ is enough to have uplift done by the sheriffs :)
Keywords: checkin-needed
Duplicate of this bug: 1211184
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.