Closed Bug 1137083 Opened 5 years ago Closed 2 years ago

[Privacy Panel] There is no indicator (5m, 10m....) for adjustment level and no geolocation value when enabling location adjustment

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, P1, major)

ARM
Gonk (Firefox OS)

Tracking

(b2g-v2.2 affected, b2g-master fixed)

RESOLVED WONTFIX
Tracking Status
b2g-v2.2 --- affected
b2g-master --- fixed

People

(Reporter: gchang, Unassigned)

References

Details

Attachments

(4 files)

### Steps:
1. Go to Settings > Privacy Panel > Location Accuracy
2. Enable "Use geolocation" and "Use local adjustment" and choose "Adjustment"
3. Adjust the accuracy level in below bar
4. Open Geoloc app
5. Tap "Get current"

### Expected:
1. The latitude and longitude should have value.

### Actual:
1. No values show in the log
2. Can't locate position in google map.

PS: If privacy control is not enabled, the latitude and longitude will have value.


### Reproduce rate
always

### Version:
Gaia-Rev        e4bf968d5a7366e7bdc58f0fdba28b32e864bdf7
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/da6ac51f5113
Build-ID        20150225162504
Version         37.0
Device-Name     flame
FW-Release      4.4.2
Attached file The logcat
NI developer for this issue.
blocking-b2g: --- → 2.2?
QA Whiteboard: [COM=Privacy Panel]
Flags: needinfo?(huseby)
The adjustment level (blur distance) has been fixed yesterday on master by bug 1133274 :)
I concur that is bug is now fixed on master.  One caveat about geolocation is that you need to have a connection to the internet (wifi or mobile data) if you are not outside or just started up the phone to get a location.

When I'm testing there have been times when I forgot to join the wifi network and was getting no location.
Flags: needinfo?(huseby)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
blocking-b2g: 2.2? → 2.2+
I tested this both on latest master and 2.2. The wifi and data connection are enabled. Neither of them can get location.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Is this really falls under Settings app? Is this still a blocker after bug 1132377?
Flags: needinfo?(huseby)
Hi Theo, Dave, do you mind checking Comment 6 again? Thanks.
Flags: needinfo?(theo.chevalier11)
Flags: needinfo?(huseby)
Summary: [Privacy Controls] There is no indicator (5m, 10m....) for adjustment level and no geolocation value when enabling location adjustment → [Privacy Panel] There is no indicator (5m, 10m....) for adjustment level and no geolocation value when enabling location adjustment
Hi,
My comment was only about the blur distance being fixed on 2.2, not sure what's wrong on Comment 6.
Flags: needinfo?(theo.chevalier11)
Hi Theo,
You can adjust the level, but it doesn't work. After adjusting the blur distance. You can go to google map and locate your current position. You will get a warning which is "Google Maps could not determine your precise location.".
I just tested this on the latest v2.2 and the bug is no longer present.  This does fall under Settings because the only way to launch the privacy panel is from the Settings app.  But technically, it was a bug in the privacy panel.
Flags: needinfo?(huseby)
Severity: normal → major
Priority: -- → P1
Uh, I just confirmed that this bug has been fixed and it is closed.  Why did you flag this as P1 and upgrade its severity?
Flags: needinfo?(jocheng)
Hi Gerry,
Could you please help to confirm that this bug is resolved per comment 11?
Thanks!
Flags: needinfo?(jocheng) → needinfo?(gchang)
I use below build to test again. Please see the url. 
http://youtu.be/_V49O0vn5M4

After using local adjustment with blur distance, I still can't locate my position.

Gaia-Rev        166491b92278dc9e648f8d49ab02d9ca00d74421
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9ae4bcc9b5f2
Build-ID        20150309162503
Version         37.0
Device-Name     flame
FW-Release      4.4.2
Flags: needinfo?(gchang) → needinfo?(huseby)
I'm building the latest v2.2 head and will test this soon.  Sometimes google doesn't find a location when you are using precise as well.  I always use geoloc to test because it shows the raw geolocation I/O.  Instead of using google, try this for testing: http://benwerd.com/lab/geo.php
Flags: needinfo?(huseby) → needinfo?(gchang)
I just re-tested this with:

Gaia-Rev        166491b92278dc9e648f8d49ab02d9ca00d74421
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1cda026f89968
Build-ID        20150310094626
Version         37.0
Device-Name     flame
FW-Release      4.3
FW-Incremental  eng.huseby.20150205.151909
FW-Date         Thu Feb  5 15:19:20 PST 2015

The location blurring works.  I set it to 2km and went to maps.google.com and was able to see the output in adb logcat showing that the location was blurred.

> W/GPS     (  312): ../../../dom/geolocation/nsGeolocationSettings.cpp:192   mapping watch ID 10 to origin https://www.google.com
> W/GPS     (  312): ../../../dom/geolocation/nsGeolocation.cpp:567   returning approximate location for watch ID: 10
> W/GPS     (  312): ../../../dom/geolocation/nsGeoGridFuzzer.cpp:122   approximate location with delta 2 is 36.163662, -115.360832
> W/GPS     (  312): ../../../dom/geolocation/nsGeolocation.cpp:614   returning coordinates: 36.163662, -115.360832
let me try this with a kk build.
Yup, works great on kk too:

> W/GPS     (  208): ../../../dom/geolocation/nsGeolocationSettings.cpp:192   mapping watch ID 8 to origin https://www.google.com
> W/GPS     (  208): ../../../dom/geolocation/nsGeolocation.cpp:567   returning approximate location for watch ID: 8
> W/GPS     (  208): ../../../dom/geolocation/nsGeoGridFuzzer.cpp:122   approximate location with delta 20 is 36.082678, -115.207989
> W/GPS     (  208): ../../../dom/geolocation/nsGeolocation.cpp:614   returning coordinates: 36.082678, -115.207989
Per Dave's comments
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → INVALID
Hi Dave, 
Have you tried PVT official build to test? because I still can't locate my location.
The latest build I use is 
Gaia-Rev        572d60e0a440ee4af50bc6b6adad8876eadbdb4d
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/244e6ba3c20e
Build-ID        20150312002501
Version         37.0
Device-Name     flame
FW-Release      4.4.2

In order to see the log you commented in comment #18, I try to build codes by myself with MOZ_GPS_DEBUG=1, in this way, I found that I can locate my position with blur distance and can see the logs. I don't know why the local build can work but official build can't work.
Flags: needinfo?(gchang)
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
as comment 16 and comment 20. could we have regression window between 2 build? thanks.
I could not find a point where this issue was actually fixed, even in builds created just minutes after the one Dave listed in comment 16.  I could find the original regression window if you feel that would be helpful, but there are no builds on the pvt server that show this issue having been fixed on 2.2 in that timeframe.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150310095118
Gaia: 03adf96933e308e2b10fd39d458a0bae28e378e9
Gecko: fd1bfa5c3419
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(ktucker)
QA Whiteboard: [COM=Privacy Panel] → [QAnalyst-Triage+][COM=Privacy Panel]
Flags: needinfo?(ktucker) → needinfo?(bchien)
I think the build ID in comment #16 is built by dev locally. It's not in PVT.
NI dev for more information
Flags: needinfo?(bchien) → needinfo?(huseby)
Hi Dave,
Could you please try recreate the issue with PVT build?
Thanks
Yup.  Today if I can.
I just tested this with the latest v2.2 and marta's patch applied.  The exception list works, but fuzzed locations don't work.  Precise, no location, fixed location, and global settings all work.  I'll debug it ASAP.
Flags: needinfo?(huseby)
Removed from 2.2 blocker as Privacy Control will not be FxOS 2.2 committed feature.
blocking-b2g: 2.2+ → ---
I am assuming this might be due to some patches not being uplifted to 2.2. trying to fix that
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 5 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.