Closed Bug 1137097 Opened 5 years ago Closed 5 years ago

[Header] we don't recalculate when changing orientation

Categories

(Firefox OS Graveyard :: Gaia::Components, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S9 (3apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: julienw, Assigned: julienw)

References

Details

Attachments

(3 files)

50 bytes, text/x-github-pull-request
wilsonpage
: review+
Details | Review
54 bytes, text/x-github-pull-request
wilsonpage
: review+
Details | Review
46 bytes, text/x-github-pull-request
Details | Review
Gaia Header should listen to the orientationchange event and run runFontFitSoon.

See https://developer.mozilla.org/en-US/docs/Web/API/CSS_Object_Model/Managing_screen_orientation#Listening_orientation_change for more information.
See Also: → 1141832
Blocks: 1141832
Blocking a blocker
blocking-b2g: --- → 2.2+
Alive, could you help on this?
Flags: needinfo?(alive)
Are you assigning me by a random choose?
Flags: needinfo?(alive)
Looks like :wilsonpage is the best guy
Flags: needinfo?(wilsonpage)
Duplicate of this bug: 1040656
julien is going to take this as he is currently working on some other gaia-header improvements.
Flags: needinfo?(wilsonpage)
Assignee: nobody → felash
Attached file font-fit PR
Attached file gaia-header PR
Attachment #8579666 - Flags: review?(wilsonpage)
Attachment #8579523 - Flags: review?(wilsonpage)
Comment on attachment 8579666 [details] [review]
gaia-header PR

I realize I'd like to skip recalculating in 2 situations:
* when not-flush is used
* when innerWidth does not change

I'll finish this tomorrow.
Attachment #8579666 - Flags: review?(wilsonpage)
Comment on attachment 8579666 [details] [review]
gaia-header PR

Hey Wilson,

I think this is now ready, tell me what you think :)
Attachment #8579666 - Flags: review?(wilsonpage)
Attachment #8579523 - Flags: review?(wilsonpage) → review+
Comment on attachment 8579666 [details] [review]
gaia-header PR

Some questions and comments on pull-request.
Attachment #8579666 - Flags: review?(wilsonpage)
Comment on attachment 8579666 [details] [review]
gaia-header PR

Ready for next review !
Attachment #8579666 - Flags: review?(wilsonpage)
Comment on attachment 8579666 [details] [review]
gaia-header PR

r+ (conditional)

All looks good apart from the `notFlush` part. Perhaps I'm missing something, I think the resize logic should be run in this case too.
Attachment #8579666 - Flags: review?(wilsonpage) → review+
Fixed the last comments and landed

gaia-header master: ee7e4f0b1ebe827bb38f67408e70e363c46061f2
gaia-header v0.8.0 stamp: 64da8f8103b21960230b2d6e3f2412e8441d052f
gaia master: https://github.com/mozilla-b2g/gaia/commit/869a9112a2f3c982362aeacb7187f56e05a5e801
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8581788 [details] [review]
gaia PR to ugprade gaia-geader

[Approval Request Comment]
Note that this uplift is also necessary for bug 1140613.

[Bug caused by] (feature/regressing bug #): bug 1112131 (although I'm not really sure this specific bug is new)
[User impact] if declined: in these apps that handle both portrait and landscape orientations, we don't resize the text. It looks like this can lead to bugs like bug 1141832 as well.
[Testing completed]: yes (unit and manually)
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none


note that the same
Attachment #8581788 - Flags: approval-gaia-v2.2?
Attachment #8581788 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
You need to log in before you can comment on or make changes to this bug.