Browser should be resistant to corrupted history

VERIFIED DUPLICATE of bug 113287

Status

()

Core
History: Global
--
critical
VERIFIED DUPLICATE of bug 113287
17 years ago
16 years ago

People

(Reporter: Jerome Lacoste, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6+)
Gecko/20011129
BuildID:    2001112903

I had a corrupted history as in bug 113378. As I said there are two problems:
- the history was corrupted
- the browser crashed on startup

The browser should not crash if the history was corrupted. It should probably
detect it, and perhaps rename the corrupted file.

Reproducible: Always
Steps to Reproduce:
1- copy any corrupted history.dat in a new profile (e.g. from bug 113378). I
guess any dummy file renamed history.dat currently crashes the browser.
2- start the browser
3- do any operation that involves parsing the history (apparently click on a
link does)

Actual Results:  Browser crashes

Expected Results:  Browser detects that history is corrupted and ?? proposes a
solution.

See also bug 113025: [RFE]: history.dat file should not be required to run
Mozilla properly.
This should be the same with any non critical file in the profile.
A more generic bug "reading non critical profile files should be made crash
resistant"
The average user would not end up stuck if his profile is corrupted.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 113287 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Summary: Browser should be resistant to corrupted history → Browser should be resistant to corrupted history
mass-verifying Duplicate bugs which haven't changed since 2001.12.31.

set your search string in mail to "CitizenGKar" to filter out these messages.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.