Thunderbird crashes several times a day when I delete a message nsMsgXFViewThread::RemoveChildHdr(nsIMsgDBHdr*, nsIDBChangeAnnouncer*)

RESOLVED DUPLICATE of bug 646168

Status

Thunderbird
Untriaged
--
critical
RESOLVED DUPLICATE of bug 646168
3 years ago
3 years ago

People

(Reporter: Karsten, Unassigned)

Tracking

({crash})

31 Branch
x86_64
Windows 7
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8574258 [details]
Bug report.txt

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

Deleted a message from my Inbox (Inbox of unified folders). This happens not always, only once every 20 or so messages I delete. If after restart I delete the same message, there is no problem.
I have had this problem for several months and it is slighly getting worse


Actual results:

Thunderbird closes down and a message appears asking if I want to report the crash. I always press "Report bug)

Last Crash report: https://crash-stats.mozilla.com/report/index/47b3466a-0b9c-47a6-b901-b85cc2150307




Expected results:

Just a deletion of the file and opening of the next mail in my inbox.

Comment 1

3 years ago
Thanks, this is reported as bug 646168

bp-47b3466a-0b9c-47a6-b901-b85cc2150307
0 	xul.dll	nsMsgXFViewThread::RemoveChildHdr(nsIMsgDBHdr*, nsIDBChangeAnnouncer*)	mailnews/base/src/nsMsgXFViewThread.cpp
1 	xul.dll	nsMsgSearchDBView::OnHdrDeleted(nsIMsgDBHdr*, unsigned int, int, nsIDBChangeListener*)	mailnews/base/src/nsMsgSearchDBView.cpp
2 	xul.dll	nsMsgDatabase::NotifyHdrDeletedAll(nsIMsgDBHdr*, unsigned int, int, nsIDBChangeListener*)	mailnews/db/msgdb/src/nsMsgDatabase.cpp
3 	xul.dll	nsMsgDatabase::DeleteHeader(nsIMsgDBHdr*, nsIDBChangeListener*, bool, bool)	mailnews/db/msgdb/src/nsMsgDatabase.cpp
4 	xul.dll	nsMsgDatabase::DeleteMessages(unsigned int, unsigned int*, nsIDBChangeListener*)	mailnews/db/msgdb/src/nsMsgDatabase.cpp
5 	xul.dll	nsImapMailFolder::CopyMessagesOffline(nsIMsgFolder*, nsIArray*, bool, nsIMsgWindow*, nsIMsgCopyServiceListener*)	mailnews/imap/src/nsImapMailFolder.cpp
Severity: normal → critical
Status: UNCONFIRMED → RESOLVED
Crash Signature: [@ nsMsgXFViewThread::RemoveChildHdr(nsIMsgDBHdr*, nsIDBChangeAnnouncer*) ]
Last Resolved: 3 years ago
Keywords: crash
Resolution: --- → DUPLICATE
Summary: Thunderbird crashes several times a day when I delete a message → Thunderbird crashes several times a day when I delete a message nsMsgXFViewThread::RemoveChildHdr(nsIMsgDBHdr*, nsIDBChangeAnnouncer*)
Duplicate of bug: 646168
You need to log in before you can comment on or make changes to this bug.