'Settings' link in search suggestions info pop-up doesn't open Search pane/view if Settings already opened/active

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Search
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: aryx, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

B2G 3.0 20150311125826 on Flame (v18D base image)

The 'Settings' link in the search suggestions info pop-up doesn't open the Search pane if Settings is active.
Whiteboard: [systemsfe]
Can we get a branch check on this?
Keywords: qawanted
This issue reproduces on Flame Master.

Result: "Settings" in search suggestion message on rocketbar overlay is not highlighted or linked to the settings page.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150501010203
Gaia: 759a1f935a6a81c32ad66e39a6353b334dfa4f91
Gecko: 7723b15ea695
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

==============================
This issue does NOT reproduce on Flame 2.2.

Result: "Settings" in search suggestion message on rocketbar overlay is highlighted and linked to the settings page.

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150501002503
Gaia: 209bf4d6fcb16ea6834b8bd86976c012e5914fe6
Gecko: 79e7065ceefa
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: qawanted → regression
Created attachment 8600508 [details]
LinkToSettings.png
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(In reply to Yeojin Chung [:YeojinC] from comment #2)
> This issue reproduces on Flame Master.
> 
> Result: "Settings" in search suggestion message on rocketbar overlay is not
> highlighted or linked to the settings page.
That's a new bug, this open is about the (styled) link only not opening the Settings if they are already running.
Please relook at this bug based on comment 4.
Flags: needinfo?(ychung)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #5)
> Please relook at this bug based on comment 4.

This issue is currently blocked by bug 1162274. When it's verified on the user build tomorrow, I'll re-check this issue. Leaving NI.
Depends on: 1162274
This issue does not reproduce on Flame Master and 2.2. When the Settings app is already open and active, the "Settings" link from the search suggestion dialog works properly. I also tested with settings app open and running in the background, and no issues are found as well.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150511010202
Gaia: 6089234ace8b294a8feef064387604bae16254e3
Gecko: d8420a541d1c
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150511034732
Gaia: 6d7981e1b6be2992ab4842065859270b4a62a4bd
Gecko: 755ff2baa2c9
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

==============================================
On Flame 2.1, "Settings" is not highlighted and linked to the search page on search suggestion dialog.

Environmental Variables:
Device: Flame 2.1
BuildID: 20150509032506
Gaia: 3e7bd686ecd852f4dfa4605b45f558e6bd34f02a
Gecko: de4ebfdc7db6
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ychung) → needinfo?(ktucker)
This appears to have been resolved so I am closing this as worksforme. Please reopen the issue if the issue is encountered again.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Resolution: --- → WORKSFORME
Depends on: 1163825
No longer depends on: 1163825
You need to log in before you can comment on or make changes to this bug.