If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

test-page-mod and test-page-worker failures in travis-ci

RESOLVED FIXED

Status

Add-on SDK
General
P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mossop, Assigned: mossop)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
erikvold
: review+
Details | Review | Splinter Review
(Assignee)

Description

3 years ago
The following tests failed:
  ./test/test-page-mod.testPageModContentScriptFile: timed out, failure
  ./test/test-page-mod.testPageModCss: failure
  ./test/test-page-worker.testLoadContentPageRelativePath: timed out

The reason they are failing is because they can't find content script files they need. In both cases they create a loader with prefixURI pointing into the test fixtures directory:

https://github.com/mozilla/addon-sdk/blob/master/test/pagemod-test-helpers.js#L18

Unfortunately since the baseURI preference is set that prefix is completely ignored when self.data.url is called:

https://github.com/mozilla/addon-sdk/blob/master/lib/sdk/addon/bootstrap.js#L106
https://github.com/mozilla/addon-sdk/blob/master/lib/sdk/self.js#L24

Previously the test-native-options test was clearing baseURI while it ran which was hiding this but running the test individually shows that it has been faulty for a long time, at least back January, probably caused by bug 1115601.
(Assignee)

Comment 1

3 years ago
Created attachment 8576332 [details] [review]
pull request

This is looking more healthy on travis. One intermittent failure (bug 1009340), one other I didn't recognise but respinning to check. Pretty sure this is good though.
Attachment #8576332 - Flags: review?(evold)
(Assignee)

Updated

3 years ago
Blocks: 1139189
Attachment #8576332 - Flags: review?(evold) → review+
Blocks: 902217
Priority: -- → P1

Comment 2

3 years ago
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/5d4a58046a91888b743629106c59c8c434fcfcc2
Bug 1142330: Make child loaders user a unique ID so they don't inherit the preferences of the parent loader.

https://github.com/mozilla/addon-sdk/commit/b637d55fe61e3ab5362a703fd96489eeb899a6d2
Merge pull request #1893 from Mossop/bug1142330

Bug 1142330: Make child loaders user a unique ID so they don't inherit the preferences of the parent loader. r=erikvold
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.