Mail and Editor appear in Task menu when not built into application

RESOLVED WORKSFORME

Status

P4
normal
RESOLVED WORKSFORME
19 years ago
2 years ago

People

(Reporter: darkmane, Assigned: jrgmorrison)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Repro:
     CLean Build Tree
     configure --disable-md --disable-mailnews --disable-editor --disable-tests
--disable-static
     make
     cd dist/bin
     mozilla-apprunner.sh
     Click on the task menu


Behavior:

    Both messenger and Editor appear in the task menu

Expected behavior: Options that have been disabled by the build process should
not appear in the menu sytem.
(Reporter)

Updated

19 years ago
Depends on: 11385
(Reporter)

Comment 1

19 years ago
Made the bug dependant on 11385, because until the build system is fixed, no
testing can be done.

Updated

19 years ago
Assignee: trudelle → don

Comment 2

19 years ago
don, isn't this an XPApps policy issue? the menu itself works, so...

Updated

19 years ago
Component: XUL → XPApps

Comment 3

19 years ago
The xul files are not going to get modified by setting compiler flags. The menu
could be built by checking which components are installed but that is a bit of
work. Might be easier to just maintain 2 sets of xul. Set component to XPApps

Updated

19 years ago
OS: Linux → All
Hardware: Macintosh → All

Comment 4

19 years ago
Change platform and OS to all

Updated

19 years ago
Assignee: don → davidm
Priority: P3 → P2
Target Milestone: M13

Comment 5

19 years ago
David, how hard is it to fix this problem?  You're going to tell me that the
task menu is only the top goop on this whole modularity can of worms, aren't
you? :-)

Can you work with Paul Hangas and an Editor geek (Simon?) to make sure we at
least we have the multiple sets of XUL working the right way.

Comment 6

19 years ago
Yep fixing the task menu is a small percentage of the work. The new menu,
taskbar, search, prefs, help system and who know what else also needs to be done.
At one point in time hyatt was going to be doing some fancy chrome registry work
to allow overlays to do some of the UI merging work ( although I am not sure if
that is adequate). No idea what the current plans are. If we wanted a component
based UI we should have done some planning work.
This is related to bug #6064 and bug #10963.

Updated

19 years ago
Assignee: davidm → don
Target Milestone: M13 → M15

Comment 8

19 years ago
Move to M15.  Not required for beta 1.

Comment 9

19 years ago
Move to M16 for now ...
Target Milestone: M15 → M16

Updated

19 years ago
Target Milestone: M16 → M18

Comment 10

19 years ago
Move to M21 target milestone.
Target Milestone: M18 → M21
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy

Comment 12

18 years ago
nav triage team:

Would be nice to have, but probably won't get to it for beta1
Keywords: nsbeta1-
Priority: P2 → P4

Comment 13

18 years ago
XPAPPs & XPToolkit are jrgm's area
Assignee: vishy → jrgm
(Assignee)

Comment 14

18 years ago
This is fixed is it not. Certainly the installers make sure that these 
menuitems are not overlayed if not installed. Or is this specifically 
for the unix build process. Marking WORKSFORME (and giving it back to 
the previous owner, cause ckritzer has been on a crack binge).
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 15

18 years ago
Okay, so I can't close it and give it away at the same time ... [If it's 
reopened then it needs a new owner).

Comment 16

18 years ago
This should be split if it is ever reopened [MailNews and Editor are different 
<g>]. If it needs to be reopened, feel free to assign it to me. It would also 
need to be blocked by a menugroup xbl widget which hyatt promised.

Otherwise if this is partially fixed, i'll verify tomorrow.

Comment 17

18 years ago
small atomic mass update:
qacontact->jrgm
QA Contact: ckritzer → jrgm
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.