Aero Glass not painted when Thunderbird looses focus with WindowBlinds installed

RESOLVED INVALID

Status

Thunderbird
General
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: realRaven, Unassigned)

Tracking

({regression})

37 Branch
x86_64
Windows 7
regression

Thunderbird Tracking Flags

(thunderbird37 affected)

Details

(Reporter)

Description

3 years ago
Just upgraded the beta to 37.beta1. It exhibits a bug I have already seen with the latest version of Firefox. When I switch away to another window from Tb (=e.g. to Firefox or Postbox) the Thunderbird window looks completely unpainted:

http://i.imgur.com/GT6U32c.png

then if I do not focus to the main window but only hover over various screen elements only these get repainted:

http://i.imgur.com/zkdrpQT.png

When I click the main window it sometime repaints or sometimes repaints single screen elements. When I resize the window, it "flashes" (completely renders the screen elements and then makes them invisible again).

Graphics Card: 
ATI Radeon Hd 4850
that was a quite common card when I bought it a few years back. IU know there are sometimes font rendering issues on Firefow (smidged fonts) and there was an about:config entry that would prevent this. Hoping this is something similar...
(Reporter)

Comment 1

3 years ago
I could reproduce the same bug with Earlybird (38.0a2 (2015-03-13))
About dialiog is problematic:
http://i.imgur.com/FZ5ltTD.png
when I use a non-standard theme as workaround it doesn't manifest when the main window looses focus, but resizing makes the bug still appear:

the client area is black and only hovered widgets are repainted:
http://i.imgur.com/L0sSlXW.png

Maybe this will help in determining on which Windows Repaint cycle the bug happens.
Axel, can you try to disable HW-acceleration? On TB 37 in Options/Advanced you can untick the option "Use hardware acceleration when available". On TB 36 you need to switch in "Config Editor" layers.acceleration.disabled and gfx.direct2d.disabled to true.
(Reporter)

Comment 3

3 years ago
I tried toggling the following settings so far without success:

gfx.canvas.azure.accelerated = false
gfx.direct2d.disabled = true
gfx.direct2d.use1_1 = false
gfx.direct2d.force-enabled = true
gfx.work-around-driver-bugs = false
gfx.vsync.refreshdriver = false

but I wonder was there a "tiles" one for ATI cards? (Can't remember the full name)

also, is it possible to diff 37beta1 default prefs with 36beta1 to see what new (graphics) settings have been introduced?
(Reporter)

Comment 4

3 years ago
Another comment - I do NOT have this issue with the current Firefox beta (Fx 37.0) but there might be helpful prefs configured  in there that undo agressive screen update routines of hte new gecko engine. I will try to create new profile on that to see whether it recreates the problem there as well (assuming the platform is the same as on Tb 37beta1)
(Reporter)

Comment 5

3 years ago
Another observation: I can avoid the error completely by turning off Aero; so there is a high probability that this is related to transparency functions on my graphics adapter / graphics driver. There must be something in the rendering that was added in this machine that either accelerates or change the method of the way native transparency is handled?

Comment 6

3 years ago
Try setting layers.acceleration.disabled to "true" (which did it for me with weird graphics issues).
As for tiles, I have layers.enable-tiles "false" and layers.tiles.adjust "true" along with that.

Also, why does this bug have a "blocking" severity? Doesn't look like it's universal.
(Reporter)

Comment 7

3 years ago
(In reply to rsx11m from comment #6)
> Try setting layers.acceleration.disabled to "true" (which did it for me with
> weird graphics issues).
tried that but it didn't resolve the issue.

> As for tiles, I have layers.enable-tiles "false" and layers.tiles.adjust
> "true" along with that.
> 
> Also, why does this bug have a "blocking" severity? Doesn't look like it's
> universal.
Well if I do not find a workaround I will have to buy a different graphics card (and my reasoning was that the HD4850 was widely used and still has great performance without being a power hog); but I see your point so I am demoting this to "major" for now
Severity: blocker → major
(Reporter)

Comment 8

3 years ago
(In reply to rsx11m from comment #6)
> As for tiles, I have layers.enable-tiles "false" and layers.tiles.adjust
> "true" along with that.
> 
is already set to this (by default). Also I do recall that this was addressing smeared fonts, which wasn't really related. I think that this one is about transparent layers (that are behind the canvas) being refreshed or getting WM_PAINT at the wrong time. But I am not an expert with Windows Rendering. I think the only way to find out would be to "diff" the Platform, and also check if there were any new Gecko prefs added in this release?
(In reply to Axel Grude [:realRaven] from comment #4)
> I will try to create new profile.

Have you tried the new profile? Still the same issue?
(Reporter)

Comment 10

3 years ago
(In reply to Richard Marti (:Paenglab) from comment #9)
> (In reply to Axel Grude [:realRaven] from comment #4)
> > I will try to create new profile.
> 
> Have you tried the new profile? Still the same issue?

Yes the error happens in a fresh profile as well. It is definitely caused by a change in platform (Gecko). My guess is some different hardware acceleration / transparency functionality.
(Reporter)

Comment 11

3 years ago
I found out I can avoid the bug by checking a per-application setting in Windowblinds, called "Enable this if glass is painting with nothing on it". It is hidden away in

Per application / Advanced Features.

Unfortunately I did not find a way to set it globally, but I will raise a bug with Stardock support as they seem to be aware of what might trigger it.
(Reporter)

Updated

3 years ago
Summary: Screen painting disabled when Thunderbird looses focus - faulty repaint → Aero Glass not painted when Thunderbird looses focus
Axel, if you can find a regression window using the Thunderbird Daily builds then that would help narrow down the change that caused this on our end. However, it's quite possible that this isn't a Thunderbird bug at all since this requires third-party software to reproduce.
Severity: major → normal
Summary: Aero Glass not painted when Thunderbird looses focus → Aero Glass not painted when Thunderbird looses focus with WindowsBlinds installed
(Reporter)

Comment 13

3 years ago
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #12)
> Axel, if you can find a regression window using the Thunderbird Daily builds
> then that would help narrow down the change that caused this on our end.

How would I go about this? Since it started with the last beta wouldn't I have to work my way backwards through builds from there towards release somehow?


> However, it's quite possible that this isn't a Thunderbird bug at all since
> this requires third-party software to reproduce.

I am aware that it is very graphics card specific (probably much like the blurred font one, and also having Windowblinds installed to skin Windwos 7 in non standard way doesn't help). By the way Stardock promised they are working on a version that fixes the min/max/restore restore bug caused by Firefox (and possibly Tb) window frame theming. I quite like the flexibility of themes in windows 7 afforded to me by Stardock; wouldn't like the fixed layouts that are forced on users in the Mac world.
(In reply to Axel Grude [:realRaven] from comment #13)
> (In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #12)
> > Axel, if you can find a regression window using the Thunderbird Daily builds
> > then that would help narrow down the change that caused this on our end.
> 
> How would I go about this? Since it started with the last beta wouldn't I
> have to work my way backwards through builds from there towards release
> somehow?

All of our past builds are on the ftp server:
* 36.0b1: ftp://ftp.mozilla.org/pub/thunderbird/releases/36.0b1/
* 34.0b1: ftp://ftp.mozilla.org/pub/thunderbird/releases/34.0b1/
* 33.0b1: ftp://ftp.mozilla.org/pub/thunderbird/releases/33.0b1/
* 32.0b1: ftp://ftp.mozilla.org/pub/thunderbird/releases/32.0b1/
... and so on. You'll want to install each of these and test them to see where the problem begins. 

> 
> 
> > However, it's quite possible that this isn't a Thunderbird bug at all since
> > this requires third-party software to reproduce.
> 
> I am aware that it is very graphics card specific (probably much like the
> blurred font one, and also having Windowblinds installed to skin Windwos 7
> in non standard way doesn't help). By the way Stardock promised they are
> working on a version that fixes the min/max/restore restore bug caused by
> Firefox (and possibly Tb) window frame theming. I quite like the flexibility
> of themes in windows 7 afforded to me by Stardock; wouldn't like the fixed
> layouts that are forced on users in the Mac world.

Fair enough, but if it's not our bug there's probably nothing we can do about it until Stardock fixes it on their end.
(Reporter)

Comment 15

3 years ago
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #14)
> (In reply to Axel Grude [:realRaven] from comment #13)
> > (In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #12)
> > > Axel, if you can find a regression window using the Thunderbird Daily builds
> > > then that would help narrow down the change that caused this on our end.
> > 
> > How would I go about this? Since it started with the last beta wouldn't I
> > have to work my way backwards through builds from there towards release
> > somehow?
> 
> All of our past builds are on the ftp server:
> * 36.0b1: ftp://ftp.mozilla.org/pub/thunderbird/releases/36.0b1/
> * 34.0b1: ftp://ftp.mozilla.org/pub/thunderbird/releases/34.0b1/
> * 33.0b1: ftp://ftp.mozilla.org/pub/thunderbird/releases/33.0b1/
> * 32.0b1: ftp://ftp.mozilla.org/pub/thunderbird/releases/32.0b1/
> ... and so on. You'll want to install each of these and test them to see
> where the problem begins. 
> 
Oh I ran all the betas since they started. The bug started with 37.beta1. Obviously I always run the latest beta, have been doing it for a year now.
Thanks Axel,

Could you narrow this down further using the 37.0a1 nightly builds?

You'll find the first Thunderbird 37.0a1 build in the November 29, 2014 folder:
ftp://ftp.mozilla.org/pub/thunderbird/nightly/2014/11/2014-11-29-03-02-03-comm-central/

You'll find the last Thunderbird 37.0a1 build in the January 12, 2015 folder:
ftp://ftp.mozilla.org/pub/thunderbird/nightly/2015/01/2015-01-12-03-02-03-comm-central/

Keep testing builds between those dates until you narrow it down to a single day difference between a working build and a broken build. I can provide further direction as needed.
(Reporter)

Comment 17

3 years ago
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #16)
> Thanks Axel,
> 
> Could you narrow this down further using the 37.0a1 nightly builds?
> 
> You'll find the first Thunderbird 37.0a1 build in the November 29, 2014
> folder:
> ftp://ftp.mozilla.org/pub/thunderbird/nightly/2014/11/2014-11-29-03-02-03-
> comm-central/

> 
there are a lot of files in there, but the Windows ones are only around 70kBytes? Also should I install 32bit (like Firefox) even though my OS is 64bit?
(Reporter)

Comment 19

3 years ago
Anthony,

I have started to install the daily versions you suggested, and can confirm that the problems starts with version

thunderbird-37.0a1.en-US.win32-2014-12-09-03-02-06-c-c
- Version 37.0a1 (2014-12-09)

Once I roll back to 
thunderbird-37.0a1.en-US.win32-2014-12-05-03-02-01-c-c
- Version 37.0a1 (2014-12-05)

the problem is gone. hth.

Comment 20

3 years ago
FWIW, bug 1149761 also cites WindowBlinds
Summary: Aero Glass not painted when Thunderbird looses focus with WindowsBlinds installed → Aero Glass not painted when Thunderbird looses focus with WindowBlinds installed
(Reporter)

Comment 22

3 years ago
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #21)
> Thanks Axel, two more builds to test:
> 
> *
> ftp://ftp.mozilla.org/pub/thunderbird/nightly/2014/12/2014-12-07-03-02-11-
> comm-central/thunderbird-37.0a1.en-US.win32.installer.exe
> *
> ftp://ftp.mozilla.org/pub/thunderbird/nightly/2014/12/2014-12-06-03-02-03-
> comm-central/thunderbird-37.0a1.en-US.win32.installer.exe

Tested both and they are fine. Do you have one for the 8th of December as well?
(Reporter)

Comment 23

3 years ago
I also tested the installer in 
ftp://ftp.mozilla.org/pub/thunderbird/nightly/2014/12/2014-12-08-03-02-08-comm-central/

and this one is fine as well. 

As soon as I install the build from the 9th of December the graphics problem is back. So I guess you can start diff-ing now :)
Thanks Axel, I would guess either bug 1108057 or bug 1108198 caused this regression. I've flagged the developers for those bugs, hopefully they have some insight.
status-thunderbird37: --- → affected
tracking-thunderbird37: --- → ?
Flags: needinfo?(richard.marti)
Flags: needinfo?(aleth)
Keywords: regression

Comment 26

3 years ago
Bug 1108057 is a font-size CSS change in the chat sidebar, it can't cause anything as dramatic as this.
Flags: needinfo?(aleth)

Comment 27

3 years ago
Does this problem affect 38 too?

Comment 28

3 years ago
(In reply to aleth [:aleth] from comment #27)
> Does this problem affect 38 too?

Ah, sorry, I missed comment 1.
I don't think bug 1108198 caused this regression because it changes a prefs how the content colors are used and doesn't affect the window painting. And this is a copy of a FX patch. If this affects TB, then it should also affect FX.

I think the regression comes from m-c with a change in the display drawing part.
Flags: needinfo?(richard.marti)

Comment 30

3 years ago
(In reply to Richard Marti (:Paenglab) from comment #29)
> I think the regression comes from m-c with a change in the display drawing
> part.

Bug 1107297 - D3D11 should only composite invalid rect
Flags: needinfo?(bas)
(Reporter)

Comment 31

3 years ago
Sounds(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #30)
> (In reply to Richard Marti (:Paenglab) from comment #29)
> > I think the regression comes from m-c with a change in the display drawing
> > part.
> 
> Bug 1107297 - D3D11 should only composite invalid rect

Sounds plausible. It is a windows specific paint routine affecting rectangles... Interestingly hovering the element with the mouse invalidates the element in a way that they are properly repainted. The question is whether there is a (Dx) option in about:config which I could turn off to test whether it affects the patched version?
I think it might be just the general usage of WARP. WindowBlinds is a form of malware(yes, I'm sorry, that's really what it is, intercepting OS calls and interfering with their functioning really can't be described in any other way) that intercepts DirectX calls in a variety of way in order to achieve it goals. We've seen it interact poorly with WARP before, what's your about:support graphics section say?
Flags: needinfo?(bas)
(Reporter)

Comment 33

3 years ago
(In reply to Bas Schouten (:bas.schouten) from comment #32)
> I think it might be just the general usage of WARP. WindowBlinds is a form
> of malware(yes, I'm sorry, that's really what it is, intercepting OS calls
> and interfering with their functioning really can't be described in any
> other way) that intercepts DirectX calls in a variety of way in order to
> achieve it goals. We've seen it interact poorly with WARP before, what's
> your about:support graphics section say?

I don't about your statement on the Windowblinds' implementation methods, but it appears to have worked quite nicely in XP and Windows 7 over the last couple of years (I use it maybe for 10 years) and they seem to generally keep the pace without crashing stuff - I use this system as DAW, programming platform and for gaming. In the end it is the exsperience that counts for me. The only applications that have problems are Firefox (minimize/maximise buttons) and Virtualbox (invisible caption bar, even if I disable skinning). Generally it seems to be application that provide their own skinning methods for titlebar / window borders while keeping some of the native UI within. There seem to be no problems with "complete reskins" (where Windows Themes are completely ignored) either.

There are a few special settings in my setups, I believe my old graphics card (MSI AMD Radeon HD 4800) is a little too outdated for Dx11. Here are the settings on my test profile:



  Application Basics

    Name: Thunderbird
    Version: 38.0
    User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Thunderbird/38.0
    Profile Folder: Show Folder

              (Local drive)
    Application Build ID: 20150401012718
    Enabled Plugins: about:plugins
    Build Configuration: about:buildconfig
    Memory Use: about:memory

  Mail and News Accounts
    account1:
      INCOMING: account1, , (imap) imap.googlemail.com:993, SSL, passwordCleartext
      OUTGOING: smtp.googlemail.com:465, SSL, passwordCleartext, true

    account2:
      INCOMING: account2, , (none) Local Folders, plain, passwordCleartext

    account3:
      INCOMING: account3, , (pop3) pop3.live.com:995, SSL, passwordCleartext
      OUTGOING: smtp.live.com:587, alwaysSTARTTLS, passwordCleartext, true

    account5:
      INCOMING: account5, , (im) prpl-irc, plain, 0

    account6:
      INCOMING: account6, , (imap) imap.mail.yahoo.com:993, SSL, passwordCleartext
      OUTGOING: smtp.mail.yahoo.com:465, SSL, passwordCleartext, true

    account7:
      INCOMING: account7, , (imap) imap.gmail.com:993, SSL, passwordCleartext
      OUTGOING: smtp.gmail.com:465, SSL, passwordCleartext, true
      OUTGOING: smtp.gmail.com:465, SSL, passwordCleartext, false
      OUTGOING: smtp.gmail.com:465, SSL, passwordCleartext, false

    account9:
      INCOMING: account9, , (imap) imaps.pec.aruba.it:993, SSL, passwordCleartext
      OUTGOING: smtps.pec.aruba.it:465, SSL, passwordCleartext, true

    account10:
      INCOMING: account10, , (imap) imap.googlemail.com:993, SSL, passwordCleartext
      OUTGOING: smtp.googlemail.com:465, SSL, passwordCleartext, true

  Crash Reports
    http://crash-stats.mozilla.com/report/index/bp-2af18e6d-2ff9-4beb-bd74-c66a42150409 (09/04/2015)
    http://crash-stats.mozilla.com/report/index/bp-44f02094-ce69-495c-806b-067332150314 (14/03/2015)
    http://crash-stats.mozilla.com/report/index/bp-69dee065-52bd-4f7d-b316-5ecc02150220 (20/02/2015)
    http://crash-stats.mozilla.com/report/index/bp-70eeaf51-9e3c-46a8-b7e1-a5fad2140723 (23/07/2014)
    http://crash-stats.mozilla.com/report/index/bp-46003422-e755-4d29-a5f8-ec3752130902 (02/09/2013)

  Extensions
    CodeHighlight, 1.0.0, true, codehighlight@linuxstyle.org
    CompactHeader, 2.1.0beta5, true, {58D4392A-842E-11DE-B51A-C7B855D89593}
    Console², 0.9, true, {1280606b-2510-4fe0-97ef-9b5a22eafe80}
    Copy Folder, 1.61, true, copyfolder@crunch.mod
    Custom Buttons, 0.0.5.8, true, custombuttons@xsms.org
    DOM Inspector, 2.0.15, true, inspector@mozilla.org
    Gisp folder macro, 1.5pre15, true, gispfoldermacro@mesquilla.com
    Menu On Top, 1.0pre227, true, menuOnTop@agrude.com
    Quick Locale Switcher, 1.7.8.7, true, {25A1388B-6B18-46c3-BEBA-A81915D0DE8F}
    quickFilters, 2.9pre111, true, quickFilters@axelg.com
    QuickFolders, 4.1pre24, true, quickfolders@curious.be
    QuickPasswords, 3.5, true, QuickPasswords@axelg.com
    Restartless Restart, 9, true, restartless.restart@erikvold.com
    Shrunked Image Resizer, 4.0.3, true, shrunked@darktrojan.net
    SmartTemplate4, 0.9.6.1pre86, true, smarttemplate4@thunderbird.extension
    Stacked Inspector, 1.0.20110524, true, stackedinspector@example.com
    Stationery, 0.8.5.04.beta, true, {d0e38b3a-0d60-46bf-bf01-83d4ba041015}
    Titlebar Cleaner, 0.4.1, true, titlebarCleaner@agrude.com
    ViewAbout, 2.0.1, true, viewabout@rumblingedge.com
    Zombie Keys, 2.17pre10, true, zombiekeys@bolay.de
    Account Colors, 9.0, false, accountcolors@DW-dev
    Calendar EWS Provider, 3.2.0-Beta52, false, ewscalendar@mesquilla.com
    Color Folders, 1.1, false, colorfolders@fisheater.com
    ColumnsWizard, 5.0.1, false, columnswizard@micz.it
    Correct Identity, 1.4.3, false, {47ef7cc0-2201-11da-8cd6-0800200c9a66}
    DKIM Verifier, 1.3.3, false, dkim_verifier@pl
    Envelope-Content Splitting, 1.36, false, {FEB9E708-1431-11DE-B5CD-B98556D89593}
    ExQuilla for Microsoft Exchange, 31.0.1136, false, exquilla@mesquilla.com
    Extension List Dumper, 1.15.2, false, extensionlistdumper@sogame.cat
    Extension Test, 2.7b1, false, extension-test@dactyl.googlecode.com
    ExternalTemplateLoader, 0.4.3, false, {aaf23341-212c-43c4-8824-e51cfe051345}
    Extra Folder Columns, 1.1.5, false, extra-cols@jminta_gmail.com
    FiltaQuilla, 1.3.0, false, filtaquilla@mesquilla.com
    Folder Pane View Switcher, 1.10, false, FolderPaneSwitcher@kamens.us
    folderplus, 1.9, false, folderplus@gorsini.free.fr
    Lightning, 3.3.3, false, {e2fda1a4-762b-4020-b5ad-a41df1933103}
    Mail Redirect, 0.8.5, false, {CC3C233D-6668-41bc-AAEB-F3A1D1D594F5}
    Manually Sort Folders, 1.1, false, tbsortfolders@xulforum.org
    MRC Compose, 1.6.2, false, mrc_compose@mr-consultant.net
    Multiple Addon Deactivator, 1.7, false, ChrisLE@mozilla.org
    Noia 2.0 eXtreme XT, 3.50, false, noia2_full_xt@gd.noia
    Noia Fox Einstellungen, 3.0.1, false, NoiaFoxoption@davidvincent.tld
    Quicker Filer, 0.6.4, false, qfiler@eivind.rovik
    Return Receipt Toolbar Button, 0.20, false, return@teozyczkowski.pl
    Secure Addressing, 1.6, false, secure-addressing@matsuba.net
    Silvermel and Charamel XT, 1.5.7, false, silvermelxt@pardal.de
    Smiley Fixer, 1.4, false, smiley-fixer@richard.quirk
    Theme Font & Size Changer, 37.0, false, {f69e22c7-bc50-414a-9269-0f5c344cd94c}
    ThreadVis, 2.2.0, false, {A23E4120-431F-4753-AE53-5D028C42CFDC}
    Thunderbird Conversations, 2.8.1, false, gconversation@xulforum.org
    ThunderPEC, 1.6.3, false, thunderpec@gmail.com

  Important Modified Preferences

    Name: Value

      accessibility.typeaheadfind.flashBar: 0
      browser.cache.disk.capacity: 358400
      browser.cache.disk.smart_size_cached_value: 358400
      browser.cache.disk.smart_size.first_run: false
      browser.cache.disk.smart_size.use_old_max: false
      dom.report_all_js_exceptions: true
      extensions.lastAppVersion: 38.0
      font.internaluseonly.changed: true
      font.name.monospace.el: Consolas
      font.name.monospace.tr: Consolas
      font.name.monospace.x-baltic: Consolas
      font.name.monospace.x-central-euro: Consolas
      font.name.monospace.x-cyrillic: Consolas
      font.name.monospace.x-unicode: Consolas
      font.name.monospace.x-western: Consolas
      font.name.sans-serif.el: Calibri
      font.name.sans-serif.tr: Calibri
      font.name.sans-serif.x-baltic: Calibri
      font.name.sans-serif.x-central-euro: Calibri
      font.name.sans-serif.x-cyrillic: Calibri
      font.name.sans-serif.x-unicode: Calibri
      font.name.sans-serif.x-western: Calibri
      font.name.serif.el: Cambria
      font.name.serif.tr: Cambria
      font.name.serif.x-baltic: Cambria
      font.name.serif.x-central-euro: Cambria
      font.name.serif.x-cyrillic: Cambria
      font.name.serif.x-unicode: Cambria
      font.name.serif.x-western: Cambria
      font.size.fixed.el: 14
      font.size.fixed.tr: 14
      font.size.fixed.x-baltic: 14
      font.size.fixed.x-central-euro: 14
      font.size.fixed.x-cyrillic: 14
      font.size.fixed.x-unicode: 14
      font.size.fixed.x-western: 14
      font.size.variable.el: 17
      font.size.variable.tr: 17
      font.size.variable.x-baltic: 17
      font.size.variable.x-central-euro: 17
      font.size.variable.x-cyrillic: 17
      font.size.variable.x-unicode: 17
      font.size.variable.x-western: 17
      general.useragent.locale: de-DE
      gfx.direct3d.last_used_feature_level_idx: 0
      javascript.options.strict: true
      mail.openMessageBehavior.version: 1
      mail.winsearch.firstRunDone: true
      mailnews.database.global.datastore.id: db6927dd-7efa-4d79-adcb-c1e66649984
      mailnews.database.global.views.conversation.columns: {"threadCol":{"visible":true,"ordinal":"1"},"flaggedCol":{"visible":true,"ordinal":"3"},"attachmentCol":{"visible":false…
      mailnews.database.global.views.global.columns: {"threadCol":{"visible":true,"ordinal":"1"},"flaggedCol":{"visible":true,"ordinal":"3"},"attachmentCol":{"visible":true,…
      network.automatic-ntlm-auth.trusted-uris: https://eumail.avaya.com
      network.cookie.prefsMigrated: true
      network.predictor.cleaned-up: true
      places.database.lastMaintenance: 1428783763
      places.history.expiration.transient_current_max_pages: 104858
      plugin.importedState: true

  Graphics

      Adapter Description: ATI Radeon HD 4800 Series
      Vendor ID: 0x1002
      Device ID: 0x9442
      Adapter RAM: 1024
      Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
      Driver Version: 8.970.100.1100
      Driver Date: 4-29-2013
      Direct2D Enabled: true
      DirectWrite Enabled: true (6.2.9200.16571)
      ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
      WebGL Renderer: false
      GPU Accelerated Windows: 1/1 Direct3D 11

      AzureCanvasBackend: direct2d 1.1
      AzureSkiaAccelerated: 0
      AzureFallbackCanvasBackend: cairo
      AzureContentBackend: direct2d 1.1

  JavaScript

  Incremental GC: 1

  Accessibility

    Activated: 0
    Prevent Accessibility: 0

  Library Versions

      Expected minimum version
      Version in use

      NSPR
      4.10.8
      4.10.8

      NSS
      3.18 Basic ECC
      3.18 Basic ECC

      NSS Util
      3.18
      3.18

      NSS SSL
      3.18 Basic ECC
      3.18 Basic ECC

      NSS S/MIME
      3.18 Basic ECC
      3.18 Basic ECC
(Reporter)

Comment 34

3 years ago
ANother comment: I upgraded my graphics card to a modern Geforce 960 today and I can still reproduce the bug. So it is pretty clear to me that it is a problem with Stardock's Windowblinds. The good thing is that they have that "per application setting" which is "Enable this if glass is painting with nothing on it", so they must be aware that there is a problem with some apps. I am enabling this option for now, but I can always test again with this switched off if you need me to run any more versions.

Comment 35

3 years ago
Just to confirm that the same thing was happening to my long-standing Thunderbird install since the auto update to v38. TB was always fine before. (Win7 Nvidia GTX 295)

I seem to have some recollection of something similar in the past some years ago and maybe I'd tweaked a setting or two in TB config for hardware acceleration but trying that now that made no difference to the current repainting issues. 

Finding this suggestion (as above) for changing a per application setting in WindowBlinds8 did the trick for me and now the redraw failures and blackouts of TB have now stopped.

In main TB releases, it was definitely a change in v38 that brought the problem out for me.

Comment 36

3 years ago
Based on comment 32 and comment 34 it sounds like this is stardock's issue, so closing invalid.

bug 982362 is also Axel's
Status: NEW → RESOLVED
Last Resolved: 3 years ago
tracking-thunderbird37: ? → ---
Resolution: --- → INVALID
See Also: → bug 982362
You need to log in before you can comment on or make changes to this bug.