Closed Bug 1143567 Opened 5 years ago Closed 5 years ago

Ensure that non-APZ input events have any APZ transform applied

Categories

(Core :: Panning and Zooming, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla39
Tracking Status
firefox39 --- fixed

People

(Reporter: dvander, Assigned: dvander)

References

Details

Attachments

(4 files)

Even if events aren't processed by APZ, we still need to fix their reference point to account for any async transforms.
Add the DispatchInputEvent call which will make sure the event goes through APZ first.
Attachment #8577910 - Flags: review?(bugmail.mozilla)
Attached patch part 2, fix gtkSplinter Review
Attachment #8577911 - Flags: review?(bugmail.mozilla)
This cleans up the Dispatch*Event functions in nsWindow so they take the actual type they're supposed to. Predictably there were paths with bad casts.
Attachment #8577913 - Flags: review?(jmathies)
Ensure that anything dispatching a WidgetInputEvent routes through DispatchInputEvent, which applies an APZ transform if one exists.

After the cleanup these are the only places (I think) that dispatch a WidgetInputEvent.
Attachment #8577914 - Flags: review?(jmathies)
Attachment #8577910 - Flags: review?(bugmail.mozilla) → review+
Attachment #8577911 - Flags: review?(bugmail.mozilla) → review+
Comment on attachment 8577913 [details] [diff] [review]
part 3, clean up nsWindow dispatch

Review of attachment 8577913 [details] [diff] [review]:
-----------------------------------------------------------------

::: widget/windows/winrt/MetroWidget.cpp
@@ +667,1 @@
>    mEventQueue.Push(newEvent);

mEventQueue.Push(cmdEvent);
Attachment #8577913 - Flags: review?(jmathies) → review+
Attachment #8577914 - Flags: review?(jmathies) → review+
Please see https://bugzilla.mozilla.org/show_bug.cgi?id=1144081 for a possible regression due to this patch.
You need to log in before you can comment on or make changes to this bug.