timeupdate event isn't fired before seeked event

RESOLVED FIXED in Firefox 38

Status

()

Core
Audio/Video
P2
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jya, Assigned: jya)

Tracking

(Blocks: 1 bug)

Trunk
mozilla39
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox37 wontfix, firefox38 fixed, firefox39 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
Per HTMLMediaElement spec:
http://www.w3.org/html/wg/drafts/html/master/semantics.html#seeking

"4.8.14.9 Seeking
16. ⌛ Queue a task to fire a simple event named timeupdate at the element.
17. ⌛ Queue a task to fire a simple event named seeked at the element.
"

The event timeupdate isn't fired.

This cause failure of the media-source/mediasource-duration.html test
(Assignee)

Comment 1

3 years ago
Created attachment 8579129 [details] [diff] [review]
Part1. Fire timeupdate before seeked event as per spec

fire timeupdate before seeked event.
Attachment #8579129 - Flags: review?(karlt)
(Assignee)

Updated

3 years ago
Assignee: nobody → jyavenard
Status: NEW → ASSIGNED
(Assignee)

Comment 2

3 years ago
Created attachment 8579137 [details] [diff] [review]
Part2. Update webref tests

update test. We don't pass on linux and webm as we fail an assert to calculate the duration of the video (6.042 vs 6.045)
Attachment #8579137 - Flags: review?(karlt)
Attachment #8579129 - Flags: review?(karlt) → review+
Attachment #8579137 - Flags: review?(karlt) → review+
Should the test be re-enabled on Mac now?
Perhaps win too?
Flags: needinfo?(jyavenard)
(Assignee)

Comment 4

3 years ago
There's more failure with the two following tests, they timeout.

I have found the cause for those (tracked in bug 1143971 and bug 1144617)
Flags: needinfo?(jyavenard)
(Assignee)

Updated

3 years ago
See Also: → bug 1144980

Updated

3 years ago
Priority: -- → P2
https://hg.mozilla.org/mozilla-central/rev/749fd9127c14
https://hg.mozilla.org/mozilla-central/rev/0abff0bf399a
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
(Assignee)

Comment 7

3 years ago
I believe this should be uplifted for 38.
Flags: needinfo?(giles)
Comment on attachment 8579129 [details] [diff] [review]
Part1. Fire timeupdate before seeked event as per spec

Approval Request Comment
[Feature/regressing bug #]: MSE and HTML5 video
[User impact if declined]: Spec compliance, possible stalls after seeking.
[Describe test coverage new/current, TreeHerder]: Landed on m-c, web platform tests.
[Risks and why]: Risk is low. We just queue the missing event, which should have no harmful side-effects.
[String/UUID change made/needed]: None.
Flags: needinfo?(giles)
Attachment #8579129 - Flags: approval-mozilla-aurora?
status-firefox37: --- → wontfix
status-firefox38: --- → affected
Attachment #8579129 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Windows permafail on Aurora:
https://treeherder.mozilla.org/logviewer.html#?job_id=715812&repo=mozilla-aurora
Flags: needinfo?(jyavenard)
Flags: needinfo?(giles)
(Assignee)

Comment 12

3 years ago
You need bug 1142433 uplifted...
Flags: needinfo?(jyavenard)
I believe jya addressed this.
Flags: needinfo?(giles)
You need to log in before you can comment on or make changes to this bug.