Disable media-source/mediasource-duration.html

RESOLVED FIXED in Firefox 39

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jya, Assigned: jya)

Tracking

(Depends on 1 bug, Blocks 1 bug)

Trunk
mozilla39
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox39 fixed)

Details

Attachments

(2 attachments, 2 obsolete attachments)

Following bug 1142433, as we now properly reports the duration of the media segments, we fail differently.

Those errors are now:
/media-source/mediasource-duration.html
---------------------------------------
TIMEOUT expected FAIL Test endOfStream completes previous seek to truncated duration
TIMEOUT expected FAIL Test setting same duration multiple times does not fire duplicate durationchange
TIMEOUT [Parent]
Disable test
Attachment #8578002 - Flags: review?(karlt)
Assignee: nobody → jyavenard
Status: NEW → ASSIGNED
Blocks: 1143971
Comment on attachment 8578002 [details] [diff] [review]
Disable media-source/mediasource_duration.html

>Now test will consistently timeout.

If the test is consistently timing out, then please annotate with
"expected: TIMEOUT", instead of disabling.  That way the test that is passing can continue to run, and we will notice when the others are fixed.
Attachment #8578002 - Flags: review?(karlt) → review-
Marking them as timing out on windows 7/8.1 and mac
Attachment #8578422 - Flags: review?(karlt)
Attachment #8578002 - Attachment is obsolete: true
Duplicate of this bug: 1143999
Depends on: 1143999
Marking them as timing out on windows 7/8.1 and mac
Attachment #8578439 - Flags: review?(karlt)
Attachment #8578422 - Attachment is obsolete: true
Attachment #8578422 - Flags: review?(karlt)
Comment on attachment 8578439 [details] [diff] [review]
Disable media-source/mediasource_duration.html

>Now test will consistently timeout.

Thanks.  Can you say "usually" timeout, or something to indicate that results are not consistent, please?
Attachment #8578439 - Flags: review?(karlt) → review+
Blocks: 1066467
Doh, forgot the log message, actually now it's just about updating the link
Blocks: 1144509
remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/eea4ea802424

and shortly after, as it appears webref are now running on mac too !
remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/6cf2a639d0b3
https://hg.mozilla.org/mozilla-central/rev/eea4ea802424
https://hg.mozilla.org/mozilla-central/rev/6cf2a639d0b3
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
Bug 1143999 tracks enabling this again.
You need to log in before you can comment on or make changes to this bug.