[Camera] The word 'Close' appears partially running off the screen when accessing camera through a pick / attach activity from email or messages

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: yzen)

Tracking

({late-l10n, regression})

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing],[2.2-nexus-5-l])

Attachments

(4 attachments)

Reporter

Description

4 years ago
Description:
When you access camera through an attachment function from email or messages you get a X next to the shutter button to allow you to return to the original app. On today's build, there is the word 'close' below the X. This text runs off the bottom of the screen (see screenshot)

Repro Steps:
1) Update a Flame to 20150318055750
2) Launch Messages
3) Select add-attachment
4 [review]) Select camera


Actual:
Word 'close' appears partially running off the bottom of the screen

Expected:
The word close will NOT appear 
-or-
it will not run off the screen

Environmental Variables:
Device: Flame Master
Build ID: 20150318055750
Gaia: b8051d370ddf4e5bd8e7d8a19fb9eeb5fd6ffb39
Gecko: 41a61514461e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (Master)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 5/5
See attached: screenshot
Reporter

Comment 1

4 years ago
This issue does NOT occur on 2.2

Actual results: the word 'close' does not appear

Device: Flame 2.2 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150318055750
Gaia: b8051d370ddf4e5bd8e7d8a19fb9eeb5fd6ffb39
Gecko: 41a61514461e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (Master)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Duplicate of this bug: 1144850
[Blocking Requested - why for this release]:
Regression of a core feature.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: ychung
I'm finding the broken window.
Since Yeojin is tracking this issue, please ignore comment 4.
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150316124630
Gaia: 61b13c3579317402a8603c69ae9e803fc75a0542
Gecko: 6bd9e79ac74f
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150316134029
Gaia: a1e2f2bdcafc814afdcba0c2258ca69f65b2a869
Gecko: 0f06c9f45cde
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: 61b13c3579317402a8603c69ae9e803fc75a0542
Gecko: 0f06c9f45cde

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: a1e2f2bdcafc814afdcba0c2258ca69f65b2a869
Gecko: 6bd9e79ac74f

https://github.com/mozilla-b2g/gaia/compare/61b13c3579317402a8603c69ae9e803fc75a0542...a1e2f2bdcafc814afdcba0c2258ca69f65b2a869

Possibly caused by bug 1068909 
(This has been uplifted on 2.2 this morning. I will re-check the issue on 2.2 later.)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
2.2 is also affected now on the latest build (possibly due to the uplift for bug 1068909). "Close" is shown next to the X button.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150319082140
Gaia: a3ef5b1a792957c8b22bb3cdded97f21e5a8cc88
Gecko: 99f7aadda070
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Yura, can you take a look at this please? Looks like the landing and recent uplift for bug 1068909 might have caused this to occur.
Blocks: 1068909
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(yzenevich)
Assignee

Comment 10

4 years ago
Comment on attachment 8580183 [details] [review]
[gaia] yzen:bug-1144733 > mozilla-b2g:master

I accidentally used an existing l10n key, this PR fixes the collision.
Flags: needinfo?(yzenevich)
Attachment #8580183 - Flags: review?(jdarcangelo)
Assignee

Updated

4 years ago
Assignee: nobody → yzenevich
Status: NEW → ASSIGNED
Attachment #8580183 - Flags: review?(jdarcangelo) → review+
Duplicate of this bug: 1145308
Duplicate of this bug: 1145069
This issue verified failed on nexus 5 2.2 and nexus5 3.0.

N5 2.2[Affected]:
Build ID               20150319002500
Gaia Revision          9043c11f699c15bb6072422d1dad6518d1b5ddda
Gaia Date              2015-03-19 01:40:44
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c0442d170bec
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150319.042430
Firmware Date          Thu Mar 19 04:24:46 EDT 2015
Bootloader             HHZ12d

N5 3.0(Affected):
Build ID               20150319160212
Gaia Revision          c39e15f631de80c69467fda0d4ea0bcda9e194ca
Gaia Date              2015-03-18 19:30:04
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cbd0efcd976c
Gecko Version          39.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150319.192641
Firmware Date          Thu Mar 19 19:26:57 EDT 2015
Bootloader             HHZ12d
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing],[2.2-nexus-5-l]
Assignee

Updated

4 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#2rz9PcXjS1KVIDYnvEDJxQ

The pull request failed to pass integration tests. It could not be landed, please try again.
Assignee

Updated

4 years ago
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 16

4 years ago
Comment on attachment 8580183 [details] [review]
[gaia] yzen:bug-1144733 > mozilla-b2g:master

[Approval Request Comment] Fixes a regression with showing 'Close' button in camera
[Bug caused by] (feature/regressing bug #): bug 1068909
[User impact] if declined: 'Close' label will be visible when picking.
[Testing completed]: on device
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: https://github.com/mozilla-b2g/gaia/pull/28987/files#diff-e4bc27afcad6f10d1abaf8eced7aa340
Attachment #8580183 - Flags: approval-gaia-v2.2?
Assignee

Updated

4 years ago
Keywords: late-l10n
blocking-b2g: 3.0? → 2.2+
Attachment #8580183 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
I can't find this anywhere on master, can someone explain what's going on?

No trace of this bug in the history, 
https://github.com/mozilla-b2g/gaia/commits/master/apps/camera/locales/camera.en-US.properties

And more important the string is not there.
Flags: needinfo?(kgrandon)
Thanks for letting me know. This was indeed a *big* problem due to infrastructure issues yesterday. I'm going to manually land this into master for now: https://github.com/mozilla-b2g/gaia/commit/406725c48afa3d45a4270ca1b41211ea05130d90

I'm also going to try to see if I can audit this in case it happened in other places. It should no longer be a problem.
Flags: needinfo?(kgrandon)
According to the STR of Comment 0, this bug has been successfully verified on latest Nightly Flame v2.2&3.0. The word "Close" does NOT appear.
See attachment: verified_v2.2&3.0.mp4
Reproduce rate: 0/5

Device: Flame 2.2 build(Pass)
Build ID               20150325162500
Gaia Revision          2d42a7c1d99472780e3aeb2e16d7cb0a4adbd222
Gaia Date              2015-03-25 20:46:52
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ebb742bfe1a4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150325.200218
Firmware Date          Wed Mar 25 20:02:30 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 build(Pass)
Build ID               20150325160204
Gaia Revision          508b8d48fb5ecf08bf0e5b4fef42bc48b770e7f2
Gaia Date              2015-03-25 16:54:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f40ee067d081
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150325.191758
Firmware Date          Wed Mar 25 19:18:07 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+] [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.