[homescreen] flickering of screen after deleting/delete apps/collections

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: aryx, Assigned: mstange)

Tracking

({polish, regression})

unspecified
2.2 S9 (3apr)
ARM
Android
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master unaffected)

Details

()

Attachments

(2 attachments)

B2G 2.2 201503220002503 on Flame (v18D base image)

After deleting an app or a smart collection, the whole screen will flicker for a short time.

Steps to reproduce:
1. Add 3 apps or smart collections into an own group.
2. Delete one of them.

Actual result:
Directly after confirming the deletion, the screen flickers.

This does not reproduce with B2G 3.0 20150320015602 on Keon.
Is this a regression?
Keywords: qawanted
QA Contact: ychung
I was able to reproduce this issue easily on Flame 2.2. This issue does NOT reproduce on Flame 3.0 and 2.1.

Result: The flickering on the screen is not observed when deleting a smart collection. 

Device: Flame 3.0
BuildID: 20150323052026
Gaia: 8eac260ee81a8aca05770d18c5736536d44ee7a7
Gecko: bc85c479668a
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2
BuildID: 20150323083624
Gaia: a9c115c2bfec193d0e9e55f760c92aabe9005b02
Gecko: 80aff14f7bdb
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1 
BuildID: 20150323065323
Gaia: 13c85d57f49b4bfd657ff674f2b530c141c94803
Gecko: acfc2a472b6f
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawantedregression
This looks really bad on Flame 2.2 so nominating 2.2?

Let's get a regression window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
QA Contact: pcheng
Can we get a video as well?
qawanted to get a video of the issue.
Keywords: qawanted
Added a video. You can see the flicker around 19 seconds into the video. It was really hard to hit the delete button. I am researching that issue now.

http://youtu.be/JFDMbjWehUM
blocking-b2g: 2.2? → 2.2+

Comment 7

4 years ago
kevin, could you help on this?
Flags: needinfo?(kgrandon)
Let's see if we can get a regression window first.
Flags: needinfo?(kgrandon)
mozilla-inbound reverse regression window:

Last Broken Environmental Variables:
Device: Flame
BuildID: 20150304142439
Gaia: eff3321ab4e65da3f906688ebb55ddf1e93d9452
Gecko: 478b551b19bd
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Working Environmental Variables:
Device: Flame
BuildID: 20150304142742
Gaia: eff3321ab4e65da3f906688ebb55ddf1e93d9452
Gecko: 2bd95d9c12bb
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Gaia is the same so it's a Gecko change that fixed this.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=478b551b19bd&tochange=2bd95d9c12bb

Fixed on 3.0 master by patches for Bug 913443.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Markus, can you take a look at this please? Looks like all the work that you did for bug 913443 resolved this issue on 3.0. Is there anyway we can get those fixes uplifted to 2.2?
Blocks: 913443
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(markus)

Comment 11

4 years ago
Name mixup, reassigned bug to :mstange instead. I've got nothing to do with this project ;-)
Flags: needinfo?(markus) → needinfo?(mstange)
Assignee

Comment 12

4 years ago
There were a few regressions from that patch; most of them have been fixed but I've just discovered another one. How much time is left for uplifting stuff to 2.2?
Flags: needinfo?(mstange)
Assignee

Updated

4 years ago
No longer blocks: 913443
Depends on: 913443

Comment 13

4 years ago
According to we are close to 2.2 FC. Kevin and Markus, could you help to evaluate the risk to uplift 2.2?
Flags: needinfo?(mstange)
Flags: needinfo?(kgrandon)
For what it's worth, I think we should uplift this - I'm sure the homescreen isn't the only place that will be flickering and let's consider that 2.2 is possibly going to be a very long-lived release.
I'm not the patch author, but seems like it's been baking on master for a while?
Flags: needinfo?(kgrandon)
Duplicate of this bug: 1148730
Assignee

Comment 17

4 years ago
It has been baking a while, and it needed to, since it's a risky change. By now I feel fairly confident that it would be safe to uplift. Tomorrow I'm going to see how much work it is to make the patch(es) apply to 2.2.

However, the patch should have been a pure optimization. It wasn't supposed to fix any bugs. This makes me a little afraid that the bug might still be hiding somewhere.
Flags: needinfo?(mstange)
(In reply to Markus Stange [:mstange] from comment #17)
> It has been baking a while, and it needed to, since it's a risky change. By
> now I feel fairly confident that it would be safe to uplift. Tomorrow I'm
> going to see how much work it is to make the patch(es) apply to 2.2.
> 
> However, the patch should have been a pure optimization. It wasn't supposed
> to fix any bugs. This makes me a little afraid that the bug might still be
> hiding somewhere.

Thanks Markus!
Up to you if you want to post the 2.2 patches here or in the original bug. Pleasse NI bajaj for the uplift approvals as soon as you are ready.
Assignee

Comment 19

4 years ago
I've fired off a try push with the merged patches:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=6ed206e6c262

This contains patches from the following bugs:
 - bug 1134311 (necessary for bug 913443 to apply)
 - part 1 from bug 961887 (necessary for bug 913443 to apply)
 - all of bug 913443
 - bug 1141595 (fixes regression from bug 913443)
 - bug 1144307 (fixes regression from bug 1141595)
Thanks Markus!
Naoki, can we do some sanity checks with the try build before we push?
Flags: needinfo?(nhirata.bugzilla)
Assignee

Comment 21

4 years ago
Ok, so that didn't build, because my patches also rely on bug 1127044. Looks like I do need to get this to compile locally first.
Flags: needinfo?(nhirata.bugzilla) → needinfo?
Assignee

Updated

4 years ago
Flags: needinfo?
Assignee

Comment 22

4 years ago
New try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=eeb060ab745c
Flags: needinfo?(nhirata.bugzilla)
I could have sworn that this bug was reported before 3/22.  Anyhow, it shows orange on mac desktop and red on windows desktop b2g.

Also to note there seems to be a performance issue when deleting the icons in the collection in the collection screen.  I'm not 100 % sure if this is the cause, I may have to file a separate bug.
Flags: needinfo?(nhirata.bugzilla)
Assignee

Comment 25

4 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #24)
> Anyhow, it shows orange on mac desktop and red on windows desktop b2g.

I've done two more pushes, once with an up-to-date b2g37 without my patches, and once with the same revision but with my patches applied.
Without patch: https://treeherder.mozilla.org/#/jobs?repo=try&revision=43e3f7c6e819
With patch: https://treeherder.mozilla.org/#/jobs?repo=try&revision=eb5bd660f68b

The failures happen both with and without my patches, so it looks like it's not my fault.
Assignee

Comment 26

4 years ago
Posted patch uplift patchSplinter Review
NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): unknown
User impact if declined: black flickering on the homescreen when a panel is hidden, performance problems during some animations
Testing completed: has been baking on b2g 3.0 for a few weeks
Risk to taking this patch (and alternatives if risky): moderate
String or UUID changes made by this patch: none

Instead of landing this squashed patch, whoever does the landing can just lift revisions 20513ceb061a to b6553e05d836 from the try repo in order to preserve the original commit messages and patch separations.
Attachment #8587422 - Flags: approval-mozilla-b2g37?
Flags: needinfo?(bbajaj)
Flags: needinfo?(bbajaj)
Keywords: verifyme
Attachment #8587422 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/30bec84bb1a9
Assignee: nobody → mstange
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: in-testsuite+
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S9 (3apr)

Comment 28

4 years ago
This issue has been verified successfully on Flame 2.2,
STR: 
1. Long press an app/collection.
2. Delete one of them.
**You can see the app/collection can be deleted, and the screen doesn't flicker.
See verified video: "Verify.mp4".
Repro Rate: 0/10

Flame 2.2 build(pass):
Build ID               20150406002503
Gaia Revision          a6351e1197d54f8624523c2db9ba1418f2aa046f
Gaia Date              2015-04-03 22:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c3335a5d3063
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.040047
Firmware Date          Mon Apr  6 04:00:58 EDT 2015
Bootloader             L1TC000118D0

Updated

4 years ago
Status: RESOLVED → VERIFIED

Updated

4 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.