After changing font, can't close prefs

VERIFIED FIXED in mozilla0.9.7

Status

P1
normal
VERIFIED FIXED
17 years ago
7 years ago

People

(Reporter: askwar, Assigned: samir_bugzilla)

Tracking

({regression})

Trunk
mozilla0.9.7
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Using build 2001121106 on Linux.

When I change a font in the preferences and click on the Ok button, the
preferences do not close.  Instead I have to click on Ok, followed by Cancel to
make sure that the prefs are stored and to close the preferences dialog.

Comment 1

17 years ago
saw this yesterday too. Don't even have to change any prefs: selecting the font
pane is enough: Once selected, OK button doesn't work.

Added comment about this and the js warnings in
http://bugzilla.mozilla.org/show_bug.cgi?id=108939#c35

Resolving as new, regression keyw.
Keywords: regression

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

17 years ago
Ah, yes, I thought that I read the bug already somewhere.

However, I do not get any output on the xterm.  I started mozilla with:
"~/mozilla/mozilla".

Comment 3

17 years ago
*** Bug 114669 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

17 years ago
Hmm, thinking about it... Does anyone think that Bug 114640 might be related to
this?
(Assignee)

Comment 5

17 years ago
Created attachment 61360 [details] [diff] [review]
Add back one line of code whose removal caused this regression.
(Assignee)

Comment 6

17 years ago
morse, please r.
blake, please sr.

I'd really like to get this in for mozilla0.9.7.  Previous regressions in
mozilla0.9.6 of similar nature caused a barage of bugmail and I'd like to save
us all the energy this time around.  
Status: NEW → ASSIGNED
Keywords: patch, review
Priority: -- → P1
Target Milestone: --- → mozilla0.9.7
(Assignee)

Updated

17 years ago
Keywords: mozilla0.9.7, nsbeta1

Comment 7

17 years ago
Hold on...I added that typeof() line originally, but only because I couldn't 
figure out what was going on. It's bogus. I have a better idea now.
(Assignee)

Updated

17 years ago
Attachment #61360 - Attachment is obsolete: true

Comment 8

17 years ago
Comment on attachment 61360 [details] [diff] [review]
Add back one line of code whose removal caused this regression.

r=morse
If Blake has a better idea, then let's hear it.  Otherwise this should go in as
is for 0.9.7.
Attachment #61360 - Flags: review+
(Assignee)

Comment 9

17 years ago
OK, then over to Blake.  Please fix this in mozilla0.9.7.  If you can't get to
it then please sr this patch ((61360) which I've marked obsolete for now) so I
can check it into mozilla0.9.7 to prevent the plentitude of bugmail.  Thanks.  

Steve, thanks for the review.
Assignee: sgehani → blakeross
Status: ASSIGNED → NEW
(Assignee)

Updated

17 years ago
Keywords: patch, review

Comment 10

17 years ago
I meant "I have a better idea of what's going on".  But, in fact, this patch 
may be just fine.  The problem is that the fonts panel has a GetFields function 
which adds additional attributes to the data object, and it's confusing us 
because we're treating them as elements.
Keywords: patch, review
(Assignee)

Comment 11

17 years ago
Blake,
Cool, so could you gimme an sr then?  Thanks.
Assignee: blakeross → sgehani
(Assignee)

Updated

17 years ago
Attachment #61360 - Attachment is obsolete: false

Comment 12

17 years ago
Comment on attachment 61360 [details] [diff] [review]
Add back one line of code whose removal caused this regression.

sr=blake, sorry for delay
Attachment #61360 - Flags: superreview+
(Assignee)

Comment 13

17 years ago
Checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 14

17 years ago
*** Bug 114871 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 15

17 years ago
With 2001121208 on Linux, this bug (and also bug 114640) is fixed.
no longer a problem. vrfy'd fixed using 2002.01.07.0x comm bits on linux rh7.2,
winnt and mac 10.1.2.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.