Closed Bug 1146657 Opened 5 years ago Closed 5 years ago

Load non-File-backed Blobs passed into `mgmt.install()` into a temporary File-based Blob before installing

Categories

(Firefox OS Graveyard :: Gaia, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1150160

People

(Reporter: drs, Assigned: fabrice)

References

Details

(Whiteboard: [spark])

In bug 1123846, we discovered that we need DeviceStorage permissions unlocked for all apps in order for the Customizer to be able to generate add-ons for them.

This API is actually needed for a workaround [1], since Blobs must be backed by the File interface in order for the `mgmt` API to install them. Perhaps we could just fix this interface instead.

[1] https://dxr.mozilla.org/mozilla-central/source/dom/apps/ImportExport.jsm#249
Fabrice, can you take this? Would it be better to just fix the workaround, or unlock the permission?
Flags: needinfo?(fabrice)
Fabrice and I talked over IRC. We're going to go ahead and fix the platform workaround in comment 0 reference [1], rather than unlocking DS.
Assignee: nobody → fabrice
Summary: Unlock DeviceStorage permissions for all apps → Load non-File-backed Blobs passed into `mgmt.install()` into a temporary File-based Blob before installing
Flags: needinfo?(fabrice)
Depends on: 1149175
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150160
Whiteboard: [lightsaber] → [ignite]
Whiteboard: [ignite] → [spark]
You need to log in before you can comment on or make changes to this bug.