Last Comment Bug 1146761 - clicking on a date/flag/etc should scroll to the corresponding change
: clicking on a date/flag/etc should scroll to the corresponding change
Status: RESOLVED FIXED
:
Product: bugzilla.mozilla.org
Classification: Other
Component: User Interface: Modal (show other bugs)
: Production
: x86 Mac OS X
-- normal (vote)
: ---
Assigned To: Byron Jones ‹:glob›
:
:
Mentors:
: 1164737 1181900 (view as bug list)
Depends on:
Blocks: 1150541
  Show dependency treegraph
 
Reported: 2015-03-23 22:12 PDT by Byron Jones ‹:glob›
Modified: 2015-08-10 08:24 PDT (History)
3 users (show)
See Also:
Due Date:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
1146761_1.patch (12.73 KB, patch)
2015-08-03 00:47 PDT, Byron Jones ‹:glob›
dylan: review-
Details | Diff | Splinter Review
1146761_2.patch (14.07 KB, patch)
2015-08-07 00:19 PDT, Byron Jones ‹:glob›
dylan: review+
Details | Diff | Splinter Review

Description User image Byron Jones ‹:glob› 2015-03-23 22:12:52 PDT
clicking on a date/flag should scroll to the corresponding change.

eg. clicking on a review flag should scroll you to the comment/change that added that item.
Comment 1 User image Byron Jones ‹:glob› 2015-05-13 21:24:46 PDT
*** Bug 1164737 has been marked as a duplicate of this bug. ***
Comment 2 User image Byron Jones ‹:glob› 2015-07-08 20:17:31 PDT
*** Bug 1181900 has been marked as a duplicate of this bug. ***
Comment 3 User image Byron Jones ‹:glob› 2015-08-03 00:47:35 PDT
Created attachment 8642272 [details] [diff] [review]
1146761_1.patch

- adds necessary information to the activity stream to enable finding attachments and flags
- hook into ui to match inlinehistory
Comment 4 User image Dylan Hardison [:dylan] 2015-08-05 11:35:08 PDT
Comment on attachment 8642272 [details] [diff] [review]
1146761_1.patch

Review of attachment 8642272 [details] [diff] [review]:
-----------------------------------------------------------------

Hmm, when I set a review? or needinfo? on an existing bug (without a comment) it always links back to #c0 rather than to the activity item that made the change.

r-
Comment 5 User image Byron Jones ‹:glob› 2015-08-07 00:19:57 PDT
Created attachment 8644819 [details] [diff] [review]
1146761_2.patch

*facepalm*
Comment 6 User image Dylan Hardison [:dylan] 2015-08-10 08:08:02 PDT
Comment on attachment 8644819 [details] [diff] [review]
1146761_2.patch

Review of attachment 8644819 [details] [diff] [review]:
-----------------------------------------------------------------

r=dylan

I've wanted this feature approximately forever.
Comment 7 User image Byron Jones ‹:glob› 2015-08-10 08:24:47 PDT
To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   7e41532..44cd792  master -> master

Note You need to log in before you can comment on or make changes to this bug.