Closed Bug 1146883 Opened 5 years ago Closed 5 years ago

nightly crashes when deleting quoted html elements in a gmail reply

Categories

(Core :: Editor, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla39
Tracking Status
firefox36 - wontfix
firefox37 + verified
firefox38 + verified
firefox39 + verified

People

(Reporter: bkelly, Assigned: ehsan)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file, 1 obsolete file)

I was trying to reply to the original message in this thread today via gmail:

  https://groups.google.com/a/chromium.org/forum/#!topic/blink-dev/35_QSL1ABTY

(I was looking at an email, though, not the google group.)

I was trying to trim away excess quote content when the browser crashed.  It seems trying to delete the html elements in the quote triggered the problem.

Here's the ID from about:crashes, but it doesn't seem to be available to view in crash-stats yet:

  8ef32064-eb9a-43a9-a1af-7c54d50f5753

Without the stack I'm not sure what component to put this in yet.
I guess the crash ID is invalid.

If anyone wants to investigate, let me know and I'll forward the email in question to you.
Can you reproduce reliably?  If so, want to just reproduce in a debug build?
Ok.  Not sure when I will have to do this.  Might not be today.
Flags: needinfo?(bkelly)
Or, I could finally see the dialog box that says "submit crash report" and click ok.

https://crash-stats.mozilla.com/report/index/4faa5c27-5a36-404c-b9ca-7cdb12150324
Flags: needinfo?(bkelly)
Flags: needinfo?(ehsan)
More context:

I first tried selecting a large block of the quote to delete in bulk, but the selection kept getting lost.  So I fell back to just holding the backspace key down for a really long time.  I guess I deleted an important character because that's when the nightly windows went away.
It seems like bug 1088054 accidentally removed a null check here: <http://hg.mozilla.org/mozilla-central/rev/4c792bf9bc28#l2.53>
Assignee: nobody → ehsan
Blocks: 1088054
Component: General → Editor
Flags: needinfo?(ehsan)
[Tracking Requested - why for this release]:
This is a regression from bug 1088054 which was landed in the 36 cycle.
Attachment #8582468 - Flags: review?(roc)
This seems to be the #15 top crashes in 36.0.4. :(

https://crash-stats.mozilla.com/topcrasher/products/Firefox/versions/36.0.4?days=7

KaiRo, how can I know how serious this crash is?
Flags: needinfo?(kairo)
Err, this patch actually compiles!
Attachment #8582468 - Attachment is obsolete: true
Attachment #8582468 - Flags: review?(roc)
Attachment #8582502 - Flags: review?(roc)
All I know is what you posted already, that it's #15 on 36.0.4 with ~0.6% of all crashes, which isn't too much in volume. That said, it seems to not exist in 35 or older versions. Also, on pre-release channels it's not in the top 30.
Crash Signature: [@ nsINode::GetAsText() ]
Flags: needinfo?(kairo)
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #11)
> All I know is what you posted already, that it's #15 on 36.0.4 with ~0.6% of
> all crashes, which isn't too much in volume. That said, it seems to not
> exist in 35 or older versions. Also, on pre-release channels it's not in the
> top 30.

Yeah that completely matches with bug 1088054 having regressed it.  Thanks!
Comment on attachment 8582502 [details] [diff] [review]
Null check the node passed to GetGoodSelPointForNode

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 1088054
User impact if declined: This causes crashes in websites as as webmail or blog editing software.
Testing completed: Locally
Risk to taking this patch (and alternatives if risky): This is essentially risk free, as the fix is a simple null check that takes us to the behavior we had prior to bug 1088054.
String or UUID changes made by this patch: None.

Approval Request Comment
[Feature/regressing bug #]: Not going to repeat the same thing twice.  :-)
[User impact if declined]:
[Describe test coverage new/current, TreeHerder]:
[Risks and why]: 
[String/UUID change made/needed]:
Attachment #8582502 - Flags: approval-mozilla-release?
Attachment #8582502 - Flags: approval-mozilla-beta?
Attachment #8582502 - Flags: approval-mozilla-b2g37?
Attachment #8582502 - Flags: approval-mozilla-aurora?
Attachment #8582502 - Flags: review?(roc) → review+
Tracking this crash that is close to the top of the top crash list for 36.
Comment on attachment 8582502 [details] [diff] [review]
Null check the node passed to GetGoodSelPointForNode

We're going to take this very simple crash fix in 37 RC. I am clearing the b2g37 nom as this will be automerged to that branch. I am also marking release- as we're not going to do another point release for 36. Beta+ Aurora+
Attachment #8582502 - Flags: approval-mozilla-release?
Attachment #8582502 - Flags: approval-mozilla-release-
Attachment #8582502 - Flags: approval-mozilla-beta?
Attachment #8582502 - Flags: approval-mozilla-beta+
Attachment #8582502 - Flags: approval-mozilla-b2g37?
Attachment #8582502 - Flags: approval-mozilla-aurora?
Attachment #8582502 - Flags: approval-mozilla-aurora+
Keywords: crash
Flags: qe-verify+
https://hg.mozilla.org/mozilla-central/rev/a5cee922ae79
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
Duplicate of this bug: 1147773
Depends on: 1148069
No longer depends on: 1148069
Reproduced the initial crash and verified it as fixed using Firefox 37 RC build, Firefox 38 beta 1 and Developer Edition 39.0a2 2015-03-30 (64-bit) under Win 7 64-bit and Mac OS X 10.9.5.

The crash-stats shows only 2 crashes after the fix landed, both for 38.0a2 version, so I'm marking this version as verified yet. It will be checked later in the cycle.
Status: RESOLVED → VERIFIED
(In reply to Petruta Rasa [QA] [:petruta] from comment #23)
> Robert, should we file a new bug for that ones?

Looks like the stacks are different, so probably a new bug. That said, looks like the volume of those is not that huge for now.
Can you please file a bug for this and CC me on it?
Flags: needinfo?(petruta.rasa)
Logged bug 1158837.
Depends on: 1158837
Flags: needinfo?(petruta.rasa)
You need to log in before you can comment on or make changes to this bug.