Firefox deletes blocked downloads

RESOLVED DUPLICATE of bug 1137909

Status

()

RESOLVED DUPLICATE of bug 1137909
4 years ago
4 years ago

People

(Reporter: grumbel, Unassigned)

Tracking

36 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150306140302

Steps to reproduce:

1. Download a file
2. Trigger "Blocked: May contain a virus or spyware"



Actual results:

The blocked file got deleted without prior warnings and with no way of recovery.


Expected results:

The file should have been put in quarantine and the user should have the option to recover it. Firefox destroying downloaded files is really not unacceptable.

Comment 1

4 years ago
(In reply to Ingo Ruhnke from comment #0)
> Steps to reproduce:
> 1. Download a file
> 2. Trigger "Blocked: May contain a virus or spyware"

Any specific example to trigger this, as I have never seen such a warning?
Exact steps to reproduce are welcome. :)
Flags: needinfo?(grumbel)
(Reporter)

Comment 2

4 years ago
It's a new "feature", see:

http://www.ghacks.net/2014/11/19/bypass-firefoxs-blocked-may-contain-a-virus-or-spyware-message/
Flags: needinfo?(grumbel)

Comment 3

4 years ago
Please answer my questions in comment 1 by providing steps to reproduce.
Flags: needinfo?(grumbel)
(Reporter)

Comment 4

4 years ago
I already gave steps to reproduce:

1. Download a file that triggers "Blocked: May contain a virus or spyware" (specific URL doesn't matter)
2. See Firefox delete the file with no question or ways to recover it

The problem here is 2., not 1.

False positives happen, I don't mind that. However I do expect Firefox to allow me to recover the file instead of just outright deleting it.
Flags: needinfo?(grumbel)
(Reporter)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1147845

Comment 6

4 years ago
> I already gave steps to reproduce:

You did, but they were incomplete, as I asked for a "specific example to trigger this" and there's still no URL. But bug 1147845 has one.

Comment 7

4 years ago
This bug is similar to bug 1139564, the fix for which was only backported to Firefox 38 thus far. However, bug 1147845 is about regression between v1 and v2 of the implementation but doesn't affect Tier1 platforms like Linux.
Duplicate of bug: 1137909
You need to log in before you can comment on or make changes to this bug.