Closed Bug 1147944 Opened 5 years ago Closed 5 years ago

[SIM PIN] Input gets disabled with 2 SIMS, after entering the right PIN on the first one

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S9 (3apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: apastor, Assigned: apastor)

References

Details

(Whiteboard: [systemsfe])

Attachments

(3 files)

STR:

1.- Insert 2 PIN enabled SIMs
2.- Start the phone
3.- Enter the right PIN on the first one

Expected:

The input is enabled in the 2nd PIN screen

Actual:

The input is disabled in the 2nd PIN screen
Blocks: 1139308
Blocker of a blocker
blocking-b2g: --- → 2.2?
Assignee: nobody → apastor
Comment on attachment 8583892 [details] [review]
[gaia] albertopq:1147944-sim2-disabled > mozilla-b2g:master

Just found a regression of bug 1139308. We need to clear the input after a succeed unlock.
Attachment #8583892 - Flags: review?(alive)
blocking-b2g: 2.2? → 2.2+
Whiteboard: [systemsfs] → [systemsfe]
Comment on attachment 8583892 [details] [review]
[gaia] albertopq:1147944-sim2-disabled > mozilla-b2g:master

It's not bad, but my question is can't us clear in the init/show function when second SIM PIN prompt is requested?
Attachment #8583892 - Flags: review?(alive) → review+
I was following the same path that was implemented before the change (we were clearing after verifying) but makes perfectly sense. I already change it. Thanks!
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8583892 [details] [review]
[gaia] albertopq:1147944-sim2-disabled > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1139308
[User impact] if declined: User can not enter the PIN on a second SIM
[Testing completed]: Added unit tests
[Risk to taking this patch] (and alternatives if risky): Low risk patch. Adding a missing method that was forgotten on bug 1139308.
[String changes made]: none
Attachment #8583892 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8583892 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Target Milestone: --- → 2.2 S9 (3apr)
Duplicate of this bug: 1147326
Per Comment 6,it has fixed on Flame v3.0.

According to the STR of Comment 0,this bug has been successfully verified on latest Nightly Flame v3.0.
See attachment: verified_v3.0.mp4.
Reproduce rate: 0/5

Device: Flame 3.0 build(Unaffected)
Build ID               20150329010203
Gaia Revision          67ad91f3f660b1f16b354ee4c5159ddc5a74d149
Gaia Date              2015-03-28 10:02:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/385840329d91
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150329.042104
Firmware Date          Sun Mar 29 04:21:16 EDT 2015
Bootloader             L1TC000118D0
According to the STR of Comment 0,this bug has been successfully verified on latest Nightly Flame v2.2.
See attachment: verified_v2.2.mp4.
Reproduce rate: 0/5

Actual results:Insert 2 SIM cards with PIN codes, the 2nd PIN input box is enabled and displays normally after entering the right PIN on the first one.

Device: Flame 2.2 build(Pass)
Build ID               20150331162505
Gaia Revision          8b3086ad3963f1707e2bee9094baccafffe161c4
Gaia Date              2015-03-31 21:48:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/88e0e00cd64e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150331.200333
Firmware Date          Tue Mar 31 20:03:44 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.